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CLASS: XII   VOLUME –I   STAR OFFICE 

STAR WRITER 

*1. What is mean by Text editing? 

 Entering a new text or modifying the existing text in a document is known as 

text editing. The insertion point always indicates where the new text will appear. If a 

mistake is identified it can be corrected using either Backspace key or delete key. 

 

2. List the functions of Star office. 

 Star office consists of several applications which are grouped together into an 

integrated environment, their functions are 

Create Text document using Star Office writer 

Create Spreadsheet using Star Office Calc 

Create Presentations using Star Office Impress. 

Draw using Star Office Draw 

Create a database using Star Office Base 

*3. Define Word processor. 

  Star office writer is a word processor. The term word processing refers to the 

activity carried out using a computer and suitable software to create, view, edit, 

manipulate, transmit, store, retrieve and print documents. 

 Some of the commonly used word processors are MS Word, Lotus AmiPro, 

Word Perfect, Word Star, Word Pro. 

 

**4. List the selection shortcuts. 

 Double click on a word  - To select a word 

 Click once next to the line  - To select the particular line 

 Press Ctrl + A    - To select the entire document 

*5. How to correct mistakes in a document? 

 A mistake can be corrected either using the Backspace key or Delete key. 

Backspace key deletes the characters to the left of the insertion point. Delete key deletes 

the characters to the right of the insertion point. 

 

6. How can we switch between multiple documents? 

• Using Windows menu 

• Clicking the button visible on the taskbar 

• Pressing Alt + Tab 

 

7. What is end of document marker? 

          The thick horizontal line in the page area is called the end-of document marker. 

The insertion point cannot move beyond this line. 

 

*8. How to insert text in a document? 
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 The user is in the type-over mode, if the existing text to the right of Insertion 

point disappears, while typing a new text. The user can toggle between type-over mode  

and Insert mode by using the Insert key. The status bar gives the information about the 

current mode (Insert or Type-over mode). 

 

9. How to select text with keyboard? 

• Insertion point is moved to the start of the text to be selected. 

• The shift key is pressed down and the movement keys are used to highlight the 

required text. 

• When the shift key is released, the text is selected. 

 

*10. How to move & copy the text in a document? 

 To copy the text  Edit - > Copy     /    Ctrl + C 

 To Move the text Edit - > Cut        /   Ctrl + X 

 To paste the text Edit - > Paste    /   Ctrl + V 

*11. How to use highlighting the text feature? 

 Highlighting can be used to call attention to key ideas or pointers in a document. 

The highlighted section used to review or find the key points in the document. To 

highlight the selected text, The Highlighting icon is selected, and the needed colour is 

clicked. To remove the Highlighting, Select the text and select the No Fill from the 

colour palette. 

 

12. Differentiate hard return and Soft return. 

 A paragraph is any text followed by a hard Return. A hard return is inserted every 

time when enter is pressed. Soft returns are inserted as line breaks by star office writer 

and are adjusted when text is added or deleted. 

 

*13. List the paragraph alignments. 

 The keyboard shortcuts are, 

 Left   - Ctrl + L 

 Right   - Ctrl + R 

 Center  - Ctrl + E 

 Justify  - Ctrl + J 

**14. Define Hanging indent. 

 A special kind of indent, called a hanging indent used for numbered lists. The 

First Line option can be used to indent the line of the paragraph. Using the spin arrows, 

if a positive value is specified, the first line will be indented. A negative value will result 

in a hanging indent; that is the first line will hang outside the paragraph. 

 

15. How to modify Line spacing in a document? 

 By default, Star Office writer single spaces the text in the document. The spacing 

works well for different types of documents with different spacing values. The line 
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spacing options are Single Line, 1.5 lines, Double, Proportional, Atleast, Leading and 

Fixed. 

 

*16. How would you create the Bullets and Numbered list? 

 Bullets and Numbers are used to list the important points and messages. Star office 

writer automatically numbers all the items in a list, and the text is indented. Star office 

writer provide various styles for the bullets and numbers, which can be selected using 

Format - > Bullets and Numbering. 

 

17. How would you use the features of Star Office help? 

 Star office provides several help systems that you can use while you work 

a. Online help   b. Help Agent  c. Help tips   

d. Extended Help Tips – Shift + F1 

To access the star office help, Help - > Star Office Help where you can search for a help 

topic. 

*18. What does Automatic Spelling Correction mean? 

 When Auto Spell check feature is ON, Star Office Writer compares each word 

typed with the words in the dictionary and underline words that do not match with a red 

squiggly line. 

To do spell check after the entire document is typed, Tools - > Spelling - > Check   / F7 

 

*19. What is the use of Auto Correct feature? 

Star Office writer recognizes some common misspellings and typographical 

mistakes and make the replacement automatically. To add the error and its correction to 

the autocorrect list,  

Choose Tools - > AutoCorrect 

*20. How will you create a table in the document? 

  To create a simple default style table,    Table - > Insert - > Table is selected from 

the menu bar. 

 In the Insert Table dialog box using the spin arrows in the Columns and Rows text 

box the required number of Rows and Columns are entered. 

 

*21. How will you add a required number of rows and columns in a table? 

 To insert more than one row or column in the table, Table - > Insert - > Table or 

Table - > Insert - > Column command is used. A cell is the intersection of rows and 

columns. Press Tab key to move forward through the cells or Shift + Tab to move 

backward through the cells. 

 

**22. How to change the width of the column in a table? 

To resize a column, place the cursor in a table cell, hold Alt key and press left or right 

arrows. 

To resize a column without affecting width of the table, hold Alt + Ctrl key and press 

left or right arrows. 

To resize a Row, place the cursor in the row, hold Alt key and press left or right arrows. 
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 If Table  - > Table Properties command is used we would get a Table format 

dialog box. To change the column width, choose the Columns Tab and type Column 

size in the Column width spin boxes and Click Ok 

 

**23. How to make the selected Rows and Columns of Same size?  

 To make all columns even, right click inside the table and select  

Column - > Space Equally in the pop up menu. 

 To make all rows even, Right click inside the table and select  

Row - > Space Equally in the pop up menu. 

 

24. What does page formatting mean? 

  Margins control how close Star Office writer prints to the edge of the page. Margins can 

be changed using,  

• Page style dialog box ( Format - > Page ) 

• Changing margins using rulers. ( View - > Ruler )  

The default margins are 1 inch Top & Bottom margins and 1.25 inches Left & 

Right margins. 

  

**25. What are the two types of page orientations? 

Usually the length of the document will be more than the width, this orientation is 

called Portrait. 

In some documents the width will be more than the length; this type of orientation is 

called Landscape. 

The default orientation is Portrait. 

To change the orientation, Choose Format - > Page, in Page style dialog box choose 

Portrait or Landscape radio buttons. 

 

**26. How can the ruler be used to change the margins? 

 If the Ruler is not displayed in the screen, View - > Ruler option is clicked. The 

grey area of the ruler indicates the margins top area. The mouse pointer is moved in 

between the grey and white area, it shows the margin guide a line with arrows on both 

sides, which helps to drag it to a new location. 

 

**27. What is meant by Header & Footer? 

 Header is an area at the top of the page, to add information like Name,  

Title, Author etc. 

 Footer is an area at the bottom of the page to add information’s like  

Page Number, date etc., 

 To add Header & Footer Choose Header & Footer tabs in page style dialog box 

and select the Header on / Footer on Check boxes.  

  

**28. How to add page numbers in a document? 

 To insert page numbers on every page, Insert - > Fields - > Page number. 
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 To change the format of the page number use the Format combo box in Page style 

dialog box to choose from the list of styles like 1,2,3…a,b,c..,i,ii,iii,…  

       

STAR CALC 

*1. What is an Electronic Spreadsheet? 

 An electronic spreadsheet is a worksheet used in a computer to create and quickly 

perform “What if” analysis of interrelated columnar data in workspaces. 

 Spreadsheets are made up of Rows and Columns like a grid of cells with a 

programmable calculator attached to each cell. The intersection of Rows and Columns 

creates cells. Visicalc “The Visible Calculator” was the first electronic spreadsheet. 

 

**2. List the spreadsheet applications 

 A spreadsheet specifically refers the software package, while ’Worksheet’ refers 

to the files that you can create using Spreadsheet software.  

• Payment of Bills 

• Income Tax Calculations 

• Invoices or Bills 

• Account Statements 

• Inventory control 

• Cost-Benefit Analysis 

• Financial Accounting 

• Tender Evaluation 

• Result Analysis of students 

*3. List the advantages of using Electronic Spreadsheet. 

• Calculations are automated through the built-in mathematical, financial and 

statistical functions 

• Accurate results to any desired level of decimal points are possible 

• Worksheets can be quite big in size 

• Any part of the worksheet can be viewed or edited 

• Worksheet can be saved and retrieve later 

• Any part or whole of an existing worksheet can be merged with any existing or 

new worksheet. 

• Any part or whole of the worksheet can be printed in a desired manner. 

• Worksheet data can be viewed in the form of graphs or charts 

• The worksheet information can be transferred to any database or word 

processing software 

*4. List popular spreadsheet packages. 

 VisiCalc was the first commercial spreadsheet package developed by 

Microcomputers in 1979. It has 63 columns and 254 rows.  

Lotus Development Corporation introduced Lotus 1-2-3 in 1982. 

Ms Excel – Microsoft Corporation 
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Quattropro – Borland International 

Improve – Lotus Corporation 

Star Office Calc – Sun Microsystems. 

**5. How to enter data’s like date & Time in worksheet? 

 Place the cursor in the cell where you want to enter the data and type it in as 

MM/DD/YY. You can enter the time in the worksheet by typing it as HH:MM:SS 

 

6. List the process involved in creating worksheet. 

 Creating a worksheet is a process that involves several steps like organizing the 

data, entering the data, creating formulae, editing the worksheet, formatting the 

values, labels and cells, adding charts if required, analyzing the data and printing 

the worksheet 

 

**7. Can we change the data present in a cell? How? 

 Type in the new data. The new data will simply overwrite the old contents  

of the cell 

 Click on the formula bar with the mouse, press the F2 function key or simple 

double click the contents of the cell. A vertical cursor appears on the formula bar. Move 

the cursor using the arrow keys or the backspace key and edit the data. 

 

*8. Write a note on Text operators in Star calc. 

 The operator combines sections of text to the entire text 

Operator   Name      Example 

& AND  Text Operator : AND  “Star” & “Office” yields StarOffice 

***9. Write a note on Text operators in Star calc. 

 These operators combine areas. 

Operator   Name      Example 

 : Colon   Range      A1 : C108 

 ! Exclamation Point Intersection           SUM ( A1:B6!B5:C12) 

 

**10. Write the rules of precedence. 

 When arithmetic operators are used in Star office calc calculates the results sing the 

rules of precedence, 

• Exponentiation (^) 

• Negation (-) 

• Multiplication and division (* , /) 

• Addition and Subtraction (+, -) 

  

***11. Different types of cell referencing. 

 Relative cell addressing is the default type of cell addressing used by star office 

calc, it helps to recalculate the formula automatically every time the contents of the 

cells used in formula change. A cell address can be made absolute by using the $ sign in 

front of row and column names. Absolute cell address does not change when copied. 

www.Padasalai.Net                                                   www.TrbTnpsc.com

http://www.trbtnpsc.com/2013/07/latest-12th-study-materials-2013.html



Prepared By : T.P.DURAI SAMY M.C.A., M.Sc (IT).,B.Ed., 

PLATO’S ACADEMY MHSS, TIRUPPUR 

Feel free to contact @9952207071, dooldurai@gmail.com 

 

Ex- C4 becomes absolute when you enter it as $C$4 

 

**12. List the use of Fill command. 

 A continuous group of cells in a worksheet is called range. Fill command is used to 

generate a series of data from the values of the selected cells. Choose the command 

Edit-Fill-Series Then select Direction, Type and increment value and click the OK 

button the values in the subsequent cells of column will be automatically generated. 

 

**13. List the use of functions in Star office calc. 

 Functions are predefined formula that is available in star office calc. To insert 

 Function Insert->Function. f(x) The Function wizard shortcut icon on the formula bar 

can also be used to select and insert functions. ∑ one of the most commonly used 

function is the sum function.  

 

***14. What is the use of date arithmetic? 

 In spreadsheet we can add and find the difference between two dates by using a 

wide variety of functions and formats. To add two date, enter 03/04/05 in cell A1 and 

type the formula, =A1+79 gives the result 05/22/05 adding 72 days with it. 

 To find the difference between two dates, enter the two dates 05/10/05  and 

12/08/70 in two different cells. In a third cell enter the formula = first cell – Second cell. 

The result will be displayed as 12572  

    

15. What is the use of Auto format Sheet in Star calc? 

 The auto format sheet facility of Star office calc helps to format worksheet with 

different predefined styles and colours. To format the worksheet click on the Autoformat 

option on the Format menu. 

 

**16. How to insert objects in star calc? 

 Star office calc provides tools for inserting objects like charts, images from image 

editor, formula etc,   click on the Insert object from View-> Toolbar and the available 

icons, Insert Chart icon, Insert Formula icon, Insert Floating Frame icon, Insert 

Movie and Sound icon, Insert OLE object icon, Insert Applet icon. 

 

*17. How to use 3-D formula in star calc? 

 To calculate the numbers in the cell A1 of Sheet 1 and A1 of Sheet 2 and store the 

result in A3 of sheet 2 , to do this type the 3-D formula =sum(Sheet 1.A1;Sheet2.A1) 

 

STAR BASE 

***1. Define Data & Information 

                         The term data comes from the word datum, data is simply the value assigned 

to a variable. The data types can be Character, number or Boolean. The 

programming languages provide their own built-in or primitive data types such as 

integer and float. Users can create their own data types known as user-defined data 

types. 
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  Information is defined as a set of processed data to do some operations or 

computations on the data of different variables to relate operations. 

 

**2. Differentiate Manual and Computerized data processing. 

The work carried out by long hand effort / manual is known as manual data 

processing. Instead of manual approach if we use a computer to create the data, 

store, process and print the data, we will call this type as computerized data 

processing. 

 

***3. Define database. 

A database is a repository of collections of related data or facts gets arranged 

in a specific structure. The entire collection or related data in one table is referred to 

as a file or a Table. Each row in a table represents a Record, which is a set of data 

for each database entry. Each table column represents a field, which groups each 

item among the records. 

 

    *** 4. List the database manipulation techniques 

  To manipulate the database in one or more ways, 

Searching, Sorting, Merging, Performing calculations on data, Filtering, 

Editing the database, Report Generation 

   

    5. List the types of database 

  Based on the conceptual structures, the database can be classified as follows, 

 Flat-file database, Relational database, Hierarchical database, Network 

database, Object oriented database 

 

***6. Define Primary key. 

 The common fields are called as keys. A primary key is a key that uniquely 

identifies a record in a database table. In Relational database, a primary key 

consists of one or more fields. 

 

*7. Define object in database.   

The object oriented structure groups data items and their associated 

characteristics, attributes and procedures into complex items called objects.  

 

***8. Define DBMS. 

  A DBMS is a program, a collection of programs that allows any number of 

users to access data, modify it , and construct simple and complex requests to 

obtain and work with selected records. The biggest asset of the DBMS is its ability 

to provide extremely quick access and retrieval from large database. The data 

management tasks in DBMS fall into three categories, 

• Entering data into the database 

• Reordering records in the database 

• Obtaining subsets of the data 
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***9. Define SQL 

 DBMS supports a language that is similar to a programming language called 

as Structured Query Language(SQL), is designed specifically for communicating 

with a database using statements.  

 

**10. Define Filter 

 A filter is also a type of query. It is also used to select and display records, 

which match a certain condition. The difference between a query and filter is 

queries can be saved for later use. The two types of filter are Auto filter & 

Standard Filter 

 

*11. Define Report 

 A report is printed information that is assembled by gathering data based 

on user supplied criteria. Reports can range from simple list of records to 

customized formats fro specific purpose. The two types of Report are Static & 

Dynamic Report 

 

12. Define multiple sorting 

 Multiple sorting means sorting on more than one field of a table at the same 

time. Star base helps to rearrange the record using Sort icon which opens Sort 

order dialog box. Records can be sorted using Sort Ascending, Sort Descending  

 

MULTIMEDIA 

***1. Define Multimedia. 

 Multimedia is a computer based presentation technique that incorporates text, 

graphics, sound, animation and video elements. A combination of these elements 

grabs the viewer’s attention. Multimedia is commonly used in entertainment, 

education, and research and business communications.  

Ex: multimedia software’s are Flash, Dream weaver & Maya  

 

***2. Define CBT/WBT 

 With the growing popularity of multimedia, sophisticated e-learning 

packages are used to train and educate people such as Computer based 

tutorials(CBT), Web based tutorials(WBT). These are self learning aids that are 

either available on CD-Rom or on the internet. 

 

***3. Define Virtual Reality 

 The various Multimedia components are coordinated with a technique 

called Virtual Reality. They provide an environment which is experienced by 

users as similar to reality. This technique is used in Flight simulators, impart 

training to pilots etc., 

 

***4. Define Sampling 
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 Before including sound in an application, analog sound has to be converted to 

digital format. This conversion of analog signal to digital format is called 

sampling. The quality of sound can be enhanced and special effects such as echo, 

fade in, and fade out through programs such as Sound Forge.   

 

***5. Define Compression and its types. 

 Compression is a technique by which a recurring set of information is 

identified and replaced by a single piece of information. 

• Lossless compression – Retains the exact image throughout the 

compression. Ex-jpg 

• Lossy Compression – Provides a comparatively higher ratio of 

compression but results in some loss of quality ex-GIF (8 bit palette) 

 

 **6. Write the types of animation 

   Animations can be two or three dimensional. Based on how 2-D animation 

are created, they can be broadly classified into two categories, 

• Cell based animation – It consists of multiple drawings, each one a little 

different from the others. When displayed in rapid sequence these drawings 

appear to move 

• Object-based animation – It refer to a slide or path animations, are created 

by moving an object across a screen. This type of animations is usually seen 

in computer games.  

 

 **7. Define Inline sound 

   Sounds and video in multimedia applications can be played “inline” or by 

using a “Helper”. When sound or video is included as a part of webpage, then it 

is called Inline sound or video. The disadvantage of using Inline sound or video is 

that it plays automatically. A helper application allows the viewer to control 

volume settings, rewind, play, and pause and stop the sound or video 

 Helper applications can be launched using the <embed>, <applet>,<object> tags.   

 

 POPULAR MULTIMEDIA FORMATS 

• MIDI – Musical instrument digital interface – 1982 - .mid/.midi 

• REAL AUDIO FORMAT – Real Networks – 1995 - .rm/.ram 

• AU - .au 

• AIFF -  Audio Interchange File Format – Apple - .aif/.aiff 

• SND – Sound format – Apple - .snd 

• WAVE – IBM & Microsoft - .wav 

• MP3/MPEG -Moving picture experts group-Music (.mp3/.mpga) – 

     Video(.mpg /.mpeg)  

• AVI – Audi Video Interleave – Microsoft – 1992 - .avi 

• WMV – Windows media format – Microsoft - .wmv 

•  Quick Time Format – Apple - .mov 
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• Shockwave format – Macromedia(Flash) - .swf(Shockwave Flash object) 

 

 PRESENTATION – IMPRESS 

 **1. List the views in Star office impress 

  Normal view   -  To create and edit slides 

     Outlines View   -  To reorder slides, edit slide titles and heading 

    Notes view   -  To additional information to a slide  

     Handouts view  -  To print the presentation and distribute it as handouts. 

   Slide sorter view  -  To view miniature image of all slides and rearrange them. 

 

 **2. Define a Master page in Star impress. 

   This page can be used to specify basic background information that needs 

to be included in all the slides. For ex,- to insert a company logo to the master 

slide will appear in all the slides. 

 

 ***3. Define Custom Animation 

   All the effects for the objects can be assigned using the Normal view.  

 To choose custom animation, Slide show - > Custom Animation, and select the 

object to which the effect has to be applied. This page displays various options that 

allow you to add or modify animation effects to elements of a slide 

 

 ***4. Define Slide Transition 

    This page displays various transition effects that can be attached to a 

slide along with other options that allow you to control the transition of the slides. 

The easiest way to assign slide transition effects to slides is slide view. Choose 

  View - > Toolbars - > slide view and select the number of slides to be listed. Then 

choose Slideshow - > Slide Transition to apply the transition effects to the slide. 

 

 ***5. How to start a presentation?   To start a presentation click, 

Slideshow icon on the presentation toolbar or choose Slideshow - > Slide show / 

ress F5. The on-screen presentation starts fully in the presentation mode. End the 

presentation by pressing the Esc key. 

   To adjust the presentation settings, choose Slide show - > Slideshow settings 

 

 *6. How to Insert, Delete and Rename a slide? 

   To insert a slide, choose Insert -> slide, the new slide uses the page layout 

of the previous slide 

   To delete a slide, select the slide in the slide pane and press delete key or 

Right click on the slide and choose delete 

   To rename a slide, Choose Slide ->Rename Slide 

 7. How to use Media Playback toolbar?  To open Media player window, 

choose Tools -> Media player where you can preview the sound and video files 

and insert them into the presentation it supports many different media formats. 
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   Play icon – Plays the current file 

   Pause icon – Pause or resume the playback of the current file 

   Stop icon – Stops the playback of the current file 

   Repeat icon – Plays the file repeatedly 

   Position slider – Moves to a different position in the file  

   Mute icon – Turns sound off and on 

   Volume Slider – Adjusts the volume 

   Zoom – Adjusts the size of the movie during video playback 

    

 ***8. How to change a slide background? 

   To change the background colour or the background fill of the current slide 

or all of the slides, choose Format ->Page -> Background  

     Color 

     Gradient 

     Hatching 

     Bitmap image 

   In the “Back ground settings for all pages” box choose yes if we want to 

change the background fill for all the slides or else click NO to change the 

background fill for a single slide    

  

 **9. How to start a custom slideshow? 

   Choose Slide Show -> Custom Slide show 

   Select the slides you want to start from the list and we can rearrange the order 

by dropping it in the required position 

   Then select “Use Custom Slide Show” checkbox to use the settings in 

custom slide show for the slideshow. 

 

 *10. What is the use of Show / Hide slide? 

   Select the slides that has to be hidden in the slide show 

   Choose Slide Show -> Show/Hide Slide 

   To view the hidden slide 

   Choose Slide Show -> Show/Hide Slide   

 

***11. Define Rehearse timings? 

Star office records the display time for each slide through Rehearse timings, 

so the next time while playing the show with automatic slide changes the 

timings will be as recorded 

 Open the presentation in Normal view 

 Choose Slide Show -> Rehearse timings, in the first slide timer will be seen 

in the bottom left corner 

*12. How to use Navigator in Star impress? 

     Using navigator we can move from slide to slide quickly. 

    Choose Edit -> Navigator or by clicking the Navigator icon in the function bar. 

    In slide show double click on a slide title to jump to that slide  
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CLASS: XII    VOLUME –II   C++ 

CHAPTER – 1 OBJECT ORIENTED PROGRAMMING CONCEPTS USING C++ 

***1. Define object 

 An Object is a group of related functions and data that serves those functions. 

An Object is a kind of self-sufficient “Subprogram” with a specific Functional area. 

 

***2. Define Encapsulation. 

 The mechanism by which the data and Functions are bound together within an 

object definition is called as Encapsulation. 

 
***3. Define Polymorphism. 

 The ability of an object to respond differently to different messages is called 

Polymorphism. 

 

*4. List the advantages of Object Oriented programming. 

 Class data type allows programs to organize as objects that contain both data and 

functions. 

 Data hiding or Abstraction of data provides security to data, unrelated member 

functions. 

 Polymorphism reduces software complexity, as multiple definitions are permitted 

to an operator or function. 

 Inheritance allows a class to be derived from an existing class thus promoting 

reusability of code, and also promote insertion of updated modules to meet the 

requirements of the dynamic world. 

 
*4. What is Class? 

 The data type class conventionally represents an object in the real world. Class is a 

template for entities that have common behavior. 
 

***5. What is inheritance? 

 The process of acquiring base class properties is called inheritance. The derived 

classes are power packed, as they include the functionality of the base class along with 
their own unique features. 

 Inheritance increases the functionality of a derived class and also promotes 

reusability  

of code 
 

CHAPTER – 2   OVERVIEW OF C++ 

1. Introduction to c++ 

 C++ was developed by AT & T Bell Laboratories in the early 1980’s by Bjarne 
Stroustrup. Earlier C++ was known as C with Classes and Rick mascitti coined the 

name where “++” is the increment operator. 
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*2. Define Tokens. 

 The basic types are collectively called as Tokens. A token is the smallest individual 

unit in a program.      Tokens  

 

 Keywords  Identifiers  Constants  Operators  Punctuators  

**3. Define keywords 

 Keywords have special meaning to the language compiler. These are reserved 

words for special purpose. These words cannot be used as normal identifiers (as variable 
name) 

 Ex : main, void, include, cout, cin etc., 

 

4. Define Identifiers 

 Identifiers are also called as variables. Variables are memory boxes that hold 

values or constants. A variable name must begin with an alphabet or underscore 

followed by alphabets or numbers. 

 Ex: _test; test; sum12; are valid identifiers 
 

*5. Define a constant. 

 Constants are data items whose values cannot be changed. A constant is a numeric or 

non-numeric type. Numeric constants consist of only numbers, either whole numbers or 

decimal numbers. Integer, floating-point is numeric constants. 

 Integer constant must have at least one digit and must not contain any fractional 

part prefixed with a + or – sign. 

 A sequence of digits starting with 0 is treated as Octal constant 
 A sequence of digits starting with 0X is treated as Hexadecimal constant 

 Floating point constant is a signed real number. It includes an integer portion, a 

decimal portion, a fractional portion and an exponent portion. While representing a floating 

point constant the integer portion or a decimal portion can be omitted but never both. 

 Ex: 58.64 a valid floating point constant  

***6. Define String literal 

 String literal is a sequence of characters surrounded by double quotes. String literals 
are treated as array of characters. Each string literal is by default added by the compiler 

with a special character ‘\0’ which marks the end of a string 

 Ex: “testing” 

***7. What is an operator? 

 Operator specifies an operation to be performed that yields a value. 

  Ex: RESULT = num1 + num2; 

 Here num1 an dnum2 are operands. + is the additional operator, that performs 
the addition of the numbers. The result is stored in the variable RESULT through ‘=’ 

Assignment operator. The operands and the operators are grouped in a special logical way 

for evaluation is called as Association. 
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 Operators are executed in the order of precedence. Based on operand 

requirements operators are also classified as Unary, Binary & Teranary operator  

 
**8. Define character constant 

 Character constant is a constant that contains a single character enclosed within 

single quotes. Some special characters like ‘\t’ , ‘\b’ ,’\n’ , ‘\0’ are called non-graphic 

character constants. These are called as escape sequences prefixed with a backslash. 

 

*9. What is a Relational operator? 

 Relational operators are used to compare numeric values. They are, 

 = = equal to 

 > greater than 

 < lesser than 

 > = greater than or equal to 

 < = lesser than or equal to 

 ! = not equal to 

 A relational expression is constructed using any two operands connected by a 
relational operator which returns (0) if false, and returns (1) if true. 

 

*** 10. Define conditional operator. 

   ( num1 > num2) ? “true” : “else” - ?: is a ternary operator with num1, 

num2, true and false are the operands. A Ternary operator (?:) is also called as 

conditional operator. The general syntax is E1 : E2 : E3 where E1, E2 & E3 are the 

operands. E1 should essentially be of scalar type, E2 and E3 are values or statements 

  
***11. List the punctuators in c++ 

 Punctuators are characters with a specific function 

 ;   - Terminates a C++ statement  

 //  - Treats statements prefixed with this as comments 

 /*    */  - Blocks enclosed within these characters are treated as 

comments 

 {  }  - To group a set of C++ statements 

 [  ]  - To indicate the index value of an element 
 ‘  ‘  - To enclose a single character 

“  “  - To enclose a set of characters  

 

**12. List the data types in c++ 

 Data types are the kind of data that variables hold in a programming language. 
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They are , 

    User Defined 

 Structure 

 Union 

 Class 

 Enumeration 

 

 Built in (Fundamental) 

 Integral – Int & Char 

 Void 

 Float – Float & 

                Double 

       

Derived  

 Array 

 Function 

 Pointer 

 Reference 

**13. What is type definition? 

 Users can define a variable that would represent an existing data type.  

 The Syntax is, 

  typedef   data_type   user_defined_data_type_identifer; 
 Example 

  typedef   int     marks; 

  typedef   char  grade; 

 Now the variables marks and grade are user define identifiers for int and char 

data types respectively. 

  marks eng, tamil; 

  grade eng, mat; 

*14. What is an enumerated data type? 

 Enumerated data type helps users in creating a list of identifiers, also called as 

symbolic numeric constants of the type int. Users can redefine these integer constants by 

assigning their own values to the enum constants 

 The syntax is, 

  enum data type identifier (value1, value2,…value n); 

 Example; 

  enum holidays(Sunday, Saturday); 

***15. What is a storage class? 

 Storage class is another modifier like long or unsigned that can be added to a 

variable declaration. The four storage specifiers are,  

    Auto – By default local variable or auto known to the block in which they are defined 

    Static – It allows the variable to exist in memory even after the function or block looses 

its scope 
    Extern – Global variable known to all functions in the program and defined in another 

program 

    Register – It instructs the compiler to store the variable in the CPU Register to optimize 

access  

Static and register variable are automatically initialized to zero when they are 

declared. Auto variables are not initialized but get undefined values known as 

garbage. 
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**16. What is a void data type? 

 Void data type indicates the compiler that the function does not return a value. 
Void indicate that it hold nothing. Integer, Void and Float are the fundamental data 

types. It has two purposes: 

 To indicate that a function does not return a value 

 To declare a generic pointer 

 

**17. What is a pointer? 

 A pointer is a variable that holds a memory address. Every byte in the computers 

memory has an address which is done using the Hexadecimal system. When a program is 

compiled, some memory is allocated to each variable depends on the data type such as 

int - 2, char - 2, float - 4 bytes. A pointer variable is used to display the contents stored at 

a location. It’s a unary operator. 

  

**18. What is the impact of modifiers? 

 Long. Short, signed and unsigned are modifiers to alter the base data type to yield a 

new value with the exception of void   

 Unsigned modifies the range of the integer values as the sign bit is also used to store 
data 

    Integer – 215 bits (To store data) 16th bit , also called as Most significant bit or 

sign bit 

    Unsigned int – 216 bits used to store data including sign bit 

  Long increase the bytes for a particular data type, thus increasing the range of values.  

19. What is a variable? 

 Variables are user defined named entities of memory locations that can store data 

based on the data type of the variable. Variable names may contain letters, numbers and 

the special character _. Variable names are case – sensitive and it must begin with a 

letter or under score.   

 The syntax is ; 

  Data type identifier     Space  identifier  ; 

 

  Ex: int a_b; 

         float _test; 

*20. What is implicit conversion? 

 It refers to the data type changes in expression done by compiler. 

   Ex: float f=7.6;  int x=f; 

 The value stored in the variable x is 7, as float is converted into int, which is 

done by the compiler automatically. 

 

*21. What is type cast? 
 Type cast refers to the process of changing the data type of the value stored in a 

variable. The syntax is: 
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  data type (variable/value) 
 Ex: x = 8 % 7.7; will throw an error as the modulus operator works only for 

integer data type. This can be corrected as, x = 8 % (int) 7.7; the float constant 7.7 is 
converted to integer constant by type casting it 

 

22. How to declare a pointer variable? 

 Pointer variable can store the address of another variable. 

 Ex:  int *iptr,num1; 

  num1 = 10;   

  iptr = &num1; 

 Pointer variables are sensitive to the data type of the variable as it must be the same 
(*) value at operator and the address of operator (&). 

 

***23. What is sizeof( ) operator? 

 Sizeof( ) is an operator. It returns the size (memory requirement) in terms of bytes, 

of the given expression or data type. 

 Ex:- sizeof(d*f) – float is converted to double and it returns 8. 

 

24. List the rules for implicit conversion 

 If one operand is of float types, the other value is also converted to float 

 If one operand is of long double, the other value is also converted to long double 

 If one operand is of type double, the other value is also converted to double. 

 If one operand is of type long int, the other is converted to long int 

  

3. BASIC STATEMENT 

**1. What is assignment operator? Which operator is used for assignment operator? 

 An assignment statement, assigns value on the right hand side of an 

expression to the variable on the left hand side of the assignment operator ‘=’. 

 Ex:  num=5; 

  total = English + maths; 

   sum+=marks; 

During Assignment operation, C++ compiler converts the data type on the right 

hand side of the expression to the data type of the variable on the left hand side of the 
expression. 

 

***2. What is control statement? 

Program statements that cause a jump of control from one part of a 

program to another are called control statement. 
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       Control Structure 

 

    Selection          Loop 
 

 

If..else  switch   Exit check   Entry Check  

       do..while ( )loop  for ( ; ; ) 

           While ( ) loop 

**3. What is a switch statement 

 This is a multiple branching statement where, based on a condition, the 
control is transferred to one of the many possible points 

 switch ( expression) 

 { 

 case 1: action block 1; 

  break; 

 case 2: action block 2; 

  break; 

 default: default block; 
 } 

 

***4. What is the difference between continue and break statement? 

The continue statement forces the next iteration of the loop, skipping the 

code following the continue in the loop body 

 Syntax: for ( ; ; )   for ( ; ; )   

   {                                       {   

   ……….   exp 1 

   Continue;   break; (condition fails) 

   ………   exp 2. 

   }    } 

A loop’s execution is terminated when the test condition fails. We can use 

break statement under certain situations to terminate the loop irrespective of the test 

expression  

Break statement would exit the current loop only 

Break statement accomplishes jump from the current loop 

 

***5. Write the syntax of simple if, if-else statement. 

In a program a decision causes a jump to different parts of a program. IF 

Statement is the simplest of all the decision statements as Simple. If & If. Else 

Statement and it chooses between two alternatives executes the chosen block based 

on the condition. 
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If (condition)   if (condition / expression ) 

{     { 

 action block;   action block 1; 
}     } 

     else 

     { 

        action block 2; 

       } 

***6. What is an entry check loop  

For(; ;) is an entry controlled loop and is used when an action is to be 

repeated 

for a predetermined number of times.  

 for ( initial value; test-condition; increment) 

 { 

  action block; 

 } 

 Initialization is executed only once, ie., when the loop is executed for the first 

time 
 Test condition is evaluated before the commencement of every iteration. 

 Increment segment is executed before the commencement of new iteration 

 

**7. Write the rules of nested loop. 

 An outer loop and inner loop cannot have the same control variables as it will 

lead to logical errors. 

 The inner loop must be completely nested inside the body of the outer loop 

 

*8. Define a loop. 

Loops execute a set of instructions repeatedly for a certain number of 

times. Loops are unconditionally executed at least once, if the condition is placed at 

the end of the body of the loop   

Based on the position of the condition, the loops are classified as Entry-Check 

loop and Exit Check loop. 

 
*9. Write the syntax of do..  while loop. 

 The construct of a do .. while loop is 

 do 

{ 

 action block; 

 } while(condition);   do…while(condition) is called as exit-check loop, as 

the condition(test expression) marks the last statement of the body of the loop. 

 

CHAPTER -4 FUNCTIONS 
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***1.What are the advantages of using function? 

Functions are the building blocks of C++ program. Functions are also the 

executable segments in a program. The Starting point for the execution of a 

program is main ( ) function. The advantages of functions are, 

 Reduce the size of the program 

 Induce reusability of code 

 A function code can be shared by other programs by compiling it 

separately and loading them together  

 

**2. Give the general syntax and example for a function prototype. 

Functions should be declared before they are use din a program. Declaration of 
a function is made through a function prototype 

Syntax: <type> <function identifier > (arguments); 

Example: int max (int a, int b); 

 The main purpose of function prototype is to help the compiler to check the 

data requirement of the function.  

 

***3. Write the difference between call by value and call by reference. *** 

  A function can be invoked from another function using its name. The call 

statement communicates with the function through arguments or parameters 
through which the data flows from the call statement to the function and vise versa. 

  In C++ functions that have arguments can be invoked by, 

 Call by value 

In call by value method, any change in formal parameter is not 

reflected back in actual parameter 
 Call by reference 

In call by reference method, any change in formal parameter is 

reflected back in actual parameter 
 

***4. What is an inline function? 

 An inline looks like a normal function in the source file but inserts the functions 

code directly into the calling program. Inline function executes faster but requires 

more memory space. To make a function inline, the keyword Inline should be inserted in 

the function header.        
Inline keyword is just a request to the compiler. Sometimes the compiler will ignore 

the request and treat it as a normal function 

 

***5. What is a scope resolution operator?  

:: is called as scope resolution operator. It is used to refer variables declared at file 

level. This is helpful under situations where the local and file scope variables have the 

same name. 
**6. List the types of scope available in c++ 

 Scope refers to the accessibility of a variable. There are four types of scope in 

C++  
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1. Local Scope 

2. Function Scope   

3. File Scope   

4. Class Scope  

**7. What is a default argument? 
 The default value is given in the form of variable initialization 

 The default arguments facilitate the function call statement with partial or no 

arguments 

 The default values can be included from right to left i.e we cannot have a 

default value for an argument in between the argument list  

 

**8. List the rules of Actual parameters 
The actual parameters can be passed in the form of constants or variables or 

expressions to the formal parameters which are of value type 

  Function prototype (F)  - int add (int n1,int n2); 

  Call statement (A) - x = add (5,10); 

       x = add (a1,a2); 

The Actual parameters can be passed only as variables to formal 

parameters of reference type. 

  Function prototype (F)  - int add (int &n1,int &n2); 
  Call statement (A) - x = add (a1,b1); 

 

5. STRUCTURED DATA TYPES – ARRAYS 

 

1. What is array? Write the different types.*** 

An Array is a collection of variables of the same type that are referenced by a 

common name. It is a derived data type 

 Arrays are of two types; 
  One Dimensional  -  Comprising of finite homogeneous elements 

  Multi Dimensional - Comprising of elements, each of which is itself a one-  

                                                  dimensional array 

 

2. Write the syntax of single dimensional array. Give an example.*** 

An one dimensional array is declared as , 

 Int num_array[5]; 
 

Syntax: 

 Data    array    [ size  ] ; 

  type     identifier 

The size of the array should always be positive. The array subscript 

always commence from zero. 

 

3. What is array of strings? Give an example.*** 
Strings are otherwise called as literals, which are treated as single 

dimensional array of characters. The declaration of strings is same as numeric 

array. 
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 Example:  char name[10]; 

   Char vowels[]={‘a’,’e’,’i’,’o’,’u’};  

 A character array should be terminated with a ‘\o’ Null Character. 

 

4. Write the syntax of write ( )** 

write ( ) is a member function of standard output stream.i.e ostream.  

The syntax is , 

 Write (identifier string characters, no of characters); 

 Example: cout.write (st r, i); 

getline is a member function of standard input stream.i.e.,istream 

 
5. Write the short notes: Strlen(), Strcpy() and Strcmp()* 

Strlen (string ) - Returns the number of characters stored in the array 

Strcpy (target str , source str) - Copies source string to target string 

Strcmp (s1, s2 ) – Compares the two given strings and returns 0 if strings are equal.  

 

6. Define Two dimensional array.** 

A two –dimensional array is an array in which each element is itself an array. 

The number of elements in a 2-dimensional array is determined  by multiplying the 
number of rows with number of columns 

 

6. CLASSES AND OBJECTS 

1. What is a class?** 

A class is a new way of creating and implementing a user defined data type. 

Classes provide a method for packing together data of different data types. 

Example: 
  class student 

{ 

  char name[30]; 

  int rollno,m1,m2,m3,total; 

  float average; 

}; 

 

The data variables are called attributes, and functions are called as methods. 
 

2. What are the two parts of class specifiers?** 

  A class specification has two parts 

 Class Declaration 

 Class function definition 

 

3. What is encapsulation?*** 
The binding of data and functions together into a single entity is referred to as 

encapsulation 
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4. What is meant by data hiding?*** 

 The members that are declared under private are not accessible by the members 

outside the class, this is referred to as Data Hiding.  
 

5. What is data abstraction?*** 

Instruments allowing only selected access of components to objects and to 

members of other classes is called as Data Abstraction. Data Abstraction is 

achieved through Data Hiding. 

Data Hiding is the key feature of Object Oriented Programming (OOPS) 

 

7. Define Friend function.** 
The private data of a class can be accessed only through the member functions of 

its own class and certain special functions called as Friend function. 

 

8. Write the general form of class declaration*** 

Class class_name 

{ 

 private: 

variable declaration 

  function declaration 

protected: 

variable declaration 

  function declaration 

public: 

variable declaration 

  function declaration 

}; 

9. Define static data members.*** 

The static member variable is, 

 Is initialized to zero, only when the first object of its class is created. No other 

initialization is permitted 

 Only one copy of the member variable is created and is shared by all the other objects of 

its class type 

 Its scope or visibility is within the class but its lifetime is the lifetime of the program 

 

10. List the access specifiers in class** 

 The class body has three access specifiers, they are Private, Public & Protected 

 Private     - Members declared under Private, can be accessed only within the 

class 

 Protected - Members declared under Protected, can be accessed from within the 

class and the members of inherited class 

 Public     -  Members declared under Public, can be accessed can be accessed    

     from outside the class also 
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11. How to access a class member function?*** 

  The members of a class are accessed using the dot operator. For example the call 

statement to the function execute ( ) of the class student may be given as, 

    Stud .execute ( ) 

  

 

 

 

 

 

12. How to define the member function outside the class?** 
 The member functions defined outside the class has the prototype as 

   type class_name :: function name (  ) 

 For example; 

    

    void add : : display ( ) 

 

      

 
 

  The membership label class_name (add::) tells the compiler that the function_name 

belogs to the class class_name. The scope of the function is restricted to the class 

specified in the function header. 

 

13. List the properties of a member function** 

 Several different classes can use the same function name 
 A member function can access the private data of a class 

 A member function can call another member function directly without using 

dot operator (This is called Nesting of member functions) 

 The member functions can receive arguments of valid C++ data type. Objects 

can alos be passed as arguments 

 The return type of a member function can be of object data type 

 Member functions can be of static type 

 

7. POLYMORPHISM 

1. What is function overloading?*** 

 The ability of a function to process the message or data in more than one form 

is called as function overloading. 

 The word Polymorphism means (Poly – Many , form – shapes). In C++ 

polymorphism is achieved through function overloading and operator overloading 

2. How are functions invoked in function overloading?** 
The compiler adopts Best Match Strategy. As per this strategy the compiler will, 

 Look for the exact match of a function prototype with that of a function call 

statement. 

Member Function 

 

Dot Operator 

 

Object name 

Scope Resolution operator 

 

Member Function 

 

Class name / tag 

 

Data type of Member function 
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 In case an exact match is not available. The compiler will look for the next 

nearest match and promote Integral data promotions and then match the 

call statement with function prototype 

Integral promotions are purely compiler oriented 

 

3. Write the rules of function overloading* 

 Each overloaded function must differ either by the number of its formal 

parameters or their data types. 

 The return type of a overloaded functions may or may not be of the same 

data type 
 The default arguments of the overloaded function are not considered by he 

C++ compiler as part of the parameter list 
   Do not use the same function name for two unrelated functions. 

 

4. What is operator overloading?** 
The term overloading refers to giving additional functionality to the normal 

C++ operators like +,++,-,--,+=,-=,*,<,>. 

The mechanism of giving a special meaning to an operator is called Operator 

overloading. 

 

     5. List out the operators that cannot be overloaded.*** 

  One cannot overload C++ specific operators like membership operator(.),Scope 
Resolution operator(::),sizeof operator and conditional operator(?) 

 

    6.List the rules of Operator overloading* 

 Only existing operators can be overloaded. New operators cannot be 

created. 

 The overloaded operator must have at least one operand of user defined type. 

 The basic definition of an operator cannot be replaced. One can give 

additional functions to an operator. 
 Overloaded operators behave in the same way as the basic operators in 

terms of their operands. 

 When binary operators are overloaded, the left hand object must be an 

object of the relevant class. 

 Binary operators overload through a member function take one explicit 

argument. 

 

8. CONSTRUCTORS AND DESTRUCTORS 
1. What is constructor?*** 

 When an instance of a class come into scope, a special function called 

Constructor gets executed.. The constructor function initializes the class object. The 

constructor and destructor have same name as class name. They return nothing and 

not associated with nay data type. 
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2. What are the functions of constructors?** 

 The constructor function initializes the class object 

 The memory space is allocated to an object  

3. What is copy constructor?*** 

Constrcutor – add (add &a) is called as copy constructor. A copy constructor is 

executed; 

 When an object is passed as a parameter to any of the member functions 

Example: void add::putdata(add x) 

 When a member function returns an object 

Example: add getdata(); 

 When an object is passed by reference to constructor 

Example: add a,b(a); 

 

4. What is destructor?*** 
A destructor is a function that removes the memory of an object which was 

allocated by the constructor at the time of creating an object. It carries the same name 

as the class name , prefixed with a tilde (~) symbol. 

Example:  class simple 

{ 

     ….. 

    public: 

    simple ( ) 
     { 

     } 

    ~ simple ( ) 

     { 

     } 

    }; 

  
5. List the rules of constructor** 

 The name of the constructor must be same as that of the class. 

 A constructor can have parameter list. 

 The constructor function can be overloaded. 

 The compiler generates a constructor in the absence of user defined 

constructor. 

 The constructor is executed automatically. 

 
6. List the rules for destructor definition** 

 The destructor must be same as that of the class prefixed with ( ~ ) tilde 

symbol. 

 The destructor cannot have arguments. 

 It has no return type. 

 Destructors cannot be overloaded. 

 The compiler generates a destructor in the absence of user defined destructor. 
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 The destructor is executed automatically when the control reaches the end of 

the class scope. 

 9. INHERITANCE 

1. What is inheritance?** 

 Inheritance is the most powerful feature of an object oriented programming 

language. It is a process of creating news classes called derived class, from the existing 

base class. The derived class inherits all the properties of base class. It is a power packed 

class, as it can additional attributes and methods. 

 

2. What are the advantages of inheritance?*** 
 Reusability of code: Code developed for one application can be reused 

in another application if such functionality is required. This saves a lot of 

development time 

 Code sharing : The methods of the base class can be shared by the 

derived class 

 Consistency of interface : The inherited attributes and methods provide 

a similar interface to the calling methods 

 
3. What are the points to be observed while defining a derived class?** 

 The keyword class has to be used. 

 The name of the derived class is to be given after the keyword class. 

 A single colon 

 The type of derivation, namely Private, Public or Protected. 

 The name of the Base class / Parent class 

 The remainder of the derived class definition 

  Example: class subtract : public add 
 

4. What are the different types of inheritance?*** 

 There are five types of inheritance, 

 Single inheritance 

 Multiple inheritance 

 Multilevel inheritance 

 Hybrid inheritance 
 Hierarchical inheritance 

 

5. What is an abstract class?* 

 Classes used only for deriving other classes are called Abstract class. Objects 

for these classes are not declared. 

 

6. Define Accessibility** 

 When a member of base class can be used by the objects or the members of the 
derived class is known as accessibility. The three access specifiers are Private, Public 

& Protected. Access specifier is also known as visibility mode. The default 

visibility mode is private   
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10. IMPACT OF COMPUTERS ON SOCIETY 

1. Write is meant by e-learning.*** 

 e-learning enables online educational programs leading to degrees 

and certificates 

 Computer based tutorials (CBT ) 

 Buying and Browsing the latest edition of books & Foreign authors 

Educational CDROM’s 

 Spreading information about schools, colleges, universities, courses 

offered, Scholarships, Educational loans and career guidance. 
 

2. What are the three technical elements we need to reach out benefits of IT to the  

     Common man?* 

 Connectivity ( Computer Networks & Internet facility ) 

 Affordable computers  

 Software 

          It is interesting to observe that 85% of computer usage is Word 

Processing 

 

3. What is an ATM?** 

 Advanced machines like ATM (Automated Teller machine ) enable withdrawal 

of money from the accounts in any bank anywhere. e-banking permits banking from the 

comfort of home by using the internet facilities like e-bay, and online shopping stores. 

 

4. Write s brief note on e-shopping.*** 

 Through e-shopping we can purchase any product, any brand, any quantity 

thorugh pictures and details available on the website. Payments can be made through Debit 

cards, Credit cards, Shopping card, and Cash on demand (COD) etc.., The items purchased 

will be delivered at your home 
 

5. Name areas of healthcare in which computers are used?* 

 Hospital management system 

 Patient tracking system 

 Exchange of diagnostic records between healthcare units. 

 Tracking and monitoring communicable diseases 

 Decision support systems with highly advanced computing techniques 

 

7. List few areas where software has been developed for agriculture* 

 Agricultural finances and accounting 

 Alternative farming techniques 

 Fertilizer analysis 

 Livestock 

 Use of satellite imagery to decide on the crops 
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 Improving cow herds and increasing revenue 

11. IT ENABLED SERVICES 

1. What is an ITES?* 
 Information Technology Enabled Services are human intensive services that 

are delivered over telecommunication networks or the internet to a range of business 

segments. ITES greatly improve employment opportunities. 

    

2. What is Dictaphone?* 

 A facility that allows the user to speak into a special device called ‘ 

Dictaphone’ and then convert the speech into a letter is an ITES. 
 

3. List few IT Enabled service.* 

 e-Governance 

 Call centres (BPO- Business Process Outsourcing ) 

 Data Management 

 Medical ( Telemedicine & Transcription )  

 Data Digitization 

 Website Service 

 

3. What is e-governance?** 

 e-Governance helps you to look at the various details provided by the 

government website to know about the departments, specific functions, schemes, 

documents, Sitemap, search, what’s new, press releases, and feedback. These websites are 

available in both Tamil & English. 

  
4.What is the use of call centers?*** 

The customers or users of IT products are in need of a facility that ensure 

communication services on all days of the year all round the clock – 24 x365 

A call center is sometimes called a telephone based shared service center 
for specific customer activities like marketing, selling, information transfer, technical 

support and so on.  

 

5. What is data management?** 

Data management is a category of IT enabled services pertaining to 

collection, digitization, and processing of data coming from various sources. 

Traditional data processing services comprise punching data from manually filled 

forms, images or publications. 

 

6. What is data digitization?*** 

Digitization refers to the conversion of non-digital material to digital form. A wide 
variety of materials as diverse as maps, manuscripts, moving images and sound may be 

digitized. 

 
7. List the steps in Medical Transcription. 
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    Step 1: The doctor dictates into a special device or a free telephone and gets stored in the 

server 

    Step 2: The sound is digitized and sent the ITES they reduce the cost by having it done 

in an affordable cost. The digitized data is converted back to sound. The trained 

transcriptionist listens to the dictation and transcribe. This is a formal record of the 

diagnosis. 

    Step 3: The transcribed files are sent to quality control persons and checked for 

corrections and send back to the hospital as a word document. This is valid for legal 

purposes and making insurance claims. 

 

12. COMPUTER ETHICS 

1. What are ethics? 

Computer ethics has its roots in the work of Norbert Wiener during World war II. 

General guidelines on computer ethics are needed for: 

* Protection of personal data        * Computer crime        * Cracking 

 

2. What does physical, personal and personnel security?** 

Physical security – It refers to the protection of hardware, facilities, magnetic discs, 

and other items that could be illegally accessed, stolen, damaged or destroyed. 

Personal security – User id and passwords are common tools to create a software 

setup that permits only authorized access. 

Personnel security – It refers to protecting data and computer system against 

dishonesty o0r negligence of employees 

 

3. List out some of the common computer crimes.** 

A computer crime is any illegal activity using computer software, data or access as 

the object, subject or instrument of the crime which include, 

 * Crimes related to money transfer on the internet * Cracking 

* Stealing hardware     * Virus      

* Theft of computer time    * Hardware and software piracy 

  

4. What is piracy?*** 

Making and using duplicate hardware and software is called piracy. We tend to 

pirate because we like free things, our thinking and actions are self-serving.  

 

5. Define Theft of computer time** 

The idle time of computers in an organization is being stolen illegally. Some 

other software runs on an idle computer without the knowledge of the organization is called 

‘Theft of computer time’. 
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6. What is a computer virus?*** 

A virus is a self replicating program that can cause damage to data and files 

stored on your computer. These are programs written by programmers with great 

programming skills who are motivated to cause destruction. 57000 known virus programs 

are in existence. 6 new viruses are found each day. 

 

7. What is cracking? 

Cracking is the illegal access to the network or computer system. Illegal uses of 

special resources in the system like hardware, software, files or system information. Revenge, 

Business reasons and thrill are the common reasons for it.  

 

8. What is Cyber law?** 

Computer crimes required special laws to be formed by the government. Different 

countries have different ways of making the laws and awarding punishments to those who 

commit the crimes is known as ‘Cyber law’. 
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      C++ 5 MARKS  

      CHAPTER – 3 

1. Explain about “if: statement with an example.*** 

In a program a decision causes a one-time jump to a different part of a program. Decision in C++ 

are made in several ways, with if… else ... statement which choose between two alternatives 

It is implemented in two forms; 

a. Simple if statement 

b. If…else statement 

 

Simple If: 

If statement is the simplest of all the decision statements. 

Syntax:  Example: 

        if (a>b) 

        { 

           cout<<a; 

          } 

If..else statement:  Example: 

 

 

 

 

 

 

 

 

 

 Output:  

   Enter a number 

   12 

   The given no 12 is even 

 In the above program “The given no is even” if the condition is evaluated to true, otherwise the 

control jumps to the else block. Once the true block is executed in an if… else statement, then the else block 

will not be executed. 

 If..else.. Statement chooses between two alternatives, executes the chosen block based on 

the condition. Else block is executed only if true block is not executed. 

 

 if ( condition / expression ) 

{ 

 action   block 1; 

}  

else 

{ 

action block 2; 

} 

if ( condition / expression ) 

{ 

action   block; 

} 

# include<iostream.h> 

#include<conio.h> 

void main ( ) 

{ 

int a; 

clrscr( ); 

cout<<”\n Enter a number”; 

cin>>a; 

if(a%2==0) 

{ 

cout<<”\n The given no is “<<a<<”is even”; 

else 

cout<<”\n The given no is “<<a<<”is odd”; 

} 

getch( ); 

} 
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2. Explain “nested-if” statement with example.** 

 The statement sequence of if or else may contain another if statement i.e., if..else statements can 

be nested within another if..else statement. 

 In an nested if..else statement, “Each else matches with the nearest unmatched preceding if”. 

 Syntax:       Example: 

 cout<<”Enter the mark”; 

 cin>>mark; 

 if(mark>90) 

      { 

   if(mark==100) 

   { 

    cout<<”Very Good”; 

   } 

   else 

   { 

    cout<<”Good”; 

}   } 

     else 

         { 

         cout<<”Try to score above 90%”; 

         } 

 } 

  

 Output: 

  Enter the mark: 

  92 

  Good 

Working process: 

i) The input for the variable mark is 92 

ii) The outer loop condition satisfied as the value of mark is > than 90 

iii) The inner loop condition checked as the value does not equal to 100, the else part gets executed. 

iv) Hence the output is “Good”. 

v) If the Outer loop fails, then the inner loop won’t be executed. 

 

3. Explain Switch statement with example?*** 

This is a multiple branching statement where, based on a condition, the control is 

transferred to one of the many possible points. 

Syntax; 

 

  

 

 

 

 

 

 

 

 

 

if ( expression 1 ) 

if (expression 2) 

{ 

 action 1; 

} 

 else 

{ 

action 2; 

} 

else 

{ 

 action 3; 

} 

switch (expression) 

{ 

case 1: action block 1; 

 Break; 

case 2: action block 2; 

 Break; 

case 3: action block 3; 

 Break; 

default:  

 action block 4; 

} 

remainder=a%3; 

switch (remainder) 

{ 

case 1: cout<<“Remainder 1”; 

 Break; 

case 2: cout<<“Remainder 2”; 

 Break; 

default: cout<<“Divisible by 3”; 

} 
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 The above program displays 

➢ “Remainder is 2” if a=5 or so 

➢ The given number is “Divisible by 3”, if a=9 or so 

 Example; 

    int rank=1; 

    switch ( rank) 

    { 

     case 1: cout<<” Shiv secured 1st Rank”; 

     case 2: cout<<” Shiv secured 2nd Rank”; 

    } 

 In the above example, the output will be  

   Shiv secured 1st Rank 

   Shiv secured 2nd Rank 

   

 Every action block should be terminated with the break statement. Otherwise all action 

blocks are executed sequentially from the point where the control has been transferred based on the 

condition. Hence break statement is used to exit from switch statement.    

 

4. Explain ‘For’ loop with example.*** 

 For(; ; )..loop is an entry controlled loop and is used when an action is to be repeated 

for a predetermined number of times. 

            Loops execute a set of instructions repeatedly for a certain number of times. A looping block 

consists of two segments, body of the loop and control statement. Loops are unconditionally 

executed at least once, if the condition is placed at the end of the body of the loop. 

 

            Based on the position of the condition, the Loops are classified as, 

➢ Entry – check loop { for(;;) , while( ) } 

➢ Exit check loop { do…while( ) } 

 

 Syntax: 

  for ( initial value; test condition; increment) 

  { 

   action block; 

  } 

              The general working of for loop is, 

1. The control variable is initialized the first time when the control enters the loop for the 

first time. 

2. Test condition is evaluated. The body of the loop is executed only if the condition is true. 

Hence for(;;) loop is called an entry controlled loop. 

3. On repetition of the loop, the control variable is incremented and the test condition will be 

evaluated before the body of the loop is executed 

4. The loop is terminated when the test condition evaluates to false.  

                  Example:         Output: 

 void main ( )       

 {         The factorial is 120 

 int i=1,fact=1; 

 for( i=1 ; i<6 ; i++) 

 { 

 fact*=i; 

 }  

 cout<<”The factorial is”<<fact; 
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 getch(); 

 }  

 A for loop can have more than one statement in incrementation and initialization 

segments, each instructions separated by a comma operator.  

 Initialization is executed only once .i.e when the loop is executed for the first time. 

 Test condition is evaluated before the commencement of every iteration. 

 Increment segment is executed before the commencement of next iteration. 

                   When there is a semicolon placed after for loop, hence then the statement fact*=i, is not 

treated as part of for loop body. 

 

5. Explain do…. While loop with example* 

Loops execute a set of instructions repeatedly for a certain number of times. A looping block 

consists of two segments, body of the loop and control statement. Loops are unconditionally 

executed at least once, if the condition is placed at the end of the body of the loop.  

  do.. while() is called as Exit check loop, as the condition (test expression) marks the last 

statement of the body of the loop. The loop executes at least once even if the condition fails. 

Syntax: 

 do 

   { 

        action block 

   } while<(condition)>; 

   To print the square of numbers 

   void main( ) 

{ 

   int num=2; 

   do 

   { 

    cout<<num*num<<’\t’; 

    num+=1; 

   } 

   while(num<6); 

   } 

  The working of the above loop is, 

1. Enters the loop 

2. Print the square of num 

3. Increment the control variable by 2 

4. Evaluate the condition to repeat the steps 4 times (num=2<6), based on which the 

control is transferred to step 2. 

Snippet: A  Snippet: B 

 

 

 

 

 

 

 

 

 

Control variable – num 

Test Expression – num < 6 

No of times Loop run – 4  

 

Output : 

4 9 16 25 

void main ( ) 

{ 

int i=10; 

do 

{ 

  cout<<i; 

  i--; 

}while(i<=10); 

} 

void main ( ) 

{ 

int i=10; 

choice=1; 

do 

{ 

  cout<<i; 

  i++; 

}while(choice); 

} 
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 Output:          -32768                  Infinite loop 

            It is very important to construct appropriate conditions that would evaluate to false at some 

point of time, and also incrementing / updating the control variable that is linked to test expression in 

the while loop. 

6.  Explain While loop with example.** 

Loops execute a set of instructions repeatedly for a certain number of times. A looping block 

consists of two segments, body of the loop and control statement. Loops are unconditionally 

executed at least once, if the condition is placed at the end of the body of the loop. 

 

 While<(condition)>  loop is called as entry check loop. The body of the while loop will be 

executed only if the test expression results true placed in the while statement. The control exits the 

loop once the test expression is evaluated to false. 

           Syntax: 

 while < (condition) > 

 { 

  action block 

 } 

   To print the square of numbers 

   void main( ) 

{ 

   int num=2;  

   while(num<6) 

        { 

    cout<<num*num<<’\t’; 

    num+=1; 

        } 

   } 

 

 The working of the above loop is, 

1. Initialize the control variable num to 2 

2. The test expression num>2 is evaluated, control is transferred to step 3, only if the test 

expression is True. 

3. Prints the square of the values stored in num. 

4. Increments num by 1. 

5. Control is transferred to step 2. 

 

 CHAPTER – 4 FUNCTIONS 

1. Explain about Call by value method with an example.*** 

In call by value method any change in the formal parameter is not reflected back in the 

actual parameter. 

Methods: 

• In this method, the called function creates new variables to store the value of the argument 

passed to it. 

Counter variable – num 

Test Expression – num < 6 

No of times Loop run – 4  

 

Output : 

4 9 16 25 
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• This method copies the values of actual parameters(parameters associated with call statement) 

into the formal parameters(the parameters associated with function header) 

• The function creates its own copy of arguments and then uses them. 

Example: 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int n1,int n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<’\n’<<n1<<’\t’<<n2<<’\n’; 

} 

void main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<<”\n Values before invoking swap”<<m1<<’\t’<<m2; 

swap(m1,m2); 

cout<<”\n Back to main values are”<<m1<<’\t’<<m2; 

getch(); 

} 

Output: 

 Values before invoking swap 10 20 

 Calling swap.. 

 20 10 

 Back to main values are 10 20 

Working Process: 

• When arguments are passed by value, the called function creates new variables of the same 

data type as the arguments passed to it. 

• The values of these arguments are copied into the newly created variables. 

• The actual parameters and formal parameters have been allocated different memory 

locations. 

• In call by value method, the flow of data is always from the call statement to the function 

definition 

• Hence, changes or modifications that are made to formal parameters are not reflected in the 

actual parameter. 

 

2. Explain about Call by reference method with an example.*** 

In call by value method any change in the formal parameter is reflected back in the actual 

parameter. 

Methods: 

• In this method, the called function arguments- formal parameters become alias to the actual 

parameters in the calling function. 
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• This means that when the function is working with its own arguments, it is actually working 

on the original data. 

Example: 

 #include<iostream.h> 

 #include<conio.h> 

void swap(int &n1,int &n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<’\n’<<n1<<’\t’<<n2<<’\n’; 

} 

void main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<<”\n Values before invoking swap”<<m1<<’\t’<<m2; 

swap(m1,m2); 

cout<<”\n Back to main values are”<<m1<<’\t’<<m2; 

getch(); 

} 

Output: 

 Values before invoking swap 10 20 

 Calling swap.. 

 20 10 

 Back to main values are 10 20 

Working Process: 

• Hence, changes or modifications that are made to formal parameters are reflected in the 

actual parameter, because formal and actual parameters in reference point to the same storage area. 

  Main     Swap 

  m1 = 10    n1=10 

  m2 = 20    n2=20  

       temp 

Assume storage area of m1 is 0xf1, and m2 is 0xf2 

    m1 = 0xf1 = 10 

    m2 = 0xf2 = 20  

Reference to formal parameters may be read as, 

 n1 = 10, n1 is a  reference to m1, which may be depicted as, 

    int &n1 = m1 

    int &n2 = m2 

This means that n1 is an alias to m1, hence m1 and n1 refer to same storage area, hence the 

statements may be rewritten as, 

    n1 = m1 = 0xf1 = 10 

    n2 = m2 = 0xf2 = 20 
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 Address  Before Exchange  After Exchange 

0xf1(n1.m1)   10    20 

0xf2(n2.m2)   20    10   

 In call by reference method, any change made in the formal parameter is reflected 

back in the actual parameter. 

 

3. Explain Inline function with example.* 

When the functions are small (fewer no of instructions), the compiler replaces the function 

call statement by its definition i.e. the code during the program execution. This feature is called as in 

lining of a function technically called as inline function.   

 

Methods: 

Inline function executes faster but requires more memory space. 

An Inline function looks like a normal function in the source file but inserts the functions 

code directly into the calling program. 

To make a function Inline, one has to insert the keyword inline in the function header. 

Inline keyword is just a request to the compiler. Sometimes the compiler will ignore the 

request and treat it as a normal function and vice versa. 

Example: Source     Behaves 

#include<iostream.h>     #include<iostream.h> 

 #include<conio.h>      #include<conio.h> 

inline float convert_feet(int  x)    void main( ) 

{        { 

return x*12;      int inches=12; 

}        cout<<inches*12; 

void main( )       getch(); 

{        }  

int inches=45; 

cout<<convert_feet(inches); 

getch(); 

} 

 

As shown in the above example, the call statement to the function (convert_feet(inches)) will 

be replaced by the expression in the return statement(inches*12). 

 

4. List the types of scope rules of a variable? Explain it?*** 

 Scope refers to the accessibility of a variable. There are four types of scopes in c++. They are 

i. Local Scope  ii. Function Scope    iii. File Scope iv. Class scope 

 

Example: 

#include<iostream.h> 

#include<conio.h> 

int a=20; 

void main() 

File Scope 
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{ 

int a=30,b=10;  

 if(a>b) 

  { 

  int temp; 

  temp=a;  

  cout<<temp; 

  } 

cout<<::a; 

getch(); 

} 

 

 Local Scope: 

    A local variable is defined within a block. The scope of a local variable is the block in which 

it is defined. A local variable cannot be accessed from outside the block of declaration. 

• The lifetime of a local variable is the lifetime of a block in its state of execution. 

• The local variable in the above program is, int temp; 

• Local variables are not known outside their own code block. A block of code begins and ends 

with curly braces{ }. 

• A local variable is created upon entry into its block and destroyed upon exit. 

 Function Scope: 

    The scope of variables declared within their function is extended to the function, and all the 

sub blocks therein. 

• The lifetime of a function scope variable, is the lifetime of the function block. The scope of 

formal parameters is function scope. 

• The function scope variables is int a=30,b=10; 

 File Scope: 

    A variable declared above all blocks and functions i.e above main() has the scope of a file. 

The scope of a file scope variable is the lifetime of the program.  

 The File scope variable is int a=20; 

Scope Resolution Operator: 

 The scope resolution operator reveals the hidden scope of the variable. :: is called scope 

resolution operator. 

 Example: 

 #include<iostream.h> 

 #include<conio.h> 

 int num=15; 

 void main() 

 { 

  int num=5;  

  num=num+::num; 

  cout<<num<<’\t’<<++::num; 

  getch(); 

} 

 

Function Scope 

Local Scope 

File Scope 

Function Scope 
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  It is used to refer variables declared at file level. This is helpful under situations where the 

local and file scope variable have the same name. 

 

      7. POLYMORPHISM 

1. Explain Function overloading with example?*** 

 In C++ polymorphism is achieved through function overloading and operator 

overloading. The term overloading means a name having two or more distinct meanings. The 

ability of the function to process the message or data in more than one form is called as 

Function overloading. Function overloading is one of the facets of C++ that supports object 

oriented programming. 

 Invoking function in function overloading: 

 The compiler adopts best match strategy. As per this strategy the compiler will 

➢ Look for the exact match of a function prototype with that of a function call statement. 

➢ In case of an exact match is not available, it looks for the next nearest match. i.e., the 

compiler will promote integral data promotions and then match the call statement with 

the function prototype 

 Example: 

   #include<iostream.h> 

   #include<conio.h> 

   void area(int a) 

   { 

   cout<<”Area of a square”<<a*a; 

   } 

   void area(int a, int b) 

   { 

   cout<<”Area of Rectangle”<<a*b; 

   } 

   void main() 

   { 

   area(2); 

   area(2,3); 

   } 

 Working Process: 

✓ Here area() is the overloaded function. 

✓ Area(2) calls the function void area(int a)- matching one argument. 

✓ Area(2,3) calls the function void area(int a, int b)- matching two arguments 

 Invalid Prototype: 

    Void fun(int x); 

    Void fun(int y); 

- Both the prototypes have same number and type of arguments. Hence it is invalid. 

 Integral Promotions: 

              Integral promotions are purely compiler oriented. By and large integral promotions are as follows: 

➢ Char data type can be converted to Integer / Float / Double 

➢ Int data type can be converted to Char / Double / Float 
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➢ Float data type can be converted to Integer / Double / Char 

➢ Double data type can be converted to Float / Integer 

    

 Rules of Function overloading: 

 Each overloaded function must differ from either by the number of its formal 

parameters or their return (data) types. 

 The return type of the overloaded functions may or may not be the same data type. 

 The default arguments of overloaded functions are not considered by C++ compiler 

 as a part of the parameter list. 

 Do not use same function name for two unrelated functions. 

 

2. Explain operator overloading with an example.*** 

The mechanism of giving a special meaning to an operator is called operator overloading. 

The term overloading refers to giving additional functionality to operators like +,++,-,--

,*,>,<,+=,-=. 

Process of overloading involves: 

• Create a class that defines the data type that is to be used in the overloading operations.  

• Declare the operator function operator() in the public part of the class. 

• Define the operator function to implement the required operations. 

 Operator Overloading provides: 

• New function definitions for basic C++ operators like +,++,-,--,>,<,+=,-= and the like.  

• One cannot overload specific operators like membership operator( . ), Scope 

resolution operator( :: ), sizeof operator and conditional operator( ?: ) 

• The overloaded definitions are permitted for user defined data type. 

• Operator functions must be either member function or friend function. 

• The new definition that is provided to an operator does not overrule the original 

definition of the operator. 

Example: 

   #include<iostream.h> 

   #include<conio.h> 

   class negative 

   { 

   int ; 

   public: 

    void accept() 

    { 

     cout<<”Enter a number”; 

    } 

    void display() 

    { 

     cout<<”Number is”<<i; 

    } 

    void operator-() 

    { 

    i=-i; 

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



   } 

  }; 

  void main() 

  { 

  clrscr(); 

  negative n1,n2; -> n1, n2 objects of the class negative 

  n2.accept(); 

  -n2;   ->invokes the function call through- to void operator-() 

  n2.display(); 

  getch(); 

  }   

  

            Output: 

 Enter a number 5 

 Number is -5 

            Working process: 

o Here – is the overloading operator. 

o -n2; invokes the function call to void operator-() 

o The function void operator-() simply negates the data members of a class. 

            Rules of overloading operators: 

 There are certain restrictions and limitations in overloading operators they are 

• Only existing operators can be overloaded. New operators cannot be created. 

• The overloaded operator must have at least one operand of user defined type. 

• The basic definition of an operator cannot be replaced or in other words one cannot 

redefine the function of an operator. Once can give additional functions to an operator. 

• Overloaded operators behave in the same way as the basic operators in terms of their 

operands. 

• When binary operators are overloaded, the left hand object must be an object of the 

relevant class. 

• Binary operators overload through a member function takes one explicit argument. 

 

3. Explain about constructor with an example.*** 

 Definition: 

When an instance of a class comes into scope, a special function called the constructor 

gets executed. A constructor is a special function which is executed automatically whenever an 

object is created. 

Functions of constructor: 

➢ The constructor function initializes the class object. 

➢ The memory space is allocated to an object. 

 Rules for constructor definition and usage: 

➢ The name of the constructor must be same as that of the class name. 

➢ A constructor can have parameter list. 

➢ The constructor function can be overloaded. 

➢ The compiler generates a constructor, in the absence of user defined constructor. 

➢ The constructor is executed automatically. 
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 Types of constructor: 

• Add( )    -     Non Parameterized / Default / Compiler generated – Constructor   

                       Without parameters. 

• Add (int a, int b) -     Parameterized Constructor – Constructor with parameters. 

• Add (add &a)     -     Copy constructor 

 

 Example: 

   #include<iostream.h> 

   #include<conio.h> 

   class simple 

   { 

   private: 

    int a,b ; 

   public: 

    simple() 

    { 

     a=0; 

     b=0; 

     cout<<”Constructor of class simple”; 

    } 

    ~simple() 

    { 

     cout<<”Destructor of class simple”; 

    } 

   }; 

   void main() 

   { 

    simple s; 

   } 

 Output: 

  Constructor of class simple 

  Destructor of class simple 

 Working process: 

• simple() is the constructor function 

• It is automatically executed when the control enters the class cope. 

 

4. Explain about Destructor with an example.** 

 Definition: 

            A destructor is a function it removes the memory of an object which was allocated by 

the constructor at the time of creating a object. It carries the same name as the class tag, but 

with a tilde( ~ ) as prefix. 

 Rules for constructor definition and usage: 

➢ The name of the constructor must be same as that of the class name except its prefixed    

   with a tilde( ~ ) sign. 

➢ A Destructor cannot have parameter list. 

➢ The Destructor function cannot be overloaded. 

➢ The compiler generates a Destructor, in the absence of user defined Destructor. 
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➢ The Destructor is executed automatically when the control reaches the end of class scope. 

 Example: 

   #include<iostream.h> 

   #include<conio.h> 

   class simple 

   { 

   private: 

    int a,b ; 

   public: 

    simple() 

    { 

     a=0; 

     b=0; 

     cout<<”Constructor of class simple”; 

    } 

    ~simple() 

    { 

     cout<<”Destructor of class simple”; 

    } 

   }; 

   void main() 

   { 

    simple s; 

   } 

 Output: 

  Constructor of class simple 

  Destructor of class simple 

 Working process: 

• ~ simple() is the Destructor function 

• It is automatically executed when the control reaches the end of the class scope. 

      9. INHERITANCE 

 1. Explain about the scope and accessibility of the base members in the derived. 

  

Base Class 

Members 

Derived 

Private Protected Public 

Private 

Members 

Are not inherited but 

they continue to exist 
- - 

Protected 

Members 

Inherits protected 

members as private 

Inherits protected and 

public as protected of 

derived 

Protected members are 

retained as the 

protected of the derived 

Public 

Members 

Are inherited as private 

members of the derived 

Inherits as protected 

members of the derived 

Inherits public 

members as public 

members of the derived 
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2. Explain the types of inheritance.*** 

 Inheritance is the most powerful feature of an object oriented programming language. It is a 

process of creating new class called derived class from the existing class or base class. The derived 

class inherits all the properties of base class. It is a power packed class, as it can additional attributes 

and methods and thus enhance its functionality. There are five types of inheritance they are, 

 Single Inheritance 

 Multiple Inheritances 

 Multilevel Inheritance 

 Hierarchical Inheritance 

 Hybrid Inheritance 

i) Single Inheritance: 

 When a derived class inherits only from one base class, it is known as single inheritance. 

 

 

 

 

 

 

 

ii) Multiple Inheritance: 

 When a derived class inherits from multiple base classes it is known as multiple 

inheritance. 

 

 

 

 

 

 

 

 

 

 

iii) Multilevel Inheritance: 

 The transitive nature of inheritance is reflected in the form of inheritance. When a class is 

derived from a class which is itself a derived class, then this is referred to as multilevel 

inheritance. 

 

 

 

 

Base class - Employee 

Derived class - Manager 

Base class - Address Base class - Office 

Derived class - Manager 

Base class – Grand Father 

Derived class - Father 
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iv) Hierarchical Inheritance: 

     When more than one derived class are created from a single base class, then that inheritance 

is called as hierarchical inheritance. 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

v)   Hybrid Inheritance: 

         Any combination of single, hierarchical and multi level inheritances is called as hybrid 

inheritance. 

 

   

 

 

 

 

 

 

 

 

 

  

 

Derived class - Child 

Base class - 

Correspondent 

Derived class – Head Master Derived class – Principal 

Base class - Admin 

Derived class - Principal 

Derived class - Staff Derived class - Student 

Derived class – Head Master 
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VOLUME- I STAR OFFICE 5 MARKS 

1. AN INTRODUCTION TO STAR OFFICE WRITER 

1. Give the steps involved for replacing a given text.  

        The find & Replace feature in Staroffice writer to search for and to replace words in a text 

document. 

To find & Replace text: 

1. Choose Edit -> Find & Replace. The Find & Replace dialog box opens. 

2. In the Search for box, type the text that you want to find in your document. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. In the Replace with box, enter the replacement word or phrase. 

4. Click Find to start the search. 

5. When writer finds the first instance of the word or phrase, do one of the following: 

• To replace the found instance of the text with what you entered in the replace with box, 

click Replace. 

• To replace all the instances of the text with what you entered in the replace with box, click 

Replace all. 

• To skip the found text and continue the search again, click Find again. 

6. Click Close when you have finished the search. 

7. To select the word or phrase that we want to search for in the text document, select the text 

and then choose Edit -> Find & Replace. The that text you selected is automatically entered in 

the Search for box. 

 

2. How would you select the required portion of the text in a document? 

➢ Selecting text with mouse: 

The following steps are to be followed: 

1. Insertion is point is moved to the beginning of the text. 

2. The left mouse button should be clicked, held down and dragged across the text to be 

selected. 

3. When the intended text is selected, the mouse button should be released.  

4. To unselect the wrongly selected text a click should be made outside the selected text. 

➢ Selecting text with keyboard: 

1. Insertion is point is moved to the beginning of the text to be selected. 

2. The shift key is pressed down and the movement keys are used to highlight the required text 
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3. When the shift key is released, the text is selected. 

➢ Selection Shortcuts: 

 The following shortcuts can be used for selection. 

 

  

 

 

 

  

2 . TEXT FORMATTING 

1. How to indent the text using paragraph dialog box? 

The increase indent and decrease indent icons are useful if it is needed to indent text from the 

left. If one wants to indent from the left or right or if one wants to create a special kind of indent, a 

different method is used. 

To indent text using the Paragraph dialog box: 

1. Move the insertion point to the beginning of the paragraph to be indented, To indent several 

paragraphs, select those paragraphs. 

2. Select Format -> Paragraph command. 

3. Click the Indents & Spacing tab in the paragraph dialog box 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

- Decrease indent ( -ve value ) – Text will be indented towards left 

  

 

- Increase indent ( +ve value ) – Text will be indented towards Right 

 

4. Do any one of the following: 

▪ To indent from the left, type the amount to be indented in the Before text spin box or 

use the spin arrows to select a value. 

▪ To indent from the right, type the amount to be indented in the After text spin box or 

use the spin arrows to select a value. 

Action to be performed To select what 

Double click on a word To select a word 

Click once next to the line To select the particular line 

Press Ctrl + A To select the entire document 
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▪ Click the Ok button. 

 The First line option can be used to indent the line of the paragraph. Using the spin 

arrows, if a positive value is specified, the line will be indented. A negative value will result 

in a hanging indent; that is, the first line will hang outside the paragraph. 

2. How would you create the Bulleted and numbered list? 

Bullets and numbers are used to list the important points or messages in a document. A 

bullet precedes each item in the list, and the text indented. Numbered list works well for directions 

or other points one want to present in sequence. Star office writer automatically numbers all the 

items in a list and the text is indented. 

❖  Creating a Bulleted list: 

        The fastest way to create a bulleted list is to be use the Bullets on / off icon              

on the formatting toolbar. For this purpose the following steps are used: 

1. Select the text that to which the bullets are to be added. The Star office writer will add 

bullets to each paragraph within the selection, and not to each line. Star office writer 

will add bullets to any blank lines within the selection. 

2. Click on the Bullets ion on / off from the formatting toolbar. Star office writer creates a 

bulleted list. 

 

 

 

❖ Creating a Numbered list: 

 Star office writer will add numbers automatically and also indent the paragraphs so that 

the text is aligned properly. All one has to do is click the Numbering on / off icon                 

in the formatting toolbar. 

 If one adds / deletes an item within the list, Star office writer renumbers the list.The 

following steps are used to create a numbered list. 

1. Select the text to be numbered. The Star office writer will number each paragraph.          

Blank lines within the selection will be numbered. 

2. Click Numbering on / off icon to number the list. 

  

 

 

 

❖ Removing the Bullets / Numbers: 

 To remove bullets form a list, the list is selected and the Bullets icon is clicked again. 

To remove numbers for a list, select the list and click the numbering button. 

• Tamil 

• English 

•  

• Mathematics 

• Physics 

1. Tamil 

2. English 

3.  

4. Mathematics 

5. Physics 
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❖  Removing the Bullets / Numbers: 

     Star office writer provides various styles for the bullets and numbers, which can be 

selected using Format -> Bullets and Numbering. Bullets and Numbering dialog box opens. 

 

 

 

 

 

 

 

 

 

 

3. CORRECTING SPELLING MISTAKES 

1. How do you carry out spelling check while typing the document? 

Checking spelling while typing: 

Star office writer has an automatic spell-check feature that can check for possible spelling 

mistakes even as the document is being typed. This feature can be turned ON / OFF by clicking on 

the Auto Spell-check icon. 

 When Auto Spell check is ON, Star office writer compares each word you typed with the 

words in the dictionary and underline that do not match with a red squiggly line. These red lines can 

be ignored and the typing work may be continued. The corrections can be made after the document is 

created. These mistakes can be corrected in two ways. 

i) Backspace key is pressed to delete a misspelled word and the word is retyped. 

ii) If the right spelling is not known, star office can help the user with some choices. The 

misspelled word is right clicked. A popup menu appears on the screen. If the correct 

spelling is shown, a click is made on that word. Star office writer makes the replacement. 
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2. How would you carry out spell check after the entire document is typed? 

   Checking the spelling after the entire document is typed: 

             The following steps are used for a spell check. 

             Tools -> Spelling -> Check is selected or       is   clicked. To check a part of the document only    

that portion is selected. The F7 key may also be pressed to select the spelling command. 

 

 

 

 

 

 

 

 

  

                      Not in dictionary text area displays the misspelled word. 

                      Suggestions list displays any alternative spellings. 

• To skip this occurrence but stop on the next one. Ignore once button is clicked. To 

skip all occurrences of this word Ignore All button is clicked. 

• To replace the word with the one of the selected spellings, in the suggestions list that 

spelling is clicked, and Change button is clicked to change this occurrence alone and 

Change All button is clicked to replace all occurrences of the word.  

• If none of the replacement is correct, corrections can be made manually in the not in 

Not in dictionary text area. Add button is clicked to add the word to the dictionary. 

3. Explain how to use the autocorrect feature in star writer. 

Star office writer recognizes some common misspellings and typographical mistakes and 

makes the replacement automatically. For instance, if a word is typed as “the”, star office writer 

automatically replaces this with the correct word “the”.  

If the errors and its corrections are to be added to the autocorrect list the following command 

is used. 

Tools -> Autocorrect 

  

It displays Autocorrect dialog box with 5 tabs. Select the Replace tab 
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The word to be replaced is typed in the Replace text box and the replacement word in         

the With text box. When the same mistake is made Star office writer automatically replace the 

misspelled word with the correct spelling. The only check box in the Autocorrect dialog box is    

Text only. 

4. WORKING WITH TABLES 

1. What are the various functions of the icons in the Table formatting toolbar 

    Once a click is made inside a table a floating toolbar for tables appear at the top of the screen. 

The toolbar contains 13 icons as shown below which can be used for various functions related to the 

table.  

Icons Functions 

 
Table Fixed 

 
Table Fixed, Proportional 

 
Table, Variable 

 Merge Cells – This icon is used to combine two or more cells into a single 

cell. 

 
Split Cells - This icon is used to split a cell into two or more cells. 

 Optimize – Clicking on this icon displays a popup menu with options like 

Space columns equally, Space rows equally, Optimum row height and 

Optimum column width. 

 Insert Row – This icon is used to insert a row below the current row 
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5.  

6.  

7.  

 

 

 

  5. PAGE FORMATTING 

 1. What are the steps used to change the margin? 

  The page can be formatted in two ways; 

• Page style dialog box 

• Using Ruler 

  If the user knows the exact values for the margin then the page style dialog box can be used 

to make a change. 

  The following steps are used; 

i) Format -> Page command is selected. Now a dialog box appears on the screen. 

ii) If necessary click is made on the page tab. The margin setting for the page is 

displayed. 

iii) Tab is pressed to move and highlight the margin that is to be changed. 

iv) The new margin setting is typed on the spin arrows are used to enter a new value. 

v) The highlight the margin and new margin setting are followed for each margin that is 

to be changed. 

vi) The ok button is clicked. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Insert Column - This icon is used to insert a column to the right of the 

current column 

 Delete Row - This icon is used to delete the current row from the table. 

 Delete Column - This icon is used to delete the current column from the 

table. 

 Borders  - This icon displays a floating toolbar with different border 

options for the table. 

 Line style  - This icon is used to choose of the style of the line to be used 

for the border. 

 Border colour – Clicking on this icon displays a palette of colours that 

can be used as a border colour for the table. 
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Now choose File -> Print preview to see the change. This option gives an overall 

picture of the document and visually shows the user how the change has affected the 

document. 

  If the user is not having the exact value for the margins then ruler option is used to change 

 the margins. 

i) If the Ruler is not displayed in the screen View -> Ruler option is clicked. 

ii) The gray area of the Ruler indicates the margin’s top area. 

iii) The mouse pointer is then moved in between the gray and white area of the ruler. 

iv) When the pointer is in the right spot, it changes into a line with arrows on both sides. 

v) The margin guide is dragged to a new location. 

  

6.  SPREADSHEET 

1. Write the advantages of Electronic spreadsheet. 

 The following are some of the main advantages of the electronic spreadsheet over the manual one. 

i) Calculations are automated through the built-in mathematical, financial and statistical 

functions. 

ii) Accurate results to any desired level of decimal points are possible. 

iii) Worksheets can be quite big in size. 

iv) Any part of the worksheet can be viewed or edited. 

v) Worksheet can be saved and retrieved later. 

vi) Any part or whole of the worksheet can be merged with any existing or new sheet. 

vii) Any part or whole of the worksheet can be printed in a desired format. 

viii) Worksheet data can be viewed in the form of graphs or charts. 

ix) The worksheet information can be transferred to any database or word processing 

software. 

2. How can you generate a series of values? Explain with an example. 

Auto fill automatically generates a data series based on a defined pattern. 

1. On a sheet, click in cell, and type a number 

2. Drag the fill handle in the bottom right corner of the cell across the cells that you want 

to fill, and release the mouse button. 

3. The cells are filled with ascending numbers. 

  To copy the contents of a cell, click on the cell. Click and drag the mouse to highlight all the 

cells where you want to copy the contents. Now, select Edit -> Fill -> Down (or Left ). The content 

of first cell will be copied in all the highlighted cells. 

 A continuous group of cells in a worksheet is called a Range. A range is referred to by the range 

address. A range address is the address of the first cell in the range, followed by a colon, followed by 

the address of the last cell in the range. 

  Example: G1,G2,G3,G4,G5   -  G1:G5 

    A4,A5,A6,B4,B5,B6 - A4:B6   

 To create a Fill series using numbers in the cells of a column in an increasing order with a 

difference of 3 between subsequent values 

• Enter initial value in the first cell of the column. 

• Direction – Down 

• Series Type – Linear 

• Increment – 3 

• By clicking Ok the subsequent cells of the column will be automatically generated. 

 

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



 

 

 

 

 

 

 

 

 

 

       As another example, select the range A1:D6 in the worksheet. Click on Edit -> Fill -> Series choose 

• Start value -2 

• Increment – 2 

• Series Type –Growth 

• Direction – Down, now click OK and you will find the worksheet as shown below. 

 

 

 

 

 

 

 

                  You can also automatically fill in series of date and time. For example to list all Sundays 

in a given period, say March to May 2005, proceed as follows; 

• Enter the date as 3/5/05 into a cell. 

• Select this cell and adequate number of cells depending upon the stop value. 

• Select the command Edit –> Fill -> Series 

• Date unit –Day 

• Increment -7, and click ok 

The Sundays of March, April and may 2005 automatically appear in the selected cells as 

shown below. 

 

 

 

 

 

 

 

 

3. What are functions? How can you use them in your worksheet? Explain with an example. 

Star office calc has a wide variety of functions that allow you to perform several frequently done 

calculations. Functions are predefined formulae that are available in Star office calc. 
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To select a function, go to Insert -> Function  menu which displays the function wizard dialog 

box. A list of all functions is displayed in the function box when All is selected in the Category box.  

                  

The Function Wizard shortcut icon is available on the formula bar can also be used to select 

and insert functions. 

Example – To insert the SQRT function to find the Square root of a number,  

i. Place the cursor in the cell where you want to insert the function and click on the   

  Function wizard icon. 

ii. Category – mathematical 

iii. Function – SQRT, select the SQRT function by double clicking it 

iv. The function wizard displays a brief description of the function. 

v. Enter the number or the cell address (Enter the number 64) 

vi. When you click ok the result is displayed in the cell in the worksheet. 

 

  

 

 

 

 

 

 

 

 

 

  

  One of the most commonly used functions is the Sum function. This function calculates the 

sum of given sets of numbers. To use this function either click on the Function wizard icon / click on 

the Sum icon on the formula bar. 

 Star office calc suggests a range of cells for which sum is to be calculated. Press Enter to 

accept this suggested range or press the Backspace key and type in the range that you want. 

 Example: To calculate the total marks in the cell G3, follow the steps given below, 
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i) Click on the cell G3 to place the cursor there. 

ii) Click on the sum icon on the formula bar, =sum(C3:F3) appears in the cell 

iii) Press Enter to accept the suggested range. 

iv) The result is displayed in the cell G3 

 

4. Explain various formatting options available in Star office calc. 

Star office calc provides you with several formatting options for formatting numbers. 

Formatting the contents of a cell, only the display changes, and the content remains unchanged. 

Before formatting the cells in a worksheet, you have to select the cells that you wish to format. 

Listed below are some of the formatting options available in Star office calc. 

This is the Bold icon and is use to display the data in bold. To use this icon, highlight the cells 

and click on the icon.  

 

This icon is used to display the data in italics. 

 

This is used to underline the data in highlighted cells. 

 

This is the Change Font icon. This icon displays a list of fonts that can be used. Select the 

font by clicking on it. 

 

This icon is used to change the font size of the data. To do so, select the data and click on this 

icon. 

 

This is the font colour icon. This can be used to change the font colour. 

 

These are the Align Left, Align Center, Align Right and Justify icons. They are used to 

align the contents of cells. 

 

Number Format: Currency icon. Clicking on this will displays the contents of the selected 

cells in currency format that is a $ sign in front with two decimal digits. 

 

Number Format: Percent icon. Clicking on this will displays the contents of the selected 

cells in percentage format that it multiplies the contents of a cell by 100 and displays the result 

with two decimals. 

 

Number Format: Standard icon. . Clicking on this will displays the contents of the selected 

cells in default format. 

 

Number Format: Add Decimal, Number Format: Delete Decimal icons. They are used to 

increase or decrease the number of decimal digits that are to be displayed in the selected cells. 
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 The Format menu can also be used to format cells. To do so, choose Format -> Cells.  

Clicking on the Numbers tab will display all the available formatting options along with a preview of 

how the data will look if that format is used.  

 

5. Explain how to insert objects in star calc.   

  Star office calc provides tools for inserting objects like Charts images from image editor, formula etc in 

a worksheet for the purpose, click on View -> Toolbar-> Insert Object. A floating toolbar appears with the 

following icons as shown below 

 

 

 

 

1. Insert Chart icon 

2. Insert Formula icon 

3. Insert Floating Frame icon 

4. Insert Movie and sound icon 

5. Insert OLE Object icon 

6. Insert Applet icon 

• Insert Chart icon 

  This icon is used for presenting the data in the worksheet in form of charts of different kinds 

such as Bar Chart, Pie Chart, Lines, X-Y plot etc. More details 

• Insert Formula icon 

   This icon is used for inserting a formula in the worksheet for performing calculations. 

• Insert Floating Frame icon 

   This icon provides to generate a scrolling screen within a worksheet 

• Insert Movie and Sound icon 

   This icon is used to insert sound or video files into the current worksheet.  

• Insert OLE Object icon 

   This icon is used to insert objects from other application into a worksheet.    

• Insert Applet icon  

   This icon is used to import Applet written in java programming language into the worksheet. 

 

         6. How to create chart in Star Office calc? 

  Star office calc software is the ability to generate charts based on numeric data. The purpose of chart is 

to visually present data for understanding. 

 

• Select the data range in the worksheet 

• Click in Insert -> Chart or          Insert Chart icon in the main toolbar. 

• The cursor becomes a small + sign with a small picture of the graph. Place this cursor where you 

want to insert the chart and click. The Auto format Chart window appears as shown below. 

 

        It prompts you to enter the area in the worksheet to be charted. Enter the range as C3:F7 and click next 
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 Autoformat chart window 

                 The next window displays the different types of charts that can be created along with a preview 

of each. Select the type of chart in which you want to present the data. The Preview window shows the 

chart. Click on next. 

  

 

 

 

 

 

 

 Types of Chart & Chart types 

           Click the Show text elements in preview checkbox to preview the formatting changes. 

           For each type of chart say bar chart, pie chart, Column there are different formats available along 

with the preview of each. Here select the desired format and click on Next. 

  

 

 

 

 

 

 

 

            In the Next window, there is a provision to give the title for charts, Titles for X and Y axis and 

legends. Click on create now your worksheet will look as shown below. 
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7. Explain the procedure for deleting a cell, row or a column in a worksheet in star calc. 

             Star office calc allows you to insert one or more cells, rows and column. To insert an empty cell or an 

empty or a column in a worksheet already created, follow the steps given below:  

 Click View -> Toolbar -> Insert Cell. A floating toolbar with four icons appears; they are Insert 

cells Down, Insert Cells Right, Insert Row and Insert Column icons.  

Insert Cells Down: 

 To insert an empty cells in a column and move the existing cells down, place the cursor in the cell 

where you want to insert the new cell and click on the Insert cells down icon. 

Example:   In the marks worksheet to insert an empty cell in D4 and move the contents of the cell range 

D4:D7 down and click the icon. The output will be as shown below: 

  

 

 

 

Insert Cells Right: 

 In order to shift the content of a cell to the right and to create an empty cell select the cell and click on 

the Insert cells Right icon. 

Example:   In the marks worksheet fifth row has to be shifted from C5-F5 to D5-G5. To do so, select 

the cell C5 and click the icon. The output will be as shown below: 

  

 

 

  

       Insert Row:  

 To insert an empty row in a worksheet, select the row where you want to insert the new row click on 

the Insert Rows icon. 
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Example:   In the marks worksheets to insert a news row between rows 4 and 5 selects the row 5 and 

click the Insert Rows icon. The output will be as shown below: 

 

 

 

 

 

Insert Columns: 

       To insert an empty column  in a worksheet, select the column where you want to insert the new                   

Column and click the Insert Columns icon. 

 Example:   In the marks worksheets to insert a new column between the columns E and F selects the 

Column F and click the Insert columns icon. The output will be as shown below: 

 

 

 

 

  7.DATABASE 

1. Write the advantages of computerized data processing. 

     The following are some of the advantages of computerized data processing system, 

i)  Once we collect and enter the data into a computer system, we can perform other operations with 

less manual labour. So manpower is considerably saved. 

ii)  Though it takes some time to develop, test and put the require computer programs to use, the 

processing speed is fast, reducing the processing time, in certain cases from man-years and man-

months to minutes and seconds. 

iii) The chance of errors is less in computerized data processing. 

iv) We can store large amount of data and information in the computer storage medium, which is 

compact. Hence we need not store bundles of paper records, thus saving space. 

v) Today computer networks are so common that we can share data and resources from one 

computer system to the other at a very fast speed and with very little effort, as in the case of 

Airline and Railway reservations. 

vi) It is easy to edit the data including correction, changes and modifications. 

vii) Computerized database is highly effective for searching, sorting and merging files and for 

other data manipulation activities.  

          2.Explain manipulation of database in detail. 

    The database can be manipulated using these 7 techniques they are: 
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• Searching 

• Sorting 

• Merging 

• Filtering 

• Performing calculations on data 

• Editing the data 

• Report Generation

Searching: 

  Searching is the process to select a desired specific data from a database. Searching is done 

using the database commands on the relevant fields. 

Example – To select the student ranking first in the class with respect to the total marks or individual 

subjects 

Sorting: 

 Sorting is the process of arranging the data in a table in some order. 

 Example: To arrange the list of staff members in an alphabetical order or according to the seniority in 

position or date of joining. In case of student database m, you may sort the passed and 

failed students separately. 

Merging: 

 Merging is a process of joining data from two or more tables of the same or different database. 

Example: To prepare a table that shows all the first ranking students of each class, select the first rank 

student from each class and merge all the names together in a single file/table. 

Performing calculations on data: 

          Editing is a process of performing correction on the existing data, deleting the existing data, 

fields or records, adding new fields, records or changing the format of the database. 

Filtering: 

 Filtering is a way of limiting the information that appears on the screen as viewing the entire 

table is unwieldy. Filter is a feature for displaying and browsing a selected list or subset of records 

from a table. The visible records satisfy the condition that the user sets. Those that do not satisfy the 

condition are hidden from the user. 

Report Generation: 

 A report is printed information that is assembled by gathering data based on user supplied 

criteria. 

Example: In a student database, you may generate a report of all the students who have scored marks    

                less than the minimum marks required for a pass, and another report of passed students. 

3. Explain the different types of database in star base. 

          Based on the conceptual structures, the database can be classified as follows: 

 Flat-File Database 

 Relational Database 

 Hierarchical; Database 

 Network Database 

 Object Oriented Database 
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           Flat – File Database: 

              A database file that consists of a single data table is a Flat-file database. Flat-file 

databases can be quite useful for certain single user or small group of institutions for maintain lists 

such as address list or inventories. 

    Example: Spreadsheet 

            It has a limitation over databases consisting of multiple tables as they don’t allow complex 

requests. However, very often you need to process more extensive information from multiple data 

tables which is not possible in Flat-file database. 

 

 Relational database: 

        A relational database structure represents a database made up of a set of related tables. In a 

relational database, one or more common fields existing in two or more tables create a relationship 

between these tables. The common field or fields are called the keys. 

         A primary key is a key that uniquely identifies a record in a database table. The relational 

database structure is the most prevalent in today’s business organizations. 

 

Hierarchical Database: 

  In hierarchical database the record are arranged in tree like structure by type. The 

relationship between the record types is said to be a parent-child relationship, in which any child 

relates only to a single parent type. 

The Hierarchical database structures were primarily used on Mainframe Computers. 

 

Network Database: 

         The Network database is very similar to the hierarchical structure. In which any one record 

type can relate to any number of other record types. 

 

Object Oriented Database: 

   An Object Oriented Programming is a newer structure that has been generating a great deal of 

interest in recent years. The Object oriented structure groups data items and their associated 

characteristics, attributes and procedures into complex items called objects. 

 An object’s characteristics can be sound, graphics and video 

 An object’s attributes might be size, style, quantity & price. 

 A procedure refers to the process of handling the data that can be associated to the object. 
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VOLUME – I STAR OFFICE 

1. Edit – Find & Replace / Ctrl+F  

 

 

 

 

 

 

 

 

 

2. Format -> Paragraph (Indents & Spacing tab) 

 

 

 

 

 

 

 

 

 

 

 

3. Tools ->Spelling-> Check / F7 (Tools -> Spellcheck)  
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4. Format -> Bullets and Numbering (Bullets on/off, Numbering on/off) 

 

 

 

 

 

 

 

 

 

 

5. Tools -> Autocorrect 

  

 

 

 

 

 

 

 

 

 

6. Table Formatting Toolbar ( Insert table, Line Style, Border Colour, Border, background Colour, Merge 

cells, Split cells, Optimize, Align(Top, Center, Bottom), Insert Row, Insert Column, Auto format, Table 

Properties – 13 icons)  
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7. Format -> Page (Page tab, page style dialog box) 

 

 

 

 

 

 

 

 

 

 

 

 

8. Edit -> Fill -> Series 

 

 

 

 

 

 

 

9. Insert -> Function( f(x) – Function wizard in Formula bar ) 
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10. Format -> Cells (Formatting the Worksheet ) 

 

 

 

 

 

 

 

 

 

 

 

11. View -> Toolbar -> Insert Object (Inserting Objects like Chart, Formula, Floating Frame, Movies and 

Sounds, OLE Object, Applet  ) 

 

 

 

12. Field Design (Star base with field types, Primary Key) 
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13. Sort icon (Sort order dialog box (Multiple Sorting) ) 

 

 

 

 

 

 

 

 

 

14. Standard Filter (Default Filter ) 

 

 

 

 

 

 

 

 

 

15. Insert Database Columns 
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16. Steps to create a Presentation (Step 1) 

 

 

 

 

 

 

 

 

 

  

 

17. Steps in creating a Presentation ( Step 2 ) 

 

 

 

 

 

 

 

 

18. Steps in creating a Presentation ( Step 3 ) 
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19. Star office Impress  

 

 

 

 

 

 

 

 

 

 

 

 

 

20. Slide Show -> Slide Show Settings 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



20 . Slide Show -> Custom Slide Show 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

21. View -> Toolbars -> Slide view (Easiest way to assign slide transition) 

 

 

 

       22. Slide Show- > Custom Animation ( Effects for the objects in slide )  
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22. Slide Show -> Slide Transition ( Transition effects for individual slides ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

23. Format -> Styles & Formatting / F11 ( for predefined styles, Outline 1- 9 ) 
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24. Edit ->Navigator ( Move from Slide to slide quickly )  

  

 

 

 

 

 

 

 

25. Format -> Page -> Background  (To change the Background fill for the current slide) 
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26. Tools -> Media Player (Media Playback Toolbar ) 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

               Insert Movie & Sound, Play, Pause, Stop, Repeat, Position Slider, Mute, Volume Slider, Zoom factor 
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VOLUME – I STAR OFFICE 

1. Edit – Find & Replace / Ctrl+F  

 

 

 

 

 

 

 

 

 

2. Format -> Paragraph (Indents & Spacing tab) 

 

 

 

 

 

 

 

 

 

 

 

3. Tools ->Spelling-> Check / F7 (Tools -> Spellcheck)  
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4. Format -> Bullets and Numbering (Bullets on/off, Numbering on/off) 

 

 

 

 

 

 

 

 

 

 

5. Tools -> Autocorrect 

  

 

 

 

 

 

 

 

 

 

6. Table Formatting Toolbar ( Insert table, Line Style, Border Colour, Border, background Colour, Merge 

cells, Split cells, Optimize, Align(Top, Center, Bottom), Insert Row, Insert Column, Auto format, Table 

Properties – 13 icons)  
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7. Format -> Page (Page tab, page style dialog box) 

 

 

 

 

 

 

 

 

 

 

 

 

8. Edit -> Fill -> Series 

 

 

 

 

 

 

 

9. Insert -> Function( f(x) – Function wizard in Formula bar ) 
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10. Format -> Cells (Formatting the Worksheet ) 

 

 

 

 

 

 

 

 

 

 

 

11. View -> Toolbar -> Insert Object (Inserting Objects like Chart, Formula, Floating Frame, Movies and 

Sounds, OLE Object, Applet  ) 

 

 

 

12. Field Design (Star base with field types, Primary Key) 
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13. Sort icon (Sort order dialog box (Multiple Sorting) ) 

 

 

 

 

 

 

 

 

 

14. Standard Filter (Default Filter ) 

 

 

 

 

 

 

 

 

 

15. Insert Database Columns 
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16. Steps to create a Presentation (Step 1) 

 

 

 

 

 

 

 

 

 

  

 

17. Steps in creating a Presentation ( Step 2 ) 

 

 

 

 

 

 

 

 

18. Steps in creating a Presentation ( Step 3 ) 
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19. Star office Impress  

 

 

 

 

 

 

 

 

 

 

 

 

 

20. Slide Show -> Slide Show Settings 
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20 . Slide Show -> Custom Slide Show 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

21. View -> Toolbars -> Slide view (Easiest way to assign slide transition) 

 

 

 

       22. Slide Show- > Custom Animation ( Effects for the objects in slide )  
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22. Slide Show -> Slide Transition ( Transition effects for individual slides ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

23. Format -> Styles & Formatting / F11 ( for predefined styles, Outline 1- 9 ) 
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24. Edit ->Navigator ( Move from Slide to slide quickly )  

  

 

 

 

 

 

 

25. Format -> Page -> Background  (To change the Background fill for the current slide) 

 

 

 

 

 

 

 

 

 

 

26. Tools -> Media Player (Media Playback Toolbar ) 

 

 

  

 

 

 

 

 

 

               Insert Movie & Sound, Play, Pause, Stop, Repeat, Position Slider, Mute, Volume Slider, Zoom factor 
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VOLUME - I 

1. AN INTRODUCTION TO STAR WRITER 

1. The thick horizontal line in the area is called____. 

a) End of the page b) End of the document c) End of the document marker d) None 
2. ____ Key deletes the characters to the right of the insertion point. 

a) Delete b) Backspace c) Enter d) Shift 

3. The ___ is used to create a database. a) Star writer b) Star draw c) Star calc d) Star base 
4. ____ key combination is used to move to the end of the document. 

a) Ctrl + Home b) Ctrl + End c) Shift + Home d) Shift + end 

5. The word to be used as replacement for the word search is given in the ____ text box. 

a) Replacement b) Replace with c) Suggestion d) Search for 
6. ___ key is used to select the entire document in star writer. 

a) Ctrl + A b) Ctrl + L c) Ctrl + E d) Ctrl + D 

7. The page preview option is available under the ____ menu. a) Format b) Edit c) File d) View 
8. The default name for the new document of star writer is ____. 

a) Untitled b) Untitled 1 c) No – name d) Default 

9. ___ is not a word processor. a) Note pad b) Star writer c) MS- word d) Word star 

10. The term word processing refers to the activity carried out ____. 
a) To view b) To create c) To manipulate d) All the above 

11. ___ is the keyboard shortcut for saving the document.  

a) Ctrl + V b) Ctrl + C c) Ctrl + A d) Ctrl + S 

12. ____ Command can be used to open a new document.  
a) File – new – text document   b) File – text – New c) File – star writer – new d) none. 

13. In star writer the flashing vertical bar is called ___. 

a) Marker b) Pointer c) Key d) Insertion point 
14. How many sets of scroll arrows in star writer?    a) 2 b) 3 c) 4 d) 10 

15. While saving a file for the first time ___ dialog box appears. a) Save as b) Edit c) Save d) open 

16. In star writer how many document can be opened at the same time? a) 1 b) 2 c) 3 d) many 

17. ____ key deletes the characters to the left of the insertion point.    
a) Backspace b) Delete c) Home d) Insert 

18. The toggle between type over mode and the insert mode using the __ key. 

a) Back space b) delete c) Home d) Insert 
19. ___ Command is used to copy the selected text in star writer. 

a) Edit – copy b) Tools – Copy c) File – copy d) Format – copy 

20. ___ Command is used to cut the selected text in star writer. 

a) Edit – cut b) Tools – Cut c) File – cut d) Format – cut 
21. ____ is used to search & replace for a particular text in star writer. 

a) Format – find & replace b) Insert – find & replace 

c) Edit – find & replace d) Edit – search & replace 
22. The shortcut key for cut, copy and paste is ___. a) Ctrl + x , ctrl +c & ctrl + v 

b) Ctrl + c , ctrl +x & ctrl + v c) ctrl + x , ctrl +c & ctrl + v d) ctrl + a , ctrl +c & ctrl + v 

23. The ___ gives the information about the current mode.     

a) Title bar b) Tool bar c) Status bar d) Menu bar 
24. Entering a new data or modifying the existing text in a document is called__. 

a) Text editing  b) Editing c) Document editing d) none. 

25. To move down one screen (scrolling) in the existing text in a document press ___ key.  
a) Page up b) Page down c) Home d) End 

26. The key that helps to move to the beginning of the document is ____. 

            a) Ctrl + End b) Ctrl + Home c) End d) Home 
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2. TEXT FORMATTING 

1. ___menu formatting option is available.   a) Format b) Tools c) Window d) Edit 

2. ____ feature is used to mark the important portions of the document. 

a) Formatting b) Highlighting c) Selecting d) Help 
3. How many types of page orientation in star writer?  a) 2 b) 4 c) 5 d) 6 

4. Click the increase indent icon, the paragraph is indented by __inch. a) 1/2 b) ¼ c) ¾ d) 1 

5. Which is a set of characters in certain style?   a) Text b) Symbol c ) Document d) Font 
6. ___ font looks professional.     a) Fajita b) Arial c) Wingdings d) Font 

7. The size of a font is measured in__.    a) Pixel b) Points c) Dots d) none. 

8. There are ___ points to an inch.     a) 24 b) 48 c) 72 d) 96 

9. A hard return is inserted every time when __ is pressed.    a) Enter b) DEL c) Home d) Insert 
10. ___ key combination is used for justified the selected program. 

a) Ctrl + E b) Ctrl + J c) Ctrl + L d) Ctrl + C 

11. The __ is a named set of defaults for formatting text. 
a) Highlighting b) Styles c) Formatting d) Editing 

12. A negative indenting value will result in a __ indent. a) Hanging b) right c) left d) None 

13. Star office default line spacing is ___ line.   a) 1 b) 2 c) 3 d) none. 

14. The formatting option are else be achieved by clicking on ___. 
a) Edit – character b) Format – character c) Format – style d) none. 

15. In a certain style a set of characters and number is called as ___.a) Column b) row c) Font d) Cell 

16. Soft returns are inserted as ___. a) Backspace b) Comma c) Line breaks d) None 
17. The default top and bottom margin is ___ inches.  a) 2.25 b) 2 c) 1.5 d) 1 

18. Bullets & numbering option is available under __ menu. a) Format b) Edit c) File d) View 

19. Which of the following is a decorative font?  a) Fajita b) Symbol c) Wingdings d) Arial 

20. ____ types of alignment in star writer?    a) 2 b) 3 c) 4 d) 5 
21. To remove the highlighting select the text and select the ___ from the color palette. 

a) No highlighting b) Fill no c) Fill d) No fill 

22. ___ font style like symbols.     a) Fajita b) Symbols c) Wingdings d) Both b & c 

23. ___ option can be used to indent the line of the paragraph. 
a) First line b) Line spacing c) paragraph d) Increase Indent. 

24. The default left and right margin is ___ inches.   a) 2.25 b) 2 c) 1 d) 1.25 

25. The default alignment of star writer is ___ alignment. a) Left b) Center c) Justified d) Right 
26. ___ command is used to indent paragraphs.  

a) Tools – paragraph b) Format – paragraph c) Tools – Character d) Format – character 

27. How many types of formatting options are in star writer?  a) 3 b) 2 c) 4 d) 5 

28. In star writer the key pressed to enter a hard return is ___.  
a) Space bar b) Enter c) Backspace d) ESC. 

29. ___ Indent is used for numbered lists.  a) Hanging b) Special c) First line d) Positive. 

30. ____ opens the star office help.    a) F5 b) F4 c) F2 d) F1 
31. Hanging indents are encountered when we type in ____. 

a) Negative values b) 0 c) Positive values d) Fixed. 

32. By default star writer ___ space the text in the document. 

             a) Double b) single c) 1.5 d) Fixed 

Ans:1.(c)     2.(a)     3.(d)     4.(b)     5.(b)     6.(a)     7.(c)     8.(b)     9.(a)    10.(d)   11.(d)   12.(a)  13.(d)            

        14.(a)   15.(a)   16.(d)   17.(a)   18.(d)   19.(a)   20.(a)    21.(c)   22.(c)   23.(c)   24.(a)  25.(b)  26.(b)    
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3. CORRECTING SPELLING MISTAKES 

1. ___ key is used to open the spell check dialog box.  a) F1 b) F2 c) F5 d) F7 

2. The button used to skip the spelling change only for the current word is ___. 
a) Ignore all b) ignore once c) Change d) Change all 

3. The spelling mistakes can be corrected in ____ ways.  a) 2 b) 3 c) 4 d) Many 

4. Misspelled word is displayed if it is ___. 

a) Tool bar b) Dialog box c) Check box d) Not in dictionary 
5. What color is used to underline the words that do not match with the words in the 

Dictionary In star writer?  a) Red b) Green c) Black d) Blue 

6. The spell check option can be turned ON or OFF by clicking on the ___ icon. 
a) Open b) Auto spell check c) File d) Copy 

7. Auto correct option is available under __ menu.  a) File b) Tools c) Edit d) Format 

8. To add the error and its correction to the auto correct list the ___ command is used. 

a) Tools – Correct b) Tools – auto correct / auto format c) Help – auto correct d) none. 
9. To skip the current occurrence but stop on the next one___ button is clicked in spelling 

    check Dialog box.  a) Ignore all b) replace all c) Ignore once d) Replace all 

10. The replacement option is available in ___ tab.   

 a) Replace b) Exception c) Auto correct d) Auto format 
11. In the spell check dialog box ___ list displays any alternative spellings. 

a) Suggestions b) Change c) add d) Choice. 

12. To add a word to the dictionary ___ button is clicked in the spelling check dialog box. 
a) Add b) Replace c) language d) Suggestions. 

13. __ is selected for checking the spelling after the document is typed. 

a) Tools – Spelling – check b) Format – spell – check c) Edit – spell – check d) none. 

14. The only check box in the auto correct dialog box is ___. 
a) Whole words only b) Back words c) Text only d) Match case 

15. Which text box is used to enter replacement word in auto correct dialog box? 

a) With b) replace c) Replace with d) Change 
16. The number of tabs in auto correct dialog box is __.  a) 2 b) 5 c) 6 d) 4  

17. Star writer uses ___ option to automatically correct some spelling mistakes. 

a) Auto correct b) Auto spell correct c) Auto check d) Auto spell 

 

 

 

 

4. WORKING WITH TABLES 

1. ___ key combination is used to move backward through the cells in a table. 
a) Tab b) Shift + tab c) Ctrl + tab d) page + tab 

2. ___ dialog box can be used to set the width of the column to an exact size 

a) Table-format b) Insert-table c) Insert-format d) Insert-column 
3. ___ command is used to delete the selected column a) Table-delete-column 

b) Table-delete-rows c) Table-columns-delete d) Delete-column 

4. ___ command is used to insert a table in star writer a) Insert-table-table 

b) Table-insert c) Insert-table-rows & columns d) Table-insert-table 

Ans: 1.(a)     2.(b)     3.(a)     4.(a)     5.(d)     6.(a)     7.(b)     8.(c)     9.(a)    10.(b)   11.(b)   12.(a)  13.(a)      

        14.(b)    15.(c)  16.(c)   17.(d)   18.(a)   19.(a)   20.(c)    21.(d)   22.(d)   23.(a)   24.(d)  25.(a)  26.(b)    

        27.(c)    28.(b)   29.(a)   30.(d)  31.(a)    32.(b)    

Ans: 1.(d)     2.(b)     3.(a)     4.(d)     5.(a)     6.(b)     7.(b)     8.(b)     9.(c)    10.(a)   11.(a)   12.(a)   13.(a)      

         14.(c)   15.(a)   16.(b)   17.(a)       
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5. ___ is used to insert more than one row in the table a) Table-rows-insert 
b) Format-rows-insert c) Format-rows-insert d) Table-insert-rows 

6. The entire table is selected using the ____ menu.  a) Edit b) Format c) File d) Table 

7. ___ is used to insert more than one column in the table a) Tools-tables-columns 

b) Format-column-insert c) Format-insert-column d) Table-insert-column 
8. The key that helps to move one cell to the right is ____ a) tab b) Home c) Page up d) End 

9. Which key is pressed to delete entries in the table? a) Delete b) Tab c) Back space d) Ctrl + alt 

10. The simplest way to add a row at a last row of a table is to press ___ button 
a) Insert b) Ctrl + Tab c) Shift + Tab d) Tab 

11. ___ command is used to delete the selected table? a)Table-Delete-Table 

b) Format-Table-Delete c) Format-Delete-Table d)Tools-Delete-Table 

12. ___ key is pressed to resize the column without changing the width of the table in text 
document?    a) alt + ctrl b) alt c) ctrl d) shift 

13. The___ icon is the insert table icon in the floating toolbar for insertion function. 

a) 3 b) 1 c) 2 d) 4 
14. Which dialog box helps in formatting table properties? 

a) format table b) Table format c) format d) file format 

15. Which key is hold down to resize the row?  a) Shift b) Tab c) ctrl d) Alt 

16. ___ command is used to select the column width of the table? 
a) Table-Table properties b) Table-format c) Format-table d) Table-properties 

17. The icon that combines two or more cells into a single cell_____ 

a) Split cell b) merge cell c) line style d) none 

18. The icon that is used to split a cell into two or more cell into a single cell_____ 
a) Split cell b) merge cell c) line style d) none 

19. How to make the selected rows in same size? a) Rows-space equally 

b) Space-row-equally c) Format-row-space d) space equally- row 
20. The total number of icons present in the formatting toolbar is _ a) 13 b) 12 c) 14 d) 11 

21. Which is the intersection of a row and a column? a) Border b) cell c) table d) entire table 

22. The table is a grid with the specified number of_____ 

a) Columns & Border b) Rows & Columns c) Rows & Borders d) Rows 
23. How will u make all columns even? a) Space equally-column 

b) Width equally-column c) column-width equally d) column-space equally 

24. The third icon in the floating toolbar for intersection function’s_____ 
a) Insert table b) Insert column c) Insert border d) none 

25. The command to create a simple table is______ a) Insert-table-table 

b) Table-insert-table c) Table-insert d) Format-insert-table 

 

 

 

 

 

5. PAGE FORMATTING 

1. What is the name of the top portion of a page in star writer?  

a) Title b) Footer c) Header d) Heading 

2. ___ methods are used to change the page margins.   a) 3 b) 4 c) 2 d) 6 
3. ___ is true to insert a page number in a document. 

a) Insert – fields – page number b) Format - fields - page number 

c) Tools- fields - page number d) View - fields - page number 

 

Ans:1.(b)     2.(a)     3.(a)     4.(d)     5.(d)     6.(a)    7.(d)     8.(a)     9.(a)    10.(d)    11.(a)   12.(a) 13.(b)       

        14.(b)  15.(d)   16.(d)   17.(b)   18.(a)   19.(a)   20.(c)   21.(b)   22.(b)   23.(d)   24.(d)   25.(b)       
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4. If the length of the document is less than the width, the orientation is called ____ 
a) Layout b) Landscape c) Portrait d) Margin 

5. How many types of page orientations are there?    a) 1 b) 2 c) 3 d) 4 

6. The top and bottom margins are __ inch.     a) 1 b) 1.2 c) 1.25 d) 1.5 

7. In star writer to display the ruler on the screen select ruler under ___ menu. 
a) File b) Edit c) Format d) View 

8. The default width of a page in default orientation is ___ inch. 

a) 8.5” X 11” b) 11 “X 8.25” c) 11” X 8.5” d) 8.5” X 1” 
9. The default page orientation is __.   a) Book b) Landscape c) Handout d) Portrait 

10. Margins can be changed using ____. 

a) Page style dialog box b) Ruler c) a & b d) Table formatting toolbar 

11. The default left and right margins are __ inch. a) 1” b) 1.5” c) 1.25” d) 1.35” 
12. __ menu command is selected to display the page style dialog box. 

a) Page – format b) Page – style c) Format- Page d) Format – Style 

13. Which area of the ruler indicates the margins top area? a) Black b) White c) Grey d) a & b 
14. Usually the length of a document will be more than the width. This orientation is called 

___ a) Page b) landscape c) Portrait d) Formatting 

15. How many spin boxes are displayed in the page style dialog box? a) 2 b) 6 c) 4 d) 5 

 

 

 

 

6. SPREAD SHEET 

1. The intersection of rows and columns in a spread sheet is called ______. 
a) Cell b) Row c) Grid d) Column. 

2. A formula in spread sheet always begins with ____.   a) + b) - c) ^ d) = 

3. Which of the following operators combines two texts?   a) + b) & c) ^ d) = 
4. The function used to find the square root of a number in star calc___ 

a) SQR b) SQT c) SQRT d) SRT 

5. The cells A4, A5, A6, B4, B5 and B6 are referred in a worksheet as _____. 

a) A4: B6 b) A1: B6 c) A1: A6; B1: B6 d) A4: A6; B4: B6 
6. Which of the following icons is used to generate a scrolling screen with in a worksheet? 

a) Insert Plug – in b) Insert floating frame c) Insert OLE object d) Insert chart 

7. The active cell in a spread sheet is identified by ____. 

a) Insertion pointer b) Cell pointer c) Mouse pointer d) Keyboard pointer 
8. Which of the following data can be typed into a spreadsheet cell? 

a) Numbers b) Text c) Formula d) All of these. 

9. How many columns are there is VisiCalc?    a) 63 b) 254 c) 32000 d) 256 
10. Which bars have shortcut icons for frequently done tasks in the spread sheet? 

a) Menu bar b) Formula bar c) Object bar d) Function bar & Object bar. 

11. Which key is pressed while editing the contents in a cell?  a) F1 b) F2 c) F5 d) F7 

12. The operator < > is used to check ___. 
a) Equal b) Greater than c) Less than d) In equality 

13. Which of the following formula calculates the sum of the numbers in the cell A1 of sheet 1 And   

      A2 of sheet 2? 
a) = sum (sheet1.A1 + sheet2.A2) b) = sum (sheet1.A1; sheet2:A2) 

c) = sum (sheet1.A1; sheet2,A2) d) = sum (sheet1.A1; sheet2.A2) 

14. Which icon used to import applets written in Java programming language into the worksheet? 

a) Insert floating frame b) Insert OLE object c) Insert Applet d) Insert formula 

Ans: 1.(c)     2.(c)       3.(a)     4.(b)     5.(b)     6.(a)     7.(d)     8.(a)     9.(d)    10.(c)   11.(c)   12.(c)    

        13.(d)    14.(c)    15.(b) 
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15. The format for entering date in star calc is___. 
a) yy/mm/dd b) yy/dd/mm c) dd/mm/yy d) mm/dd/yy 

16. Which facility of star calc helps to format the worksheet with different predefined styles and Colors? 

  a) Chart b) Auto format c) Applet d) Multiple sheets. 
17. The bar used to displays the current cell and its content is ___ bar. 

a) Menu b) Object c) formula d) function 

18. The option under the file menu used to quit the star office is ___.a) Close b) Quit c) exit d) End 

19. A continuous group of cells in a worksheet is called ____.  
a) Column b) Row c) Data sheet d) Range 

20. Graphic representations of numbers are known as _____.  

a) Charts b) Graphs c) Bar diagrams d) Cells. 
21. To do the calculations for different worksheet in a particular sheet, we use____. 

a) 2D formula b) Function c) 3D formula d) Selection 

22. The cell referencing that does not get changed when copied is ____. 

a) Relative cell addressing b) absolute cell addressing c) Reference d) Comparative. 
23. Below the Menu bar in Star calc is ___. 

a) Function bar b) Object bar c) Formula bar d) Main toolbar 

24. Which is the following is the reference operator?   a) % b) < > c) & d)! 
25. A ___ lets you create a value in one cell that is calculated based on the values in other cells. 

 a) Text b) Value c) Formula d) All the above. 

26. Fill command in star calc is available under the menu ___.a) Edit b) Format c) File d) View 

27. The first electronic spread sheet is ____.   a) Visi calc b) Star calc C) Lotus d) Excel. 
28. Which of the following operator combine cell areas in star calc? 

a) Reference b) Comparative c) Text d) Arithmetic 

29. Non numerical entries are called ____.  a) Text b) Characters c) Labels d) all of these 
30. The ___ command is used to generate a series. a) Edit b) Series – Down c) Series – Left d) Fill 

31. ___ & ____ reference operators in star calc.  a): , ! b);, ! c) *, = d) none. 

32. Auto format option is available on the ___ menu. 

a) File b) Edit c) Format d) Style. 
33. A cell address can be made absolute by using the ___ sign in front of rows and columns Names.  

a) $ b) 3 c) * d) % 

34. The cell can hold up to ____ characters.    a) 255 b) 257 c) 258 d) 256 

35. The default cell referencing is?    a) Relative b) Absolute c) Range d) a or b 
36. ___ is the short cut icon on the formula bar that can be used to insert function 

a) Function b) Autopilot c) Function Autopilot d) Insert function 

37. ___ icon is used to import data from different file ULR into a worksheet.  
a) Plug – in b) Applet c) OLE object d) Image 

38. If the data entered in a worksheet is a number the program recognizes it as a ____. 

a) Text b) Number c) Label d) Integer. 

39. In order to edit, data in a worksheet ____ keys is used. a) F1 b) F2 c) F4 d) F7 
40. ____ of a formula begins with an equal sign followed by values, operators and cell references 

a) Formula b) Function c) operator d) Syntax. 

41. Which one of the following arithmetic operators is meant for exponentiation? 
a) * b) ^ c) / d) % 

42. ___ icon displays the contents of the selected cells in currency format. 

a) Number format: dollar b) Number format: currency c) Number format: pound d) none 

43. To enter the same formula or data in various cells we can use ___ feature of star calc. 
a) Copy & paste icon b) automatic fill c) fill series d) fill 

44. Star calc has a wide variety of ____.  a) Formula b) options c) buttons d) functions. 
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45. Improve is a product of ___. 
a) Lotus corporation b) Sun micro systems c) Borland d) Microsoft 

46. To draw in spread sheet click_____. 

a) Insert picture icon b) Color icon c) Draw d) Show draw function icon 

47. ___ Icon is used to insert an image from image editor. 
a) Insert image editor b) Insert applet c) Insert OLE d) Insert chart. 

48. We can enter time in the form of ___. 

a) HH: MM: SS b) SS: MM: HH c) MM: SS: HH d) MM: HH: SS 
49. ____ operators return numerical results. 

a) Text b) Comparative c) Arithmetic d) Reference. 

50. To change the column width click on_______. a) Format – width – column 

b) Column - Format - width c) Format - Column – Height d) Format - Column - width 
51. A spread sheet contains ____ sheets.  a) 4 b) 5 c) 6 d) Multiple. 

52. ____ is a built in formula.    a) Values b) Range of cells c) Functions d) Library 

53. Which option of file is used to view a worksheet before printing? 
a) Print preview b) Open c) Page view d) Save 

54. To separate two different sheets in a formula ___ is used.  

a) Colon b) Hyphen c) Semicolon d) Comma 

55. A data file created using spreadsheet is called____  
a) Worksheet b) Application file c) file d) Project 

56. The number format currency icon displays contents with ___ decimal digits. 

a) 1 b) 2 c) 3 d) 4 

 

 

 

 

 

 

 

7. DATABASE 

1. Which of the following is not a valid data type in star base? 
a) Character b) Boolean c) Picture d) Real 

2. Which field is used to uniquely identity a record in a database table? 

a) Many key b) Primary key c) Common key d) Key 

3. Which database type contains single data table? 
a) Hierarchical b) Relational c) Flat – file d) Network 

4. Which of the following option is used to remove the filter? 

a) Remove filter b) delete filter c) Remove filter / sort d) Delete filter / sort 
5. What is the name of the process for joining data from two or more tables? 

a) Joining b) Editing c) Merging d) Adding 

6. What is the name of the screen that displays the fields of record in a well spaced our manner?  

a) Report b) Form c) Query d) Filter 
7. Which of the following are two types of reports?  

   a) Static and Dynamic   b) Static and primary c) Primary and Secondary d) Dynamic and primary 

8. What is the name of a set of data for each database entry? 
a) Field b) File c) record d) Table. 

9. Which language is used to query the database?   a) C++ b) SQL c) HTML d) C 

10. SQL stands for___. a) Structured Query language b) Sorted Query language 

c) Sorted Question language d) Structured Question language. 

Ans: 1.(a)     2.(d)     3.(b)     4.(c)      5.(b)     6.(b)     7.(b)     8.(d)     9.(a)    10.(d)   11.(b)   12.(d)    

        13.(d)    14.(c)   15.(d)  16.(b)    17.(c)    18.(c)   19.(d)   20.(a)    21.(c)   22.(b)   23.(d)   24.(d)   

        25.(c)    26.(a)   27.(a)    28.(c)    29.(c)   30.(d)   31.(a)    32.(c)   33.(a)   34.(d)   35.(a)   36.(d)    

        37.(c)    38.(b)   39.(b)    40.(d)   41.(b)   42.(b)    43.(b)   44.(d)   45.(a)    46.(d)  47.(c)     

        48.(a)    49.(c)   50.(c)    51.(d)    52.(c)    53.(c)   54.(c)    55.(a)   56.(b)         
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11. The field type that is not allowed by star base is ____.      a) Text b) Binary c) Project d) Image. 
12. The computer that primary use the hierarchical database is __.  

a) Super b) Mainframe c) personal d) Mini 

13. The team data is derived from the word_____.  a) Datum b) datem c) Datas d) Datus. 

14. A column in a star base table represents a ___.  a) Structure b) File c) Field d) record. 
15. The process used to select the desired and specific data from a database is ___. 

a) Merging b) Sorting c) Editing d) Searching 

16. In set of processed data is called ___.  a) Data b) datum c) Information d) Database 
17. Each row in a database table represents ____. a) File b) Record c) Field d) Table. 

18. A database that contains of a single data table is ____.    

a) Relational b) Flat – file c) Hierarchical d) Network 

19. Which is a type of query?     a) Table b) Forms c) Filter d) Report 
20. How many steps are there in the report wizard window? a) 6 b) 7 c) 8 d) 9 

21. What is a way of limiting the information that appears on screen? 

a) Searching b) Filtering c) Merging d) Report 
22. Star base window is divided into how many panes?  a) 2 b) 3 c) 4 d) 5 

23. Which icon is used to remove the sorting in star base? 

a) Delete Filter / sort icon b) Delete sort icon c) Remove sort / filter icon d) none. 

24. In star base, which is printed information that is assembled by gathering data based on? 
      user Supplied criteria?      a) Filter b) Query c) Form c) Report 

25. Which of the following are users constructed statements in star base? 

a) Filters b) queries c) Forms d) Report 

26. DBMS is an acronym for ___. 
a) Database maintaining system b) Database management system 

c) Database manipulating system d) Database merging system 

27. Data’s are of ____ types.      a) 3 b) 5 c) 12 d) 10 
28. Which of the following is not a step in data processing? 

a) Collection b) Verification c) Computation d) Validation 

29. The number of field types used in star base is ____.  a) 20 b) 30 c) 12 d) 13 

30. The filter used with a condition is called ___ filter. 
a) Auto b) Sort c) Default d) Remove. 

31. In database, which option is used to define the maximum size of a field? 

a) Default value b) Length c) Type d) Value 
32. Which involves data collection, verification, and validation and report generation? 

a) Data b) Data processing c) Database d) Table 

33. ____ is defined by its characteristics, attributes and procedures. 

a) Form b) record c) Object d) File. 
34. The numeric data type can be ___.    a) Integer b) float c) Date d) All the above 

35. Users can define their own data types called __ data type. 

a) Built – in b) System defined c) user defined d) primitive 
36. ___ is a set of processed data that convey the relationship between data considered. 

a) Information b) Data c) Datum d) Program 

37. If we use a computer to prepare, store, process and print the data, we call it as ___ 

      data Processing.  a) Data b) manual c) Hand d) Computerized 
38. The processing speed is fast in __ data processing. 

a) Computerized b) Manual c) Both a & b d) either a or b 

39. In computerized data processing, it is easy to edit the data including ___. 
a) Correction b) Change c) Modification D) All the above 

40. Manipulating of a database includes ____. a) Sorting b) Merging c) Editing d) All the above 
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41. Editing is the process of ____.   

a) Adding new data  b) Deleting the existing data 

      c) Changing the format  d) all the above 

42. Based on the conceptual structures, the data bases can be classified into ___ types.  
a) 3 b) 2 c) 4 d) 5 

43. The ____ database structure is the most prevalent database in today’s business Organizations. 

a) Flat – file b) relational c) Hierarchical d) Object oriented 
44. In ____ databases, records are organized in a tree like structure by type. 

a) Hierarchical b) Relational c) Network d) Flat file. 

45. ____ database is useful for certain single user or small group situations. 

a ) Relational b) Flat file c) Hierarchical d) Flat file. 
46. The ____ database is similar to the hierarchical structure excepts that any one type can relate to    

      any number of types.  a) Network b) Object oriented c) flat file d) relational 

47. An object is defined by its _____. a) Attributes b) Characters c) Procedures d) all the above. 
48. The data management tasks in a DBMS fall into one of the ___ categories. 

a) 2 b) 3 c) 4 d) 5 

49. The data management tasks in a DBMS involves____. 

a) Entering data into the database b) Reordering records in the database. 
c) Obtaining subsets of the data d) All the above. 

50. __ provides the means for multiple users to access and share data in the same database by way of  

       networked systems.   a) Star calc b) Star base c) DBMS d) Ms – office 

51. In star base window, the ____ pane displays tables, queues, forms, and report. 
a) Right b) Left c) Top d) Bottom 

52. In star office base window, on the right top is ____ pane. 

a) Tables b) Forms c) Tasks d) Reports. 
53. Once the database is created, the next step is to create the _____. 

a) Data b) Tables c) Related tables d) Reports 

54. Using tables, star office base allows us to ______. 

a) Design forms b) Query the database c) Prepare reports d) All the above. 
55. We can also give a brief description of the contents of the _____. 

a) Table b) Record c) Field d) database 

56. Star base allows us to use ____ different field types. 
a) 5 b) 10 c) 20 d) any number 

57. ____ accepts small integer’s up to a few thousands. 

a) Integer b) Small int c) Tiny integer d) Big integer 

58. ____ Data type accepts only whole numbers. a) Integer b) Decimal c) Real d) Image. 
59. Single precision decimal values are accurate up to a length of ___ places. 

a) 5 b) 7 c) 9 d) 14. 

60. Double precision decimal values are accurate upto a length of ___ places. 
a) 7 b) 14 c) 28 d) 56. 

61. While designing the table we enter values for the ____. 

a) Field name b) Field type c) Description d) All the above 

62. ____ option is used to specify the maximum characters that can be entered in that field. 
a) Entry required b) Length c) Default value d) Size of the field. 

63. ____ menu is used to modify the table design. a) File b) Format c) Edit d) Insert 

64. After entering the records into the table star base allows you rearrange them by ____. 
a) Merging b) Filtering c) Searching d) Sorting. 

65. To display the records in the original order, click on___. 

a) Unsorted icon b) Filter icon c) Remove Filter / Sort icon d) any of the above 
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66. The language, supported by DBMS is____.  a) C++ b) Java c) SQL d) ADA 
67. ___ is special views of the data in a table.   a) Database b) Sorting c) Queries d) Reports 

68. The output from a____ does not affect the original table. 

a) Table b) Sort c) Query d) Data 

69. The first step of query wizard is ____.      
a) Sort wizard   b) Sorting order c) Field selection d) Aliases 

70. A ____ is a type of query. a) Sort b) Filter c) Report d) Search 

71. ___ is used to select and display records which match a certain condition. 
a) Filter b) Sort c) Report d) Search 

72. Filters ____ be saved for later use.    a) Can b) Cannot c) May d) may not 

73. Star office allows you to use the filters of ____ types.     a) 2 b) 3 c) 4 d) many 

74. Filter used with a condition is called ____ filter. 
a) Auto b) Conditional c) Default d) filter 

75. The filter window is very similar to the one used for specify condition in a ___. 

a) Sort b) Report c) Form d) Query 
76. To remove the filter, click on ____ icon. 

a) Remove filter b) Remove filter/sort c) Remove sort d) Remove default filter 

77. A _____ is a screen that displays the fields of a record in a well spaced out manner. 

a) Query b) Filter c) Form d) Report 
78. Select the ___ check box in the set up a sub form window to insert another form within 

      this form. a) Add subform b) add form c) Insert form d) insert sub form. 

79. ___ helps us to generate report. 

a) Report wizard b) report auto pilot c) report temple d) report window. 
80. Select ____ in the paste special dialog box, to see the data automatically changes in the 

Document, when it is modified in the spread sheet. a) OLE b) Link c) Link and paste d) DDE link. 

81. Field types include ____.  a) Text b) Numeric c) Logical d) all the above. 
82. __ and ___ is conceptual model for older systems. 

a) Flat file, Network b) Hierarchical, network c) relational, object oriented d) none. 

83. Select ____ option on the task pane to create a query. a) Create query in SQL view 

b) Create query in design view c) Use wizard to create query d) Create query. 
 

 

 

 

 

 

 

 

 

8. INDRODUCTION TO MULTIMEDIA 

 

1. Which of the following is a computer – based presentation technique? 

a) Multimedia b) Data processing c) Tutorials d) Slides 

2. MMS means____. a) Multimedia service b) Multimedia messaging system 
c) Multimedia system d) Multimedia messaging services. 

3. Which if the following is the most common version of e-learning packages? 

a) CBT / WBT b) WBT / SMSC c) CST / WBT d) MMS / SMS 
4. How many image formats are most commonly used?  a) 5 b) 4 c) 3 d) 2 

5. Which file creates a perfect reproduction of the original images? 

a) JPG b) Nx view c) Shock wave d) GIF 

Ans: 1.(c)     2.(b)     3.(c)     4.(c)      5.(c)     6.(b)     7.(a)     8.(c)     9.(b)    10.(a)   11.(c)   12.(b)   13.(a)      

        14.(c)    15.(d)  16.(c)   17.(b)    18.(b)    19.(c)   20.(a)   21.(b)   22.(b)   23.(c)   24.(c)  25.(b)   26.(b)    

        27.(a)    28.(c)   29.(a)   30.(c)    31.(b)    32.(b)   33.(c)  34.(d)  35.(c)   36.(a)    37.(d)  38.(a)   39.(d)    

        40.(d)   41.(d)   42.(d)   43.(b)    44.(a)    45.(b)   46.(a)    47.(d)  48.(b)   49.(d)   50.(c)  51.(b)   52.(c)    

        53.(b)   54.(d)   55.(b)   56.(c)    57.(b)    58.(a)    59.(b)   60.(b)  61.(d)   62.(b)   63.(c)  64.(d)   65.(c)    

        66.(c)    67.(c)   68.(c)   69.(c)    70.(b)    71.(a)    72.(a)   73.(a)   74.(d)   75.(a)   76.(b)  77.(c)  78.(a)     

        79.(a)   80.(d)   81.(d)    82.(b)    83.(c)    
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6. GIF means ___. a) Graphic interchange format b) Graphic interchange File 
c) Graphic information file d) Graphic information format. 

7. Expand JPEG… a) Joint processor expert’s group b) Joint photographic experts group 

c) Joint photographic expression group d) Joint photo experts group 

8. Which image files is a lossy format?  a) JPEG b) GIF c) MPEG d) Nx View 
9. How many categories of image file compressions are there?  a) 4 b) 3 c) 5 d) 2 

10. How many attributes control the characters of sound?   a) 2 b) 3 c) 4 d) 5 

11. Which of the following is called frequency? a) Amplitude b) resistance c) pitch d) modulation 
12. Conversion of a analog waves to a digital format called__  

a) Echo b) Sound forge c) Frequency d) Modulation 

13. Which of the following animations are also referred to as slide or path animations? 

a) Cell-based animations b) Object based animations c) 3D animation d) 2D animation 
14. How many steps involved in creating a 3D animation?  a) 2 b) 4 c) 3 d) 5 

15. Which of the following is not a step to create a 3D animation? 

a) Modeling b) Animating c) Rendering d) Accessing 
16. Which of the following is a technique to blend 2 or more images to form a new image? 

a) Warping b) Morphing c) Modeling d) Animating 

17. How many frames per second causes the video to look jerky?a)< 9 b) < 10 c) < 15 d) < 20 

18. How many color depth results in the image looks murky? a) < 225 b) < 16 c) < 256 d) < 8 
19. How many types of video compressions?    a) 3 b) 2 c) 4 d ) 6 

20. Which compressions provide some loss of quality?  

a) Loss less b) Cell – based c) Lossy d) Object – based 

21. MIDI stands for _______. 
a) Musical instrument digital interface b) Musical interface digital instrument 

c) Modeling instrument digital interface d) Modeling interface digital information 

22. Which year the MIDI format was developed?    a) 1972 b) 1982 c) 1984 d) 1974 
23. Which sound format cannot contain sounds?    a) Wave b) AIFF c) AU d) MIDI 

24. The real audio format has the extension___. a) rm or .rf b) .ram or .rf c) .rm or .ram d) .rm or .rad 

25. What is the extension of Au format sound file?    a) .AUD b) .AU c) .AUD d) .ADO 

26. AIFF stands for _____. a) Audio interface format file b) Audio Interchange file format 
c) Au interchange file format d) Audio information file format 

27. What is the extension of AIFF format files?a) .aif or .af b) .aiff or .aid c) .aiff or .aif d) .aid or .aif 

28. What is the extension of SND format sound file?  a) .sn b) .sdn c) .sou d) .snd 
29. What is the extension of Wave format sound file?  a).wva b) .wav c) .wave d) .dat 

30. MPEG stands for…… 

a) Moving pictures experts group b) Model pictures expression group 

c) Moving pictures expression group d) morphing pictures experts group 
31. What is the extension of MP3 & MPEG format sound file?  

a) .mp3 or .mpeg b) .mpeg or .mpga c) .mpge or .mpg d) .mpg or .mpeg 

32. AVI stands for ……… a) Audio video interface b) Audio video information 
c) Audio video interleave d) Audio video interchange 

33. What is the extension of AVI format sound file?  a) .AV b) .AU c) .AVI d) .AIV 

34. Sounds and video in multimedia applications can be played by using ___. 

a) Inline or helper b) inline or outline c) helper or outline d) inline only 
35. Which tag is used to add in line sound to a web page? 

a) <inline> b) <bgsound> c) <sound> d) <helper> 

36. _____ tag is used to launch helper application.  
a) <embed>/<applet> b) <applet>/<object> c) <embed>/<applet> / <object> d) <embed>/<object> 

37. ___ graphs helps in rendering the image effectively on the screen. 

a) Image B) Static c) Vector d) Scalar 
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38. What is the name of the process for converting analog waves to s digital formatting? 

a) sampling b) Sound forge c) Amplitude d) Frequency 

39. Name the technique that blends two or more image to form a new image. 

a) blending b) Warping c) Morphing d) modeling 
40. Which of the following is the commercial multimedia content development software? 

_______. a) Flash b) Dream weaver c) Maya d) All of these 

41. The technique that provides an environment experienced by users as similar to reality is 
______. a) Virtual reality b) Vector graphics c) Animations d) modeling 

42. Name of the technique of distorting a single image to represent something else is ____. 

a) Modeling b) rendering c) Morphing d) Warping 

43. The sound that we hear is ____ wave patterns.  a) Analog b) digital c) hybrid d) pitch 
44. In ___ doctors can get trained by viewing at a virtual surgery. 

a) Engineering b) Medicine c) Scientist d) Online magazines 

45. Two attributes control the characteristics of sound ___.  
a) Amplitude & volume b) Frequency & pitch c) Frequency & Wave  

d) Amplitude & Frequency 

 

 
 

 

 

 

9. PRESENTATION 

1. Which key is used to create a new presentation using a template? 

a) Shift + Alt + N b) Shift + Ctrl + N c) ctrl + Alt + N d) Shift+ Tab 

2. Which of the following view allows creating and editing slides? 
a) Normal b) Outline c) Notes d) Handouts 

3. Which command is used to insert a picture in a slide?  

a) Insert _ Picture b) Format _ Picture c) Insert _ Picture _ from file d) Insert _ from _ Picture 

4. How will you change the background color of the entire slide? a) Format _ Background 
b) Format _ Page _ Background c) Format _ Page d) Insert _ Page _ Background 

5. Which key combination is used to print slides in Star Office? 

a) Alt + P b) Ctrl + P c) Shift + P d) Shift + Ctrl + P 

6. To send text outline into presentation, select ……………….. 
a) File _ Send _ Outline to presentation b) File _ Outline to presentation 

c) File _ Presentation d) File _ Sent _ Presentation 

7. In presentation the view that allows us to view miniature image of the all slide is ____ 
a) Slide sorter b) Master page c) Notes view d) Layout 

8. Which of the following is used to import objects from other application into a Presentation?  

 a) Insert ODBC object b) Insert OLEDB object c) Insert OLE object d) Insert DBMS object 

9. The shortcut key for opening style list is …………….. a) F8 b) F7 c) F5 d) F11 
10. Open stylist by choosing ……………… a) Format _ Styles and Formatting 

b) Format _ Styles c) Tools _ Styles and Formatting d) Insert _ stylist 

11. Choose ………… to hide a slide in the slide show 
a) Tools_ Show/Hide slide b) Insert _ Show/Hide Slide 

c) Slide Show _ Show/Hide Slide d) any of the above 

12. The number of option displayed in the first page of the presentation wizard is…….. 

a) 2 b) 3 c) 4 d) 5 

Ans: 1.(a)     2.(b)     3.(a)     4.(d)     5.(d)     6.(a)     7.(b)     8.(a)     9.(d)    10.(a)   11.(c)   12.(d)    

         13.(a)   14.(c)   15.(d)  16.(b)   17.(c)   18.(c)   19.(b)   20.(c)    21.(a)   22.(b)   23.(d)   24.(c)   

         25.(b)   26.(b)   27.(c)   28.(d )  29.(b )  30.(a)  31.(a)   32.(c)   33.(c)    34.(a)   35.(b)   36.(c)    

         37.(c)   38.(a)   39.(b)   40.(d)    41.(a)   42.(d)  43.(a)   44.(b)   45.(d) 
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13. Which of the following options display ‘created with Star Office‘message during the pause   
      between each presentation?  a) Automatic b) Effect c) Show Logo d) Default 

14. The view used to reorder is …………….a) Normal b) outline c) notes d) handouts 

15. To open media player window, choose …………  

a) Tools-Media player b) Edit-Media player c) Insert- Media player d) View- Media player 
16. Which is not a Background fill option? a) Color b) Gradient c) Picture d) Hatching 

17. In Star Office Impress, the window allows to quickly jump from one slide to other slide or 

       Move between open file is ……             a) Desktop b) Navigator c) Preview d) Moving slider 
18. The styles outline one through outline ………. Enables you to give the outlined headings 

      and topics on your slides a uniform look      a) 8 b) 9 c) 7 d) 6 

19. A ……… determines the text formatting style for title outline and the background for one 

      or for all of slides a) Slide b)Master slide  c) slide design d) slide background 
20. Which one of the following displays various transition effects that can be attached to a slide? 

a) Custom animation b) Slide Transition c) Animation effects d) Slide sorter 

21. We can choose a …………. while creating a new slide. 
a) Notes b) Layout c) Outline d) custom 

22. In Star Office Impress, to start a presentation, press ……a) F5 b) F1 c) F2 d) F3 

23. To rename a slide choose slide _ ………………… 

a) Rename slide b) new slide c) rename d) slide rename 
24. To open style list in presentation, press ……..  a) F10 b) F11 c) F12 d) F13 

25. Which of the following views allows recording slides, editing slide titles and heading? 

a) Normal view b) Notes view c) Handouts view d) Outline view 

26. Which of the following commands is used to open HTML export view? 
a) File - Export b) HTML - Export c) File - HTML Export d) File - HTML Export 

27. _______ is the Star Office application that allows us to create attractive presentations? 

a) Star Office Impress b) Star Office Writer c) Star Office Draw d) Star Office Calc 
28. To change the slide order, in the switching presentation view tab click ………… 

a) Slide Sorter b) Layout c) Outline d) None of these 

29. ______ View is used by a presentation to add additional information to a slide 

a) Notes b) Handout c) Outline d) Layouts 
30. The media player supports _____ different media formats. a) 2 b) 3 c) 4 d) many 

31. Select ………. option to apply the colors supported by browser 

a) Use HTML b) use HTTP c) use browser colours d) use link 
32. The _____ Section in the lower half of the page allows you to specify the final output 

       medium for presentation. 

a) Output medium b) slide c) select an output medium d) select a medium 

33. The ____ page of the wizard allows you to specify the transition effects to be used in  
       presentation.      a) First b) second c) third d) fourth 

34. To select a slide transition section at the ………… of the page allows you to choose the 

      Transition effect and speed in the slides.   a) Bottom b) right top corner c) top d) left 
35. To create a new presentation using a template, choose ………. 

a) File _ New _ Presentation b) File _ New _ Template 

c) File _ New _ Document d) File _ New _ Templates and documents 

36. Star Office Impress allows us to …….. and modify Microsoft PowerPoint presentation. 
a) Import b) export c) report d) compile 

37. Star Office Impress Window contains …………. Panes  a) 2 b) 3 c) 4 d) 5 

38. The task pan on the right displays ………… pages  a) 2 b) 3 c) 4 d) 5 
39. ………Page of the tasks plan displays various transition effects that can be attached to a Slide  

a) Custom animation b) Slide Transition c) Layout d) Master 
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40. To insert an object in a slide, choose ………… 
a) Insert _ Object b) Insert _ Chart c) Insert _ OLE d) Insert _ Formula 

41. Insert OLE object is used to import objects like ………………….. 

a) Formula b) text c) Microsoft application objects d) all the above  

43. ……….. Menu is used to start a presentation. a) View b) Tools c) Slide Show d) Window 
44. Open navigator by choosing ……….. Menu a) View b) Insert c) Edit d) Format 

45. The onscreen presentation starts automatically in the …………… mode 

a) Minimized b) full screen c) maximized d) normal 
46. End the presentation by pressing the ………………… key.    a) End b) Enter c) Esc d) Break 

47. Click ………… to get slide view 

a) Insert _ Toolbar _ Slide View b) Insert _ Slide View 

c) View _ Slide Show d) View _ Tool Bars _ Slide View 
48. Select ……… to run slide show in the order that you defined. 

a) Slide Show b) Custom Slide Show c) View Show d) any the above 

49. The new slide uses the page layout of the ………………. Slide 
a) First b) previous c) last d) any of the above 

50. If you want a slide show from the current slide, use …………… 

a) Edit _ Options _ Star Office Impress b) Tools _ Options _ General 

c) Slideshow _ Options_ Star Office Impress _ General 
d) Tools _ Options _ Star office Impress _ General 

51. For movie files, the bar contains a list box where we can select the ……… for the playback.  

a) Volume slider b) zoom factor c) position slider d) any of the above 

52. To insert movie in a slide, click on …………….. 
a) Insert _ Picture Sound b) Insert _ Audio and Video 

c) Insert _ Movie and Sound d) Insert _ Picture and Sound 

53. To play a movie or sound file click play on the ………. Tool bar  
a) Movie b) Sound c) Media d) Media Playback 

54. A presentation can be exported in different format like ___ 

a. All the above b. PDF c. JPEG d. SWF 

55. _________ is the standard resolution while exporting a presentation into a webpage 
a. Medium  b. Low c. High d. None 

56. In the publication type option, Choose____ to create HTML page without frames. 

a. Web cast     b. Automatic   c. Standard HTML format    d. Standard HTML with frames 
  

 

 

 

 

 

 

II. FILL IN THE BLANKS 

1. A presentation can be created using a Template or a scratch. 

2. Navigator icon is available in Function bar  
3. A number of HTML pages are created that are connected to one another by Hyperlinks 

4.To create a New slide design, Choose Format->Slide Design 

     

 

 

Ans: 1.(b)     2.(a)     3.(c)      4.(b)     5.(b)      6.(a)     7.(a)      8.(c)     9.(d)     10.(a)    11.(c)    12.(b)    

        13.(c)    14.(b)   15.(a)   16.(c)   17.(B)    18.(b)   19.(b)    20.(b)  21.(b)    22.(a)    23.(a)    24.(b)   

        25.(d)    26.(a)   27.(a)    28.(a)   29.(a)    30.(d)   31.(c)    32.(c)   33.(c)    34.(c)    35.(d)    36.(a)    

        37.(b)   38.(c)   39.(b)    40.(a)    41.(d)   42.(b)   43.(c)    44.(c)   45.(b)    46.(c)    47.(d)    48.(b)    

        49.(b)    50.(d)   51.(b)   52.(c)    53.(d)    54(a)    55(a)     56(c)   
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     VOLUME - I 

1. AN INTRODUCTION TO STAR OFFICE WRITER 

2 MARKS 

1. What is text editing? 

2. What is word processor? 

3. How would you switch over from insert mode to type over mode? 
4. How would you select the required portion of the text in a document? (Using keyboard) 

5. How would you select the required portion of the text in a document? (Using mouse) 

6. What is Insertion point? 

7. How will you create a new document? 
5 Marks 

1. What are the steps to be followed for search and replace a given word? 

2. How would you select the required portion of the text in a document? 

2. TEXT FORMATTING 

2 Marks 

1. What is the difference between hard formatting and soft formatting? 

2. What is text formatting? 

3. What is indenting text? 
4. What is text highlighting? 

5. What is alignment? Write the types. 

6. What is style? 

7. What is hanging indent? 
8. What are the steps to be followed to change the line spacing? 

5 Marks 

1. How can we indent text with the paragraph dialog box? 

2. How can we apply different styles for bullets and numbers? 

3. CORRECTING SPELLING MISTAKES. 

2 Marks 

1. What does automatic spelling correcting mean? 

2. How can we correct mistakes? 
3. What is auto correct option? 

5 Marks 

1. How would you carry out the spelling check after the entire document is typed? 

2. How would you add a word in the autocorrect list of the star office? 

4. WORKING WITH TABLES 

2 Marks 

1. How will you create table in a document? 

2. How will you add a required number of rows and columns in a table? 
3. How to change the width of a column in a table? 

4. How to make the selected rows and columns of the same size? 

5. How will you delete entire table? 

6. How to change the height of a row in a table? 
5 Marks 

1. What are the various functions of the icons in the table formatting toolbar? 

5. PAGE FORMATTING 

2 Marks 

1. What is page formatting mean? 
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2. What is page orientation and list its type. 
3. What is meant by header and footer? 

4. How will you insert page numbers in footer? 

5 Marks 

1. Explain the process of changing margin. 

2. How will you insert header and footer in entire document? 

6. SPREAD SHEET 

2 Marks 

1. What is an electronic spreadsheet? 

2. Can we change the data present in a cell? If so, how? 
3. What is function? Write the example 

4. What is date arithmetic? 

5. What is cell pointer? 
6. How will you change the width of a column in a worksheet? 

7. What is cell referencing? Write and explain the types. 

8. What is the use of auto format sheet? 

9. What are the advantages of using electronic spreadsheet? 
5 Marks 

1. What are the various facilities for drawing available in star office calc?  

     How can they be used? 
2. What are the formatting options available in star calc? 

3. How will you insert cell, row and column in a worksheet? 

4. Explain the procedure to be followed to draw a chart. 

5. How can you generate a series of values? Explain with an example. 
6. What is function? Explain with suitable example. 

7. What are the various icons in the insert object floating toolbar? 

7. DATABASE 

2 Marks 

1. What is data processing? 
2. What is database? 

3. What does it means to filter database records? 

4. What is Primary key? 
5. What is meant by filter? Write the types 

6. How will you sort the records? 

7. What is multiple sorting? 

5 Marks 

1. What is Database? Explain the types. 

2. How can s database be queried? How can we create query in database? 

3. How will we manipulate the database? Explain. 
4. Explain Report generation. 

5. Explain Form designing. 

6. List the advantages of computerized data processing. 

8. INTRODUCTION TO MULTIMEDIA 

2 Marks 

1. What is multimedia? 

2. What MMS? 

3. Write a note on how to create a 3-D animation. 

4. What are the uses of morphing and warping? 
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5. What is compression? Explain the types. 
6. Define MIDI. 

7. What is MP3/MPEG format? 

8. Explain multimedia formats. 

9. What is inline sounds and video? 

10. What is digital sampling? 

9. PRESENTATION. 

2 Marks 

1. What is presentation? 

2. How to create new presentation? 
3. What is custom animation? 

4. What is slide transition? 

5. Explain various types of views? 
6. Write short notes: Master page, layout. 

7. How will you rename a slide? 

8. How to start a presentation? 

9. What is meant by rehearse timings? 
10. How will we change the background of a presentation? 

11. Explain the media playback toolbar. 
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VOLUME II 

1. OBJECT ORIENTED CONCEPTS USING C++ 

1. ___ is a tool to solve a wide range of problems 

  a) Computer b) Calculator c) Abacus d) CPU 
2. The solutions to the problems are in the form of computer program or ____. 

a) System software b) Application software c) Hardware d) Software 

3. ___ Statements provide instructions to the computer on the operations that need to be 
    performed on the data items. 

a) Looping b) Assignment c) control d) Unconditional 

4. A group of the data and the operations are termed as _____ 

a) Object b) data c) Function d) Operations 
5. The operations represent the _____ of the object. 

  a) Behaviour b) Data c) State d) Function 

6. Which is a kind of a self-sufficient subprogram with a specific functional area? 
a) Object b) Inheritance c) Functions d) Encapsulation 

7. The mechanism by which the data and functions are bound together within an object 

     is called as____. a) Overloading b) Overriding c) Encapsulation d) polymorphism 

8. The ability of an object to respond differently to different message is called ____. 
      a) Function b) Polymorphism c) Draw( ) d) Overriding 

9. The process of acquiring base class properties is called _____. 

a) Inheritance b) Class c) Polymorphism d) Object 

10. The ___ are power packed, as they include the functionality of the base class along with its  
       .own unique feature. 

a) Derived classes b) Base class c) Class d) Object 

11. Which one operates on a set of known input data items? 
a) Computer program b) human ware c) System d) output data 

12. The derived class is ____ Packed. 

a) Completely b) Uniquely c) Power d) Cover 

13. A template for entities that have common Behaviour is ____ 
a) Methods b) Object c) Class d) Attributes 

14. C++ belongs to which category of programming language? 

a) Structured b) Object oriented c) modular d) Procedural 
 

 

 

 

2. Overview of C++ 

1. C++ was developed by ____.  

a) James Goling b) Bjarne stroutstrup c) John Kemney d) Thomas kushz 

2. Rick Masciti coined the name _____.  a) C++ b) BASIC c) COBOl d) Visual 

3. The basic types are collectively called as ____. 
a) Token b) Variables c) Characters d) Variable 

4. ____ is the smallest individual unit in a program. 

a) Token b) Character c) Control d) Variable 
5. Which one gives special meaning to the language compiler? 

a) Compiler b) Keywords c) Variable d) Constants 

6. ____ modifiers allows the variable to exist in the memory of the computer, even if its 

function or block looses its scope.   a) auto b) static c) extern d) register 

Ans: 1.(a)     2.(b)     3.(a)      4.(a)     5.(a)      6.(a)     7.(c)      8.(b)     9.(a)     10.(a)    11.(c)    12.(b)    

        13.(c)    14.(b)    
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7. Which one holds the values or constants in memory boxes? 
a) Variable b) While c) Switch d) go to 

8. The ____ symbol is used to declare a pointer variable.  a) * b) & c) # d) / 

9. What are the assign bitwise assignment operator?  a) &= b) ^= c) 1= d) all 

10. Built in data type is also called as ____ datatype. 
a) Fundamental b) Secondary c) Integer d) Void 

11. Static and register variables are automatically initialized to ____ value when they are 

declared ___       a) 1 b) 2 c) 3 d) 0 
12. _____ type is further divided into int and char. a) Integral b) Int c) Char d) Float 

13. When a=5,c=-- what will be the value of c?  a) 5 b) 6 c) 4 d) 8 

14. What type of integer starts with OX?  a) octal b) Hexadecimal c) Binary d) decimal 

15. ____ Data types are structure, union, class and enumeration. 
a) User defined b) Built-in c) Derived d) Integer 

16. The constant that should not have fractional part is ______. 

a) Float b) Double c) Integer d) Exponent 
17. How many operators are classified in C++?  a) 11 b) 13 c) 14 d) 15 

18. How many fundamentals data types are there in C++? a) 1 b) 2 c) 3 d) 4 

19. Which is the conditional operator?   a) ? b) > c) < d) ?: 

20. The operands and the operators are grouped in a specific logical way of evaluation is 
called……. a) Class b) Association c) Assignment d) Arithmetic 

21. When a = 6 and c = a++ what is the value of c? a) 6 b) 7 c) 8 d) 5 

22. What will be the value stored in C when a = 20,b=20, c(a<b)?a*a:b%a;______ a) 

a) 0 b) 400 c) 40 d) 20 
23. Which punctuator is used to terminate a C++ statement? a) ; b) : c) * d) , 

24. How many C++ data types are broadly classified?  a) 2 b) 3 c) 4 d) 5 

25. ___ data type enables to invent his own data type define values 
a) User defined b) Derived c) Floating d) Integral 

26. ____ allows users to define the user defined data type identifier. 

a) Type definition b) Identifier c) Data d) Class 

27. ____ data types helps users in creating a list of identifiers 
a) Int b) Float c) Char d) Enumerated 

28. ____ class is another qualifier that can be added to a variable declaration 

a) Storage b) Sub c) Static d) register 
29. Static register variables are automatically initialized to ____ value when they are 

declared.        a) 1 b) 2 c) 0 d) 3 

30. Auto variable get undefined values known as _____ 

a) Garbage b) Auto c) Register d) Static 
31. ____ Storage class defines local variable known to the block in which they are 

defined?  a) Static b) Auto c) Extern d) register 

32. Storage class variables defined with in a function or a block cease to exist, the 
moment the function or block looses its scope____.a) Auto b) Static c) Extern d register 

33. ___ Modifiers allows the variable to exist in the memory of the computer, even if 

its function of block looses its scope.    a) Auto b) Static c) Extern d register 

34. ____ storage class global variable known to all functions in the current program 
a) Auto b) Static c) Extern d register 

35. ___ storage class variables are defined in another program. 

a) Auto b) Static c) Extern d register 
36. Built in data type is also called as ____ data type 

a) Fundamental b) Secondary c) Integer d) Void 

37. How many storage specifiers are there in a C++? a) 3 b) 4 c) 5 d) 3 
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38. ___ type is used to declare a generic pointer in C++. 
a) Float b) Void c) Static d) Int 

39. Signed, unsigned, long and short are some of the ____. 

a) Data b) Derived data c) Modifiers d) Void 

40. What is the range for char data type in C++? 
a) -126 to 127 b) 128 to -127 c) -128 to 127 d) -127 to 128 

41. What is the range for int data type in C++? 

a) -32767 to 32768 b) -32768 to 32767 c) 32768 to 32769 d) 32767 to -32768 
42. The long int, signed long int has ___ bytes. a) 2 b) 4 c) 3 d) 8 

43. ___ is a variable that holds a memory address. 

a) Pointer b) Char c) Float d) Long double 

44. Integer values are stored in ___ bit format in binary form. 
a) 8 b) 16 c) 32 d) 64 

45. ___ bit is also called as the most significant bit or sign bit. 

a) 15th b) 16th c) 18th d) 19th 
46. The 16th bit will have a value ___ if negative value is stored. a) 1 b) 0 c) -1 d) 2 

47. The unsigned char, and char data types has____ bits. a) 8 b) 16 c) 32 d) 64 

48. What is the length of double data type?    a) 32 b) 8 c) 16 d) 64 

49. __ is an operator which returns the memory size requirements in terms of bytes.  
a) size of( ) b) Long c) Size d) Double 

50. In an example long double a; int b; a=6,b=4 what is the output of size of (a*b)? 

a) 8 b) 10 c) 4 d) 2 

 

3. BASIC STATEMENTS 

1. How many methods are there for assigning data to the variables in C++? 

a) 2 b) 3 c) 4 d) 5 

2. Data is read from the keyboard during run time by using the object____ 
a) cin b) cni c) nci d) nic 

3. The declarations for the object cin are available in header file called as____. 

a) istream.h b) iostream.h c) stream.h d) stream 

4. ____ file comprises of all standard declarations and definitions for predefined functions. 
a) Header b) Footer c) istream d) iostream 

5. Program statement that causes jumps are called as ____ statements or structures 

a) Control b) assignment c) increment d) decrement 

6. The multiple branching statements are _____ statement. 
a) If b) Switch c) For d) While 

7. How many kinds of loops are there in C++?  a) 1 b) 2 c) 3 d) 4 

8. A loop embedded within another loop is called____. 
a) Nested b) Loop c) Break d) Continue 

9. A program written in high level language is called as ____. 

a) Object code b) Source code c) Executable code d) All of these 

10. How many times the following loop will be executed? For(i=1;i<6;i++) 
a) 1 b) 5 c) 6 d) 7 

11. The break statement would exit only____. 

a) Current loop b) Current function c) Current program d) None 
12. In C++ which file comprises the combined properties of istream and ostream? 

a) stdio.h b) string.h c) conio.h d) iostream.h 

13.Which of the following is a preprocessor directive? 

 a. $   b. #   c. <   d. @ 
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14.Which of the following statements marks the end of the function and also transfers 
     control to the statements after call statements? 

a) Return b) Break c) Continue d) Header 

15.Which of the following functions will be executed first automatically, when a C++ 

      program is executed?  a)Void b) main c) Recursive d) Call by reference 
16.How many times the following loop will be executed ? 

int ctr = 1; 

for(;ctr<10;ctr++) 
{ 

cout<<ctr; 

} 

a) 1 b) 10 c) 11 d) 9 
17. Which of the following is not a section of a c++ program? 

a. Include files b. Declaration c. Main functions  d. Compilation 

18 . Find the output 
int ctr = 1; 

for(;ctr<10;ctr++) 

{ 

cout<<ctr; 
ctr = 1; 

} 

a) 1 infinitive b) 1,2,3,4,5,6,7,8,9,10 c) 1,2,3,4,5,6,7,8,9 d) 1,1,1,1,1,1,1,1,1,1 

19. Basic statements in C++ are constructed using________ 
a. Keywords  b. Tokens  c. Scope  d. Identifiers 

Insertion operator - << 

Extraction Operator - >> 
20. How many sections are there in a C++ program______ 

a. 1   b. 2   c. 3   d .4 

 

21. Which variable are defined only when memory is fetched to store data? 
 a. Integer  b. Floating point c. Character  d. Pointer 

22.   The machine readable form of a program is called a ________ 

 a. exe file  b. object code c. source code d. C++ file 
23. The _______ is linked with essential libraries to generate an executable file 

 a. object   b. source  c. exe file  d. machine code 

24. The ______ statement forces the next iteration , skipping any code following it 

 a. break  b. jump  c. while  d. continue  
25. _______ is an entry controlled loop 

 a. for   b. do   c. while  d. a & c 

26. In _______ loop test condition marks the last statement of the body of the loop 
 a. for   b. while  c. do   d. a & b 

27. A looping block has _______ segments 

 a. 3   b. 1   c. 2   d. 0 

28. ________ executes a set of instructions repeatedly for a certain number of times 
 a. if statement b. loops  c. switch  d. while 

29. Switch selection expression should be of ______ type 

 a. float  b. enum  c. double  d. long 
30. ______ statement chooses between two alternatives, executes the chosen block based on the 

condition a. switch b. if..else  c. do   d. while 

31.___ is the simplest of all decision statements 
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 a. switch  b. while  c. do   d. if.. 
32. A________ statement assigns value on the right hand side to of an expression to its left  

 a. looping  b. assignment c. control  d. if 

 

 

 

 

 

 

4. FUNCTIONS 

1. ___ are the building blocks of C++ programs. 

a) Functions b) if – else c) For d) Switch 
2. The starting point for the execution of a program is ____. 

a) Main ( ) b) Void ( ) c) Public d) Class 

3. The calling function parameters are called as____ parameters 
a) Formal b) Actual c) Dummy d) Duplicate 

4. In call by value method, the flow of data is always from the ___ statement to the 

    function definition.  a) Call b) return c) function d) go to 

5. In ___ method the called function argument formal parameters become alias to the 
actual parameter.   a) Call by value b) Call by reference c) return d) call 

6. The functions that return no value is declared as ____. 

a) Null b) Void c) Static d) public 

7. An ____ looks like a normal function in the source file but inserts the functions code 
   directly into the calling program. a) inline b) online c) mainline d) line 

8. To make a function inline one has to insert the keyword ___ in the function header. 

a) inline b) online c) mainline d) line 
9. Inline keyword is just a request to the ____. a) Compiler b) Interpreter c) Linker d) Object 

10. How many types of scopes in C++?      a) 2 b) 3 c) 4 d) 5 

11. In __ scope a local variable is defined is defined within a block. 

a) File b) Function c) Local d) Class 
12. A block of code begins and ends with___. a) { } b) [ ] c) ( ) d) { ] 

13. ___ scope of variables declared within a function is extended to the function block and 

      all sub blocks therein. a) File b) Function c) Local d) Class 
14. A variable declared above all blocks and a function has the ____ scope. 

a) Scope of a file b) Local scope c) Function scope d) Class scope 

15. Which of the following is NOT true, related to functions? 

       a) The actual parameters can be passed in the form of constants to the formal 
        parameters of value type. 

       b) The actual parameters can be passed only as variables to formal parameters of 

       Reference type. 
       c) The default value in the formal parameters can be given in the form of variable 

       initialization 

       d) The default value for an argument can be given in between the argument list 

16. In the following code, the scope of the variable a is _______. 
if(x<y) 

{ 

int a ; 
a++; 

} a) Local scope b) Function scope c) File scope d) Class scope 

17. A function can be invoked from another function using its__________ 

Ans: 1.(a)     2.(a)     3.(b)      4.(a)     5.(a)       6.(b)     7.(b)       8.(a)     9.(b)     10.(b)    11.(a)    12.(d)    

        13.(b)    14.(a)   15.(b)    16.(d)   17.(d)    18.(a)   19.(b)    20.(c)   21.(d)     22.(c)   23.(a)      24.(d)   

        25.(d)     26.(c)   27.(c)    28.(b)   29.(b)   30.(b)    31.(d)    32.(b)         
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a) Variables b) Name c) return d) Value 
18. Which function executes faster but requires more memory space? 

a) Normal function b) Void function c) Regular function d) Inline function 

19. The scope of any variable used in the entire program is ____ 

a) Local b) File c) Function d) Class 
20. The return type of the function prototype float power (float,int) is ___. 

a) Char b) Double c) int d) float 

Read the following coding and give the answer 
#include<iostream.h> 

int n1=10; 

void main() 

{ 
int n2 =20; 

if(n1>n2) 

{ 
int temp;temp=n1;n1=n2;n2=temp; 

} 

Cout<<’\n’<<n1<<’\n’<<n2; 

} 
21. file scope_______.   a) n1 b) n2 c) temp d) None of these 

22. Function scope _______.  a) n1 b) n2 c) temp d) None of these 

23. Local scope _________.  a) n1 b) n2 c) temp d) None of these 

24._________ is a scope resolution operator 
 a. ;  b. { }  c. ::  d. && 

25. Declaration of a function is made through a function________ 

 A. declaration b. initialization c. definition  d. prototype 
 

 

 

 

5. Structured Data types – Arrays 

1. An ____ is a collection of variable of the same type that are referenced by a common 

     name.  a) Variable b) constant c) array d) program 

2. Arrays are of ____ types.  a) 3 b) 4 c) 2 d) 1 

3. ____ dimensional array comprising of finite homogenous elements. 
a) 1 b) 2 c) Multi d) 3 

4. ___ dimensional array comprising of elements each of which is itself a one dimensional 

    array. a) 1 b) 2 c) Multi d) 3 
5. int num_array[5]; is this array how many integer values can be stored? 

a) 4 b) 5 c) 6 d) 1 

6. The size of the array should always be ____. 

a) Positive b) negative c) whole number d) real number 
7. Each element of the array is accessed by the _____ name and position of the element in 

     the array.  a) Array b) variable c) Dimensional d) Subscript 

8. int days [ ] = {1,2,3,4,5,6,7); in this statement, what is the size of the array? 
a) 6 b) 5 c) 4 d) 7 

9. cin>>number[4]; in this array processing which reads the ___ elements. 

a) 4th b) 5th c) 1st d) 3rd 

10. number [3]++ in this array processing which increments the value stored as 

Ans: 1.(a)     2.(a)     3.(b)      4.(a)     5.(b)      6.(b)     7.(a)       8.(a)     9.(a)     10.(c)    11.(c)    12.(a)    

        13.(b)    14.(a)   15.(d)    16.(a)  17.(b)    18.(d)   19.(b)     20.(d)   21.(a)     22.(b)    23.(c)   24.(c)   

        25.(d)      
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_____ element By 1. a) 4th b) 5th c) 3rd d) 2nd 
11. The process of arranging the data in a given array is called____. 

a) Merging b) ordering c) Filtering d) Sorting 

12. ____ are otherwise called as literals.  a) Strings b) Constants c) Variables d) Data 

13. A character array should be terminated with a ____ character. 
a) ‘0’ b) ‘\0’ c) ‘0/’ d) \0 

14. ____ is a member function of standard input istream. 

a) getline() b) get() c) getsline() d) line() 
15. ____ is a member function of standard output ostream. 

a) write() b) Print() c) writes() d) reads() 

16. In a 2-D array, the first sub-script stands for_______. 

a) row b) column c) diagonal d) object 
17. _____ parameters are required for write function. 

a) 2 b) 3 c) 4 d) 5 

18. String manipulations are defined in ____ header file. 
a) string.h b) String c) st.h d) std.h 

19. ____ function returns the number of characters stored in the array. 

a) strlen() b) str() c) stlen() d) strlength() 

20. ___ functions copies source string to target string. 
a) strcpy() b) str() c) scpy() d) stcp() 

21. _____ function compares the two given strings. 

a) strcpy() b) strlen() c) stcrsmp() d) strcmp() 

22. ___ dimensional array is an array in which each elements it itself an array.  
a) 2 b) 3 c) 4 d) 1 

23. The number of elements in a 2-dimentional by multiplying number of ____ with number 

       of _____.  a) rows, columns b) columns ,columns c) row, row d) row, coln 
24. The subscript always commences from_____.  a) 1 b) 0 c) 4 d) 3 

25. If the elements are stored in row wise manner it is called as ____ order. 

a) row – major b) column – major c) row d) column 

26. When elements are stored column wise manner it is called as _____ order. 
a) column – major b) row – major c) row d) column 

27. A ___ is a set of mn numbers arranged in the form of a rectangular array of m rows and 

n columns.  a) matrix b) Determinant c) array d) row. 
28. The ____ character is very important, as it acts as the string terminator.  

a) Null b) String c) int d) float 

29. Matrices can be represented through ___ arrays. 

a) Single b) 2 –D c) 3 – D d) multi - dimensional 
30. Character array should be initialized using ___ quotes. 

a) Single b) no c) double d) any 

31. An integer array with index from 0 to 4 all having value 1 may be declared and 
       Initialized ____. a) int x[4] = {1} b) int x[4]={1,1,1,1) c) int x[5]=(1,1,1,1,1) d)int x[] = {} 

32. The function strcpy(s1,s2)____  

a) Copied s1 to s2 b) copies s2 to s1 c) appends s1 to end of s2 d) appends s2 to end of s1. 

33. Which of the following is a derived data type? 
a) Union b) float c) Double d) Array 

 

 
 

 

 

Ans: 1.(c)     2.(c)     3.(a)      4.(c)     5.(b)      6.(a)     7.(a)       8.(b)      9.(a)       10.(d)    11.(a)    12.(a)    

        13.(b)    14.(a)   15.(a)    16.(a)  17.(a)     18.(a)   19.(a)     20.(a)    21.(d)     22.(a)    23.(a)   24.(b)   

        25.(a)     26.(a)  27.(a)    28.(a)   29.(b)     30.(a)   31.(b)     32.(b)    33.(d)     
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6. Classes and Objects 

1. Which of the following is a way to bind the data and its associated functions together? 

a) Class b) Data c) Functions d) Methods 
2. The most important feature of c++ is the ___. a) Integer b) float c) class d) arrays 

3. In c++ functions are also called ___.a) Definitions b) concepts c) organizers d) methods 

4. Declaration and function definitions are two specifications of which of the following__. 
a) data type b) Class c) Comments d) none of the given 

5. Which of the following is a user defined data type? 

a) Class b) Object c) Public d) Protected 

6. The body of the class starts and ends with_______. 
a) Semi colon b) Begins and end c) Start and stop d) Braces i.e. { } 

7. Declaration of class members are declared as private can be accessed only ____. 

a) Within class b) outside the class c) inside or outside the class d) separately in another class 
8. The class body has ___ access specifiers. a) 1 b) 2 c) 3 d) 4 

9. Class access specifiers are also known as ____.  

a) Specifications b) Class depth c) Visibility labels d) Class visibility specifications 

10. By default class members are treated as ____ . 
a) Public b) Private c) Protected d) Unprotected 

11. Which of the following is not valid class specifier? 

a) Public b) Private c) Protected d) Pointer 
12. The member declared as ___ can only be accessed within the class. 

a) Private b) Public c) Protected d) Class 

13. The class members declared___ can be accessed only within the class and the 

       members of the inherited classes. a) Private b) Public c) Protected d) Unprotected 
14. The member functions declared under which scope can be accessed by the objects of 

       that class?  a) Private b) Public c) Protected d) Global 

15. The binding of data and functions together into a single entity is known as ___. 
a) Inheritance b) Polymorphism c) Overloading d) Encapsulation 

16. Data hiding refers to __________. 

a) Members and functions of a class are not accessible by members of outside class 

b) Declaring members as public c) Not giving names to data 
d) Not specifying members and functions of a class 

17. Data abstraction in c++ is achieved by ____. 

a) Inheritance () b) Polymorphism () c) Data Hiding () d) Encapsulation () 

18. OOP stands for ______. a) object oriented process b) object oriented programming 
c) Online objects programming d) object to objects programming 

19. __ of a class are data variables that represents the features of properties of a class.  

a) Data members b) Member functions c) Access specifiers d) Visibility labels 
20. ___ are the functions that perform specific task in a class. 

a) Data members b) Member functions c) Concrete functions d) data functions 

21. In a class data members are also called as ___. 

a) Abstracts b) properties c) Attributes d) Dimensions 
22. class student 

 { 

 int x,y; 
 } s1,s2; 

From the above code s1,s2 are ____. a) Objects of class students 

b) Similar classes of students c) super class of students d) Sub class of students 

23. The members that can also be accessed from outside the class should be declared as 
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___.  a) private b) Public c) protected d) None of these 
24. The member of a class are accessed ____. a) Only by member functions of its own class 

b) By any functions c) Only by friend functions 

d) Only by member functions of its own class and friend functions 

25. The class access specifiers used to access friend functions is ______. 
a) Private b) Public c) protected d) Both (B) and (C) 

26. The members defined within the class behave like ___ functions. 

a) Public b) Friend c) Inline d) None of these 
27. void sum:: input() The above line tells _______. 

a) Functions sum is declared within the class input 

b) Function input is declared within class sum 

c) Function sum is sub function of input. 
d) Function input is sub function of sum. 

28. Which of the following statements is NOT true? 

a) Member functions can be of static type. 
b) The return type of a member function cannot be of object data type. 

c) A non-member function cannot access the private data of a class. 

d) Several different classes can use the same function name. 

29. :: is a ________. a) Short circuit AND b) short circuit OR c) Not operator  
d) Scope resolution operator. 

30. When objects of a class are created separate memory is allocated for? 

a) Member functions only b) Both member variables and member functions 

c) Member variables only d) neither functions nor variables. 
31. One copy of ___ data members of a class are shared by all objects of that class. 

a) Inline b) Private c) Static d) Public 

32. ___ member variable are initialized only once when the first object of its class is 
     Created.  a) Static b) PrivateC Public d) Inline 

33. The lifetime if a static member variable is some as ______. 

a) The first object of its class b) The private of variables of any object 

c) The public variables of any object d) Lifetime of the program. 
34. class example 

 { 

 int x,y,z; 
 float m,n; 

  }p[4]; 

  By the above code how many objects of the class example are created? 

a) 3 b) 4 c) 5 d) 1 
35. Class comprises ________.  

a) Data members b) Members functions  c) Both (a) and (b) d) None of these 

36. Private access specifiers is accessible by special function called_____. 
a) Void b) inline c) Friend d) all of these. 

37. Every class declaration is terminated by __.  a) , b) . c) :: d) ; 

38.  ___ member variable are initialized only once when the first object of its class is created 

a) Static b) private c) Public d) Inline 
39. Declaration and functions definitions are two specifications of which of the following __. 

a) Data type b) Class c) Comments d) none of these 

40. The class members declared ____ can be accessed from outside the class also. 
a) Private b) Public c) Protected d) Unprotected. 

41. The members of a class are accessed using___. 

a) New operator b) Size of operator c) Dot operator d) + operator. 
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42. The return type of a member function of a class can be________. 
a) Only a valid C++ data type b) Only object data type 

c) A valid C++ data type or object data type d) None of these. 

48. class product 

{ 
int code,quantity; 

float price; 

public: 
void asign_data(); 

void display(); 

}; 

void main() 
{ 

Product p1,p2; 

} 
 

Answer the following table. 

 

 

 

 

 

 

 

 

 

 

 

 

7. POLYMORPHISM 

1. The polymorphism means ______. 

a) Single form b) Many shapes c) two forms d) Many programs 

2. Polymorphism is achieved through ________. 
a) Heritance b) Encapsulation c) Over loading d) Poly programming 

3. The ability of a function to process the message or data in more than one form is called 

    as ______. a) Function overloading b) Function type c) Recursive function 

    d) Inline function 
4. Each overloaded function must differ____. a) By the member of arguments 

b) By type of arguments c) either by number of arguments or by data types of 

   Arguments. d) None of these 
5. The mechanism of giving special meaning to an operator is called ____. 

a) Operator overloading b) Function overloading c) inheritance d) Object 

6. While invoking functions if the C++ compiler does not find the exact match of the 

     function call statement then______. a) it will ignore the function call 
     b) generates an error c) Deletes the function d) looks for the next nearest match 

7. During integral promotion, a char data type can be converted to ___ 

a) integer b) Float c) Double d) All the above 
8. The return type of overloaded functions _______- 

a) Must be same b) Must be different c) May or may not be same d) None of these 

9. The functionality of operator like ‘+’ can be extended using_______ 

Object Data Members Memory Allocated 

p1 Code, quantity, price 8 

p2 Code, quantity, price 8 

Ans:   1.(a)       2.(c)      3.(d)      4.(b)     5.(a)      6.(a)     7.(a)       8.(c)      9.(c)       10.(b)    11.(d)    

12.(a)   13.(c)    14.(d)   15.(d)    16.(a)   17.(c)     18.(b)   19.()      20.(b)    21.(c)     22.(a)     23.(b)   

24.(d)   25.(a)     26.(c)  27.(b)    28.(b)   29.(d)     30.(b)   31.(c)     32.(a)    33.(d)    34.(c)    35.(c)     

36.(c)  37.(d)    38.(a)   39.(b)     40.(b)   41.(b)     42.(b)     

 
         

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



a) Operator precedence b) Operator overloading c) operator definition d) none 
10. Which of the following operators cannot be overloaded? a) + b) ++ c) -- d) :: 

11. Operator overloading ______. a) Does not overrule definition of the operator 

b) Overrules original definition c) Changes original definition d) none 

12. The operator function must be _______. a) Member function 
b) a friend function b) Either member or friend function d)None of these 

13. When overloaded operators, the overloaded operator must have______ 

a) All the operands of user defined type b) At least one operand of user defined type 
c) All the operands of C++ Data type d) None of the given 

14. A function have more than one distinct meaning is called ______ function. 

a) Polymorphism b) Overloaded c) Prototype d) Parameter 

15. ____ promotions are purely compiler oriented. 
a) Character b) Floating point c) integral d) Constant 

16. The ____ operator must have at least one operand of user defined type. 

a) Existing b) Binary c) New d) Overloaded 
17. Binary operators overloaded through a member function take one ___ arguments 

a) Implicit b) Explicit c) Complete d) Default 

18. The ____ function definitions are permitted for used defined data type. 

a) friend b) Size of c) Overloaded d) Basic 
19. In function overloaded do not use the __ function name for two unrelated function. 

a) Same b) Different c) Similar d) Complement 

20. When overloading operators, only ___ operators can be overloaded new operators 

        cannot be created. a) Binary b) Relevant c) Existing d) Similar 
Read the program and answer the following questions 

# include <iostream.h> 

# include <conio.h> 
class negative 

{ 

int i; 

public : 
void accept() 

{ 

cout << “\nEnter a number ...”; 
cin >> i; 

} 

void display() 

{ 
cout << “\nNumber ...”<<i; 

} 

void operator-() 
{ 

i = -i; 

} 

}; 
void main() 

{ 

clrscr(); 
negative n1,n2; 

n2.accept(); 

-n2; 
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n2.display(); 
getch(); 

} 

21. The prototype of the overloaded member function is ____ a) negative operator-() 

b) void operator minus c) void operator –() d) Void operator – (negative) 
22. Which of the following statements invokes the overloaded member function? 

a) Negative n1() b) --n2 c) n2+ d) –n2. 

23. Identify the operator that is overloaded. a) = b) – (unary) c) – (Binary) d) negative. 
 

 

 

 

8. Constructors and Destructors 

1. When an instance of a class comes into scope, the function that executed is ____. 
a) Destructors b) Constructors c) Inline d) Friend 

2. When a class object goes out of scope, the functions that gets executed is ____. 

a) Destructors b) Constructors c) Inline d) Friend 

3. The name of constructor must be ____. a) Same as one of the member function 
b) Same as class name c) same as object name d) None of these 

4. Which of the following is false? a) Constructor and destructor have same one 

b) Class and constructor have same name c) Class and destructor have same name. 

d) Constructor and member function have same name 
5. Which of the following do not return any value? a) member function 

b) Inline function c) Friend function d) Constructor & destructor 

6. Which of the following is automatically executed when an object is created? 
a) member function b) Inline function c) Friend function d) Constructor & destructor 

7. Which one of the following initializes a class object and allocates memory space? 

a) Destructors b) Constructors c) Inline d) Friend 

8. Which of the following is not true? a) Constructor cannot be overloaded 
b) Constructor is executed automatically c) Constructor can have parameter 

d) Destructor cannot be overloaded 

9. Which is executed automatically when the control reaches the end of the class scope? 
a) Constructor b) Destructor c) Overloading d) Copy constructor 

10. Which of the following prototype can be a copy constructor of class myclass? 

a) myclass (int myclass)   b) int copy (myclass mc) 

c) myclass copy (myclass a)  d) myclass(myclass &x) 
11. A copy constructor is invoked when ____ a) a member function returns an object 

b) an object is passed as a parameter to any of the member function 

c) an object is passed by reference to constructor d) all the above. 
12. ______ cannot have arguments 

 a) Constructor b) Destructor c) both a & c d) None  

13. Which of the following is true? a) A constructor can have parameter list 

b) The constructor is executed automatically 
c) The constructor function can be overloaded d) all the above 

14. Which of the following is a function that removes the allocated memory of an object? 

a) Constructor b) Destructor c) Member function d) Copy constructor 
15. A Destructor name must be ____. a) same as one of the member function 

b) Same as class name prefixed by tilde(~)character c) same as object name 

d) None of these 

Ans:    1.(b)      2.(c)      3.(a)      4.(c)     5.a(a)      6.(d)     7.(d)       8.(c)      9.(b)       10.(d)    11.(a)    

12.(b)   13.(b)    14.(b)   15.(c)    16.(d)  17.(b)      18.(d)   19.(a)     20.(c)    21.(c)     22.(d)    23.(b)          
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16. Which of the following cannot have arguments? 
a) Constructor b) Destructor c) Function overloading d) operator overloading 

17. How many constructor a class can have? a)1 b) 4 c) 6 d) Many 

18. How many Destructor a class can have? a)1 b) 4 c) 6 d) Many 

19. Constructor should be declared under the scope___. 
a) Private b) Protected c) pointer d) Public. 

20. When an object is passed by reference to constructor that is executed is ___. 

a) Copy b) Static c) Default d) Inline 
21. The constructor defined by the computers in the absence of user defined constructor 

is ___. a) Copy b) Static c) Default d) inline 

22. The special character related to destructor is ___. a) + b) ? c) ~ d) ! 

23. The constructors defined by the computers in the absence of user defined constructor 
      is called as ____. a) Non-parameterized b) default c) compiler generated d) all the above 

24. The constructor without any parameter is called as ____. a) Initial constructor 

b) Instance constructor c) default constructor d) parameterized constructor 
Read the following program and answer the following answer 

#include<iostream.h> 

#include<conio.h> 

class simple 
{ 

float x; 

public: 

simple() 
{ 

x=1.0; 

} 
simple(float m) 

{ 

x=m; 

} 
simple(float a,float b) 

{ 

x=a+b; 
} 

simple(simple &k) 

{ 

x = k*x; 
cout<<”\n copy constructor invoked \n”; 

} 

void show() 
{ 

cout<<”\n x=” <<x<<’\n’; 

} 

}; 
25. Write prototype of non-parameterized constructor – simple( ). 

26. Write prototype of parameterized constructor – simple ( float m). 

void main( ) 
{ 

clrscr ( ); 

Simple s,s1; 
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S1.show( ); 
Simple s2 (7) , s3 (s1); 

Simple s4 = s2,s5(4,5); 

s = s5; 

s2.show ( ); 
s3.show( ); 

s4.show( ); 

s5.show( ); 
s.show( ); 

getch( ); 

} 

27. Write prototype of copy constructor – simple ( simple &k) . 
28. Name the private members of the class – float x. 

29. Identify statements that invoke copy constructor – s3(s1). 

Read the following program and answer the following answer 
#include<iostream.h> 

#include<conio.h> 

class example 

{ 
int x,y; 

public: 

example (example &a) 

{ 
x = a.x; 

y = a.y; 

cout<<”copy constructor….”; 
} 

example( ) 

{ 

x = 1; 
y = 1; 

} 

example(int a,int b) 
{ 

x = a; 

y = b; 

} 
void display( ) 

{ 

cout<<”\nx=”<<x<<”and y”<<y; 
} 

}; 

void main( ) 

{ 
Clrscr( ) ; 

example e1; 

example e2(2,4); 
example e3(e2); 

e1.display( ); 

e2.display( ); 
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e3.display( ); 
getch( ); 

} 

30. Write prototype of non parameterized constructor- example ( ). 

31. Write prototype of parameterized constructor- example (int a, int b). 
32. Write prototype of copy constructor- example(example &a). 

33. Name private members of the class - x, y. 

34. Name Public members of the class –a, b. 
35. Identify statements that invoke copy constructor example e3(e2). 

 

 

 

9. INHERITANCE 

1. The process of creating new data types from existing data type is called_______ 
a) Inheritance b) Polymorphism c) Overloading d) Encapsulation 

2. The class created from an existing base class is called_______ 

a) Second class b) New class c) Rich class d) Derived class 

3. In Inheritance, the newly created classes are ________ 
a) Base class b) Derived class c) Super class d) function 

4. In real life, children acquire the futures of their parents in addition to their own unique 

    features. Which of the following terms refers this? 

a) Encapsulation b) polymorphism c) overloading d) inheritance 
5. Reusability of code, code sharing, and consistency of interface are all advantages of___ 

a) inheritance b) polymorphism c) overloading d) Encapsulation 

6. Which is the following is true? 
a) Base class inherit the properties from derived class 

b) Derived class inherits properties from base class 

c) Derived class does not inherit any properties from base class 

d) both a and b are true 
7. Which of the following derives a new class “sub_class” from the base class “main_class”? 

a) class main_class: public sub_class b) class sub_class; public main_class 

c) class main_class: class sub_class d) class sub_class: public main_class 
8. What is wrong with the following statement that derives a B_class from A_class? 

    Class B; public A 

a) Semicolon (;) must be replaced by colon (;) 

b) Semicolon (;) must be appear at end of the statement 
c) The world public must be replaced by private 

d) The world public must be replaced by protected 

9. Class xclass: public yclass from the above statement which of the following is true? 
a) xclass is the base class b) yclass is the base class 

c) yclass is derived from xclass d) yclass is the derived class 

10. Private, public and protected are all______ 

a) C++ variables b) Control structures of C++ 
c) Access Specifies d) Derived class members 

11. The default visibility mode while inheriting members of a base class is____ 

a) private b) protected c) public d) extended public 
12. Which of the following is true with respect to inheritance? 

a) Private members of base class are inherited to derived class with private 

accessibility 

Ans:    1.(b)      2.(a)      3.(b)      4.(d)     5.(d)      6.(d)     7.(b)       8.(a)      9.(b)       10.(d)    11.(d)    

12.(b)   13.(d)    14.(b)    15.(b)    16.(b)   17.(d)     18.(a)   19.(d)    20.(a)    21.(c)     22.(c)    23.(d)  24(d)         
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b) Private members of base class are not inherited to derived class with private 
accessibility 

c) Public members of base class are inherited but not visible to derived class 

d) none of the given 

13. In inheritance, protected members of base class are inherited as____ when private access 
specifier is used 

a) Private members b) protected members c) public members d) not inherited at all 

14. When a class is derived by private access specifier, the public members of base class are 
inherited as______of derived class 

a) Private members b) protected members c) public members d) none 

15. When a class is derived by protected access specifier, the public and protected members 

of base class are inherited as_____of derived class 
a) Private members b) public members c) protected members d) none 

16. When a class derived by access specifier protected, the public members of base class are 

inherited as______ of derived class 
a) Private members b) protected members c) public members d) none 

17. When a class derived by access specifier public, the protected members of base class are 

inherited as_____ of derived class 

a) Private members b) protected members c) public members d) none 
18. When a class is inherited by public visibility mode the public members of base class are 

derived as _______ Derived class 

a) Private members b) protected members c) public members d) none 

19. Single, multiple, multilevel, hybrid and hierarchical are all types of______ 
a) Polymorphism b) Inheritance c) Encapsulation d) overloading 

20. When a sub class inherits only from one base class it is known as_______ 

a) Single inheritance b) double inheritance c) hierarchical inheritance d) none 
21. The symbol that must be used between derived and base class is______ 

a) & b) : c) :: d) # 

22. A derived class that inherits from multiple base class is known as_____ 

a) Single inheritance b) multiple inheritance c) Multilevel inheritance d) hybrid inheritance 
23. Classes used for only deriving other classes are called______ 

a) Public classes b) abstract class c) derived class d) objects 

24. The class from which the other classes are derived is called____ 
a) Objects b) object class c) Main-class d) function 

25. Which is not inherited from base class?_______ 

a) Object b) function c) constructor d) data member 

Read the following program and answer the following answer 
class vehicle 

{ 

int wheels; 
public: 

void inputdata( int, int); 

void outputdata(); 

protected : 
int passenger; 

}; 

class heavy_vehicle : protected vehicle 
{ 

int diesel_petrol; 

protected: 
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int load; 
public: 

void readdata( int, int); 

void writedata(); 

}; 
class bus: private_heavy_vehicle 

{ 

}; 
char marks[20]; 

public: 

void fetchdata( char ); 

void displaydata(); 

}; 
26. Which is the base class of the class heavy_vehicle? 

a) bus b) heavy_vehicle c) vehicle d) both a and c 

27. The data member that can be accessed from the function display data () is_____ 

a) passenger b) load c) marks d) a & b 
28. The data member that can be accessed by an object of bus class is_____ 

a) input data b) read data c) fetch data d) None  

29. Name the derived class of the class heavy_vehicle - bus 
30. Name the data members that can be accessed from the function displaydata() - None 

31. Is the member function output data accessible to the objects of heavy_vehicle class - Yes. 

 

Read the following program and answer the following answer 

#include<iostream.h> 
#include<conio.h> 

class inherit 

{ 

private: 
int x,y; 

public: 

inherit() 
{ 

x =1;y=2; 

{ 

void print( ) 
{ 

cout<<”y=”<<y<<end1; 

} 
}; 

class inherit1: public inherit 
{ 

}; 

void main( ) 
{ 

clrscr( ); 

inherit i; 
inherit1 a; 

i.print( ); 
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i.print( ); 
getch ( ); 

} 

32. What are the private data members of class inherit? x,y 

33. What are the public members of class inherit? - 
34. What are the members inherited by the class inherit1? x,y inherit( ), print( ) 

 

 
 

 

10. IMPACT OF COMPUTERS ON SOCIETY 

1. The technical elements we need to reach out the benefits if IT to the common man are _. 

a) Connectivity b) Affordable computers c) Software d) All of these 
2. 85% of computer usage is ___. a) Word processing b) Graphics c) Animation d) None. 

3. Which of the following has changed our life style? a) Browsing b) e-mail c) chat d) All of these 

4. Which of the following enables data storage and management? 

a) LCD screen b) Picture phone c) Archive unit d) Speakers 
5. _______ is built largely to support patient needs and a foundational system for doctors..  

 a) ATM b) Tele medicine c) Tele conference  d) e-shopping 

6. In a computerized homes, which of the following rooms have LCD screen, archive 
    unit, personal archives, emotional containers etc? 

 (a) Living room (b) kids room (c) home office (d) bed room 

7. Which prevents people from acquiring bad habits? 

(a) Archive unit (b) emotion containers (c) camera (d) speakers 
8_______. are mounted on the wall to provide better effect and save floor space. 

(a)LCD SCREEN (B) camera (c) speakers (d) all the given 

9_______.is a picture based personal telephone directory. (a) Picture phone and pad 
(b) Personal archives (c) emotional container (d) archive unit 

10_______ Features allow singing alone with audio coming from original source. 

(a) kara-oke (b)memo frame (c)projection TV (d)interactive table cloth 

11______can function as electronic pets. 
(a) Archive units (b) memo pads (c) ceramic audio (d) robots 

12. kara-oke, electronic pets, games over net are all part of which of the following rooms in 

a computerized home_______ 

(a)LIVING ROOM (B) KIDS ROOM (C) HOME OFFICE D) dining room 
13. Animated stories package, memo frame, Bookshelf, personal creativity tool are all 

      located in which of the following places of a computerized home______ 

a) Kids room b) Bed room c) home office d) dinning room 
14_____ Means easy interaction with other people through touch screen, scanner and 

     Microphone facilities. 

a) Memo frame b) bookshelf c) Archive units d) kara-oke 

15. In a computerized home_______has touch and voice control for various 
      Appliances, projection TV, Alarm clock, moving telephone ete. 

a) Kids room b) bed room c) home office d) dinning room 

16. In which of the following rooms mirrors, medical box and special speakers are located 
      of a computerized home?_______ 

a) Kitchen b) bed room c)bath room d)kids room 

17. Speakers, intelligent aprons, food analyzer, health monitor are found in______.of a 

      Computerized home. 

Ans:    1.(a)      2.(d)      3.(b)      4.(d)     5.(a)      6.(b)     7.(d)       8.(a)      9.(b)       10.(c)    11.(a)    

12.(c)   13.(a)    14.(a)    15.(c)    16.(b)   17.(b)      18.(c)   19.(b)     20.(a)    21.(b)     22.(b)    23.(b)  

24(c)   25(c)    26(c)   27(d)   28(d)      
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a) Kitchen b)bed room c)bath room d)kids room 
18. Interactive table cloth keeps the food___________ 

a) hot b)cool c)sufficiently warm d)packed 

19. Interactive table cloth and ceramic audio player are found in ……….. of a 

      computerized home_______ 
a) Kitchen b)bed room c)bath room d)dinning room 

20_______.enable us to withdraw money from our accounts in a particular bank 

    Anytime and any where. 
a)ATM b)archives c)picture phone and pad d)memo frame 

21______permits banking from the comfort of the home by using internet facilities. 

a)ATM b)e-Banking c)memo frame d)none of the given 

22. Through_____we can purchase any product, any brand, any quality from any where. 
a)ATM b)e-banking c)e-shopping d)e-governance 

23. CBT stands for______ a) computer based tutorials b) computer based teaching 

c)common basic techniques d)control bullet in table 
24. ATM is an example for_________ 

a)e-shopping b) e-banking c)transcription d)digitization 

25_________enable online educational programs leading to degrees and certifications. 

a)e-shopping b)e-banking c) e-commerce d)e-learning 
26. ______facilitates remote diagnostics. 

a) ATM b) e-learning c) internet d)none of given 

 

 

 

            

11. IT ENABLED SERVICES 

1. ITES means ________. a) Improving technology enlighten services 

b) Information technology enabled services 
c) Information technology extended services d) Information entrusted systems 

2. Which of the following is an IT enabled service? 

a) E-Governances b) Word processor c) Spreadsheet d) database 
3. Which of the following is not an IT enabled service? 

a) Call centres b) E-Governance c) Data digitization d) Word processor 

4. A facility that allows the user to speak into a special device while typing a letter using 

Computer is called ________.a) Cell phone b) Telephone c) Dictaphone d) Speaker 
5. Which of the following is sometimes defined as a telephone base shared services? 

a) Data digitization b) Call centre c) Data management d) Bar code recognition 

6. Collection digitization and processing of data is basic function of __________. 
a) Call centre b) Data management c) E-Governance d) Data collection 

7. Which of the following is not an ITES of data management category? a) Data entry 

b) Custom reports c) Character recognition and processing d) Transcription 

8. Which of the organization can potentially benefit from ITES? 
a) Banking b) Insurance c) Legal d) All the above 

9. ___ is a permanent legal document that formally states the result of a medical 

investigation.  
a) Medical transcription b) Medical prescription c) Medical document d) Medical anatomy 

10. ____ refers to conversion of non – digital material to digital form. 

a) Transcription b) Data transfer c) Data digitization d) Noen of the given 

Ans:    1.(d)      2.(a)      3.( d)      4.(c)     5.(b)      6.(a)     7.(b)      8.(d)      9.(a)       10.(a)    11.(d)    

12.(b)   13.(c)    14.(a)    15.(b)    16.(c)   17.(a)      18.(c)   19.(d)     20.(a)    21.(b)     22.(c)    23.(a)  

24(b)    25(d)    26(c)              
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11. Long term preservation storage of important documents easy to use and access of 
information are all benefits of _________.  

a) Medical transcription b) Call centre c) data digitization d) Web based services 

12. Career guidance employment online examination results online are all ______. 

a) Web based service b) Data processing service c) Call centre service 
d) Transcription 

13. BPO may be expanded as ______ a) business product outcome b) Business process 

outcome c) Business product outsourcing d) business process outsourcing 
14. BFSI stands for _____ 

 a) Banking b) Financial services C) Insurance d) All of these  

15 Number of steps involved in Medical Transcription  is 

a) 1 b) 2 c) 3 d) 4 
16. Which of the following is not a step in Data management ? 

 a) Collection b) Processing  c) Verification d) Digitizing 

17_______ involves service comprise of manually filled forms, images or publications. 
a) Data Management b) Data Digitization c) Data processing  d) None 

18. _______ is the key for effective and profitable use of IT in an organization. 

 a) Data Management b) Data Digitization c) Data processing  d) None 

19. In MT the sound is digitized and send to the ITES provider in _____ step. 
 a) 1  b) 2  c) 3  d) 4 

20. _______ is critical for the success of ITES. 

a) Data Management b) Data Digitization    c) Data processing    d) Computer ethics 

 
 

 

 

12. COMPUTER ETHICS 

1. Computer ethics has its roots in the work of ____ during World War II. 

a) Charles Babbage b) Blaise pascal c) Norbert wiener d) Herman horllerith 

2. Who among the following began to examine unethical and illegal uses of computers? 
By computer professionals in mid 1960s in Menlo park, California?_____. 

a) Charles Babbage b) Don Parker c) Norbert wiener d) Herman horllerith 

3. ____ is a set of rules for determining moral standards or socially acceptable behavior 

a) Standard b) Ethics c) protocol d) None of the given 
4. General guidelines of computer ethics are needed for ___. 

a) Protection of personal data b) Computer crime c) Cracking d) All the above 

5. The protection of hardware facilities magnetic disks and other illegal accessed stolen 
Damaged or destroyed items refers to _____ security. 

a) Physical b) Personal c) personnel d) none of the given 

6. ____ security refers to software setups that permit only authorized access to the system 

a) Physical b) Personal c) personnel d) none of the given 
7. ___ security refers to protecting data and computer system against dishonesty or 

Negligence of employees. a) Physical b) Personal c) personnel d) none of the given 

8. “Cracking” comes under ____. 
a) Data security b) Computer crime c) Website service d) Transcription 

9. Making and using duplicate hardware and software is called ____. 

a) Copy right b) Free copy c) piracy d) none of the given 

10. ___ is a self-replicating program that can cause damage to data and files stored on 

Ans:    1.(b)      2.(a)      3.(d)        4.(c)       5.(b)      6.(b)      7.(d)       8.(d)      9.(a)       10.(c)    11.(c)    

12.(a)   13.(d)    14(d)     15(c) 16(c)   17(c)      18(a)      19(b) 20(d) 
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Your computer. a) Piracy b) Freeware c) Virus d) none of the given 
11. Running other software for the ideal computer without the knowledge of the organization 

Is called theft of  _______. a) Computer  b) System c) Computer time d) software 

12. ___ is the illegal access to the network or computer system. 

a) Piracy  b) Virus  c) Cracking  d) Security 
13. Which of the following is not a way of protection?  

a) Physical Security    b) Personal Security    c) personnel Security    d) Piracy 

14. It must be observed that_______ off all computer crimes happen from within the company.  
 a) 75% b) 80% c) 25% d) 40% 

15. ____  new viruses are found each day. 

 a) 5  b) 6  c) 7  d) 8 

16. _____ known virus programs are in existence. 
 a) 5000 b) 55000 c) 57000 d) 7000 

17. India has _____ to prevent computer crimes. 

 a) Strict law  b) Cyber law c) special laws d)Security 
18. Viruses are ____ 

 a) messages  b) Programs  c)code  d) Hardware 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ans:    1.(c)         2.(b)      3.(b)      4.(d)       5.(a)        6.(b)     7.(c)       8.(b)      9.(c)       10.(c)    11.(c)    

12.(c)   13.(d)      14(b)     15(b)     16(c)     17(b)      18(b) 
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1. OBJECT ORIENTED CONCEPTS USING C++ 

2 Marks 

1. What is the significance of an object? 

2. What is encapsulation? 

3. How is polymorphism different from inheritance? 
4. What is class? 

5. What is inheritance? 

2. OVERVIEW OF C++ 

2 Marks 

1. What are tokens? Write the types 

2. What are constants? 

3. What is string literal? Give example. 
4. How are the operators classified? 

5. What are relational operators? 

6. What are conditional operators? Give its syntax. 
7. Explain Type definition and enumeration. 

8. What is the use of void type? 

9. What is a pointer an address? 

10. What is the impact of modifiers? 
11. Write syntax of Type definition and enumeration 

12. What is storage class? Write the types. 

13. Explain storage classes. 

14. What are the rules for implicit conversion? 

15. What are the operators related to pointer variable? 

3. BASIC STATEMENT 

2 Marks 

1. What are the different statements in C++? 
2. What is assignment operator? Which operator is used for assignment operator? 

3. What is control statement? 

4. What is a continue statement? 

5. What is the difference between continue and break statement? 
6. Write the syntax of simple if, if-else statement and switch case. 

7. Write the syntax of for, while and do-while loop. 

8. Write the rules of nested loop. 

5 Marks 

1. What is simple if and if-else statement? Give an example. 

2. Explain the switch statement with suitable example. 

3. Explain for loop with suitable example. 
4. Explain the while loop with suitable example. 

5. Explain the do-while loop with suitable example. 

 

4. FUNCTION 

2 Marks 

1. What is function? 

2. What are the advantageous of functions? 
3. What is the main purpose of using function prototype? 

4. What is inline function? 

5. Write the rules for actual parameters in function prototype with suitable example. 

5 Marks 
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1. Explain call by value method in function with suitable example. 
2. Explain call by reference method in function with suitable example. 

3. Explain inline function. 

4. Explain various types of scopes. 

5. STRUCTURED DATA TYPES – ARRAYS 

2 Marks 

1. What is array? Write the different types. 

2. Write the syntax of single dimensional array. Give an example. 

3. What is array of strings? Give an example. 

4. What is sorting? 
5. Write the short notes: Strlen(), Strcpy() and Strcmp() 

6. Classes and objects 

    6. CLASSES AND OBJECTS 

2 Marks 

1. What is a class? 

2. What are the two parts of class specifiers? 

3. What is encapsulation? 
4. What is meant by data hiding? 

5. What is data abstraction? 

6. Give some valid points about static data members of a class. 
5 Marks 

1. Give the general form of a class and explain with an example 

7. POLYMORPHISM 

2 Marks 

1. What is function overloading? 
2. How are functions invoked in function overloading? 

3. Write the rules of function overloading 

4. What is operator overloading? 

5. List out operators can not be overloaded. 
5 Marks 

1. What is function overloading? Explain with suitable example. 

2. What is operator overloading? Explain with suitable example 

3. Write the rules of operator overloading 

8. CONSTRUCTORS AND DESTRUCTORS 

2 Marks 

1. What is constructor? 

2. What are the functions of constructors? 
3. What is copy constructor? 

4. What is destructor? 

5 Marks 

1. Write the rules of constructor and destructor. 

9. INHERITANCE 

2 Marks 

1. What is inheritance? 

2. What are the advantages of inheritance? 
3. What are the points to be observed while defining a derived class? 

4. What are the different types of inheritance? 

5. What is an abstract class? 
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5 Marks 

1. Tabulate the scope and accessibility of the base members in the derived class 

    When inherited with different access specifies? 

2. Explain the types of inheritance. 

 

10. IMPACT OF COMPUTERS ON SOCIETY 

2 Marks 

1. What is an archive unit? 

2. What are the three technical elements we need to reach out benefits of IT to the  

     Common man? 

3. What is ATM? 
4. Write s brief note on e-shopping. 

5. Write is meant by e-learning. 

6. Name areas of healthcare in which computers are used? 

7. Explain how computer help in agriculture 

11. IT ENABLED SERVICES 

2 Marks 

1. What is an ITES? 

2. What is Dictaphone? 
3. What is e-governance? 

4. What is the use of call centers? 

5. What is data management? 

6. What is data digitization? 
12. COMPUTER ETHICS 

2 Marks 

1. What is the need for a password to log into a computer system? 
2. How does the operating system enhance the security? 

3. What does book of Norbert Wiener contain about computer ethics? 

4. What are ethics? 

5. What does physical, personal and personnel security? 
6. List out some of the common computer crimes. 

7. What is piracy? 

8. What is a computer virus? 

9. What is cracking? 
10. What is Cyber law? 

FIND THE ERRORS 

1.  
#include<iostream.h> 

class simple 

{ 

int num1, num2 , sum = 0; 
protected: 

accept() 

{ 
cin>>num1>>num2; 

} 

public: 

Answer : 
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} display() 
{ 

sum = num1 + num2; 

}; 

void main() 
{simple s; 

s.num1=s.num2= 0;       num1, num2 are private members cannot accessed outside the class 

s.accept(); Protected member accept cannot be accessed outside the class 
display(); s.display(); 

} 

 

1. The member sum cannot be initialized at the time of declaration 
2. The member variable num1 and num 2 cannot be accessed from main() as they are Private.  

3. s.accept( ) is invalid. The method accept ( ) is defined under protected. 

4. display( ) should be invoked through an object. 
 

2. 

Class simple 

{ 
private : 

int x; 

simple() 

{ x = 5; } 
}; 

 

3. 
Class simple 

{ 

private : 

int x; 
public : 

simple(int y) 

{ x = y; } 
}; 

void main() 

{ 

simple s; 
} 

 

4. 
#include<iostream.h> 

class A 

{ 

private : 
int a1; 

public: 

int a2; 
protected: 

int a3; 

}; 
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class B : public A 
public: 

 

Answer : 

1. ‘a1’ is a private members and ‘a3’ is protected member. They are declared in class 
Answer : 

Public scope is not defined 

Answer : 

Instance of class simple & is with value 

void func() 

{ 

int b1, b2 , b3; 
b1 = a1; 

b2 = a2; 

b3 = a3; 
} 

}; 

void main() 

{ 
B der; 

der.a3 = 0’; 

der.func(); 

} 
Answer: They cannot be accessed. 

 

5. 
#include<iostream.h> 

class A 

{ 

private 
int a; 

public: 

int a2; 
}; 

class B :: public A 

public: 

 
Answer: 

 

 

 

 

 

 

 

 

 
 

c a 

 

Line no Error line 

 

Correct line 

 

2  

 

class A class a 

4 private private: 

9 Class B::public A Class B:public A 

10   

14   

24   
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10 { is come 

14 getdata(); Not come 

20 void main[] void main( ) 

24 } is come 
‘a1’ is a private members and ‘a3’ is protected member. They are declared in class 

A.They cannot be accessed. 

 
6.  

#include<iostream.h> 

#include<conio.h> 

class simple 
{ 

private: 

int a,b 
public 

simple() 

{ 

a= 0 ; 
b= 0; 

cout<< “\n Constructor of class-simple “; 

} 

simple() 
{ 

cout<<“\n Destructor of class – simple .. “; 

} 
void func() 

{ 

int b1, b2 , b3; 

getdata(); 
b1 = a1; 

b2 = a2; 

b3 = a3; 
} 

}; 

void main[] 

{ 
B der; 

der.a3 ; 

der.func(); 
} 

void getdata() 

{ 

cout<<“\n Enter values for a and b... “; 
cin>>a>>b; 

} 

void putdata() 
{ 

cout<<“\nThe two integers .. “<<a<<‘\t’ b; 

cout<<“\n The sum of the variables .. “<< a+b; 
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} 
}; 

void main() 

{ 

simple s; 
s.getdata(); 

s.putdata() 

} 
 

Answer : 

Line no Error line Correct line 

5 int a,b int a,b; 
6 public Public: 

13 simple() ~simple() 

24 <<a<<‘\t’ b <<a<<‘\t’<< b 
32 s.putdata() s.putdata(); 

 

FIND THE OUTPUT 

1. 
#include <iostream.h> 

#include <conio.h> 

# include <iomanip.h> 

void swap (int n1, int n2) 
{  

int temp; 

temp = n1; 
n1 = n2; 

n2 = temp; 

cout << “\n”<<n1<<”\t”<<n2<<”\n”; 

} 
void main ( ) 

{ 

int m1 = 10, m2 = 20; 
clrscr ( ); 

cout <<”\n Values before invoking swap” << m1 << “\t” << m2; 

cout << “\n Calling swap..”; 

swap (m1, m2); 
cout << “\n Back to main.. Values are” << m1 << ‘\t’ << m2; 

getch ( ); 

} 
 

 

 

Output : 

Values before invoking swap10 20 

Calling swap :20 10 

Back to main…… Values are 10 20 
 

2. 

#include <iostream.h> 
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#include <conio.h> 
# include <iomanip.h> 

void swap (int &n1, int &n2) 

{  

int temp; 
temp = n1; 

n1 = n2; 

n2 = temp; 
cout << “\n”<<n1<<”\t”<<n2<<”\n”; 

} 

void main ( ) 

{ 
int m1 = 10, m2 = 20; 

clrscr ( ); 

cout <<”\n Values before invoking swap” << m1 << “\t” << m2; 
cout << “\n Calling swap..”; 

swap (m1, m2); 

cout << “\n Back to main.. Values are” << m1 << ‘\t’ << m2; 

getch ( ); 
} 

 

Output : 

Values before invoking swap10 20 
Calling swap :20 10 

Back to main…… Values are 20 10 

 
3. 

# include <iostream.h> 

# include <conio.h> 

float power (float n, int p = 1) 
{ 

float prd = 1; 

for (int i = 1; i<= p; i++) 
prd *= n; 

return prd; 

} 

void main ( ) 
{ 

clrscr ( ); 

int x = 4, b = 2; 
cout << “\n Call statement is power(b, x)...” << power (b, x); 

cout << “\n Call statement is power(b).. “ << power (b); 

getch ( ); 

} 
 

Output : 

Call statement is power (b, x)..16 
Call statement is power (b)..2 
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4. 

# include <iostream h> 

# include <conio.h> 
int area (int side1 = 10, int side2=20 

{  

return (side1 * side 2); 
 } 

 

Output : 

24 
80 

120 

 
5. 

#include<iostream.h> 

#include<conio.h> 

class simple_static 
{ 

int a,b,sum; 

static int count; 

public: 
void accept() 

{ 

cout<<“\n Enter values.. “; 
cin>>a>>b; 

sum = a+b; 

count++; 

} 
void display() 

{ 

cout<<“\n The sum of two numbers … “<<sum; 
cout<<“\n This is addition… “<<count; 

void main ( ) 

{  

int s1 = 4, s2 = 6; 
clrscr ( ) ; 

cout << area (s1, s2) << ‘\n’; 

cout << area (s1) << ‘\n’; 
cout << area (s2) << ‘\n’; 

getch ( ); 

} 

} 
}; 

int static_simple count=0; 

void main() 
{ 

simple_static p1,p2,p3; 

p1.accept(); 
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p1.display(); 
p2.accept(); 

p2.display(); 

p3.accept(); 

p3.display(); 
} 

 

 
 

 

Output: 

Enter values 10 20 
The sum of two numbers 30 

This is addition 1 

Enter values……… 5 7 
The sum of two numbers 12 

This is addition 2 

Enter values……….. 9 8 

The sum of two numbers 17 
This is addition 3 

 

6. 

# include <iostream.h> 
# include <conio.h> 

class distance 

{ 
int feet,inches; 

public : 

void distance_assign(int f, int i) 

{ 
feet = f; 

inches = i; 

} 
void display() 

{ 

cout << “\nFeet : “ << feet<< “\tInches : “ << inches; 

} 
distance operator+(distance d2) 

{ 

distance d3; 
d3.feet = feet + d2.feet; 

d3.inches = (inches + d2.inches) % 12; 

d3.feet += (inches + d2.inches)/12; 

return d3; 
} 

}; 

void main() 
{ 

clrscr(); 

distance dist_1,dist_2; 

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



dist_1.distance_assign(12,11) 
dist_2.distance_assign(24,1); 

distance dist_3 = dist_1 + dist_2; 

dist_1.display(); 

dist_2.display(); 
dist_3.display(); 

getch(); 

} 
 

Output: 

Feet : 12  Inches : 11 

Feet : 24  Inches : 1 
Feet : 37  Inches : 0 

 

 
 

 

 

7. 
#include<iostream.h> 

#include<conio.h> 

class simple 

{ 
private: 

int a,b; 

public: 
simple() 

{ 

a= 0 ; 

b= 0; 
cout<< “\n Constructor of class-simple “; 

} 

~simple() 
{ 

cout<<“\n Destructor of class – simple .. “; 

} 

void getdata() 
{ 

cout<<“\n Enter values for a and b... “; 

cin>>a>>b; 
} 

void putdata() 

{ 

cout<<“\nThe two integers .. “<<a<<‘\t’<< b; 
cout<<“\n The sum of the variables .. “<< a+b; 

} 

}; 
void main() 

{ 

simple s; 
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s.getdata(); 
s.putdata(); 

} 

 

Output: 

Constructor of class - simple .. 

Enter values for a & b 5 6 

The two integers... 5 6 
The sum of the variables... 11 

Destructor of class – simple 

 

8. 
# include<iostream.h> 

#include<conio.h> 

class add 
{ 

int num1, num2, sum; 

public: 

add() 
{ 

cout<<”\n Constructor without parameters.. “; 

num1= 0; 

num2= 0; 
sum = 0; 

} 

add ( int s1, int s2 ) 
{ 

cout<<”\n Parameterized constructor... “; 

num1= s1; 

void getdata() 
{ 

cout<<”Enter data ... “; 

cin>>num1>>num2; 
} 

void addition() 

{ 

sum=num1+num2; 
} 

void putdata() 

{ 
cout<<”\n The numbers are..”; 

cout<<num1<<”\t”<<num2; 

cout<<”\n The sum of the 

numbers are.. “<< sum; 
} 

}; 

void main() 
{ 

add a, b (10, 20) , c(b); 

a.getdata(); 
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a.addition(); 
b.addition(); 

num2=s2; 

sum=NULL; 

} 
add (add &a) 

{ 

cout<<”\n Copy Constructor ... “; 
num1= a.num1; 

num2=a.num2; 

sum = NULL; 

} 
 

Output : 

Constructor without parameters.. 
Parameterized Constructor... 

Copy Constructors. 

 

Enter data .. 5 6 
Object a: 

The numbers are 5 6 

The sum of the numbers are ... 11 

 
Object b: 

The numbers are 10 20 

The sum of the numbers are . 30 
 

Object c: 

The numbers are 10 20 

The sum of the numbers are ... 30 
 

9. 

#include<iostream.h> 
#include<conio.h> 

class base 

{ 

public: 
base() 

{ 

cout<<”\nConstructor of base class...”; 
} 

~base() 

{ 

cout<<”\nDestructor of base class.... “; 
} 

}; 

class derived:public base 
{ 

public : 

derived() 
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{ 
cout << “\nConstructor of derived ...”; 

} 

~derived() 

{ 
cout << “\nDestructor of derived ...”; 

} 

}; 
class derived2:public derived 

{ 

public : 

derived() 
{ 

cout << “\nConstructor of derived2 ...”; 

} 
~derived() 

{ 

cout << “\nDestructor of derived2 ...”; 

} 
}; 

void main() 

{ 

derived2 x; 
} 

 

Output: 
 Constructor of base class.. 

Constructor of derived ... 

Constructor of derived2 ... 

Destructor of derived2 ... 
Destructor of derived ... 

Destructor of base class.... 

 
10. 

#include<iostream.h> 

#include<conio.h> 

class student 
{ 

int m1, m2, total; 

public: 
student ( int a, int b) 

{ 

m1 = a; 

m2 = b; 
cout<<”\n Non parameterized constructors..”; 

}; 

 
Output: 

Non parameterized constructors 
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C++ SYNTAX 
 

 

Sl. 

No 

Term Syntax Example 

1 
Conditional /Ternary 

operator 

(num1>num2)?num1:num2 Max=(a>b) ? a : b 

2 
Type Definition typedef data_type user-

defined-data-type-identifier; 

typedef int marks; 

Marks m1,m2; 

3 
Enumerated Data Type enum data type identifier 

(value1, value2, ..value n); 
enum holidays (Sunday, 
Monday); 

4 

Declaration of 
variables 

 
 

 

int a,b; 
 

 

 
 

5 
Declaration of pointer 
variable 

datatype *variable name; int *a; 

6 

Sizeof() – Memory 

requirement of given 

expression 

Sizeof() Sizeof(d*f) – will return 8 

bytes  

7 
Typecast (data type)<variable/value> or 

data type (variable / constant) 

(int)7.7 

int(7.7) 

8 

Simple if  if(condition / expression) 
{ 

action block; 

} 

 

if(a>b) 

{ 

cout<<”A is greater”; 

} 

9 

if..else statemet if(condition / expression) 
{ 

action block1; 

} 

else 
{ 

action block2; 

} 

if(a>b) 

{ 

cout<<”A is greater”; 

} 

clse 

{ 

cout<<”B is greater”; 

} 

10 

Nested if statement     if(expression 1) 

             if(expression 2) 
            { 

            action block1; 

            } 
            else 

           { 

           action block2; 

           } 
    else 

    { 

    action block3; 
    } 

if(grade= =’A’) 

if(basic > 5500) 

incentive = basic * 10 / 100; 

else 

incentive = basic * 5 / 100; 

else 

cout << “Try to attain 

Grade A”; 

  

 

Data type 

Identifier 

sp
ac
e 

Identi

fier 

   

, 
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Sl. 

No 
Term Syntax Example 

11 

Switch Statement switch(expression) 
{ 

case 1: action block1; 

break; 

case 2: action block2; 
break; 

. 

default: default statement; 
} 

grade=’A’; 
switch(grade) 

{ 

case ‘A1’:cout<<”Very Good”; 

break; 
case ‘A’: cout<<”Good”; 

break; 

default: cout<<”Study Well”; 
break; 

} 

12 

do..while() 
Exit – check loop 

do 
{ 

action block; 

}while<(condition)>; 

n=1; 
do 

{ 

cout<<n; 

n++; 
}while(n>10=); 

13 

while() 

Entry – check loop 

while(condition) 

{ 

action block; 
} 

n=1; 

while(n>=10) 

{ 
cout<<n; 

n++; 

} 

14 

for( ; ; ) 

Entry – check loop 

for(initial value;test-

condition; increment) 
{ 

action block; 

} 

for(n=1;n<=10;n++) 

{ 
cout<<n; 

} 

15 Continue 

              for( ; ; ) 

             { 
             continue; 

             } 

16 Break 

              for( ; ; ) 

             { 

             break; 
             } 

 

17 

Syntax of a function 

prototype 

<type> <function identifier> 

<arguments>; 

void fun (int a); 

18 

One dimensional array   
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12 

   

13 

   

14 

   

15 

   

16 

   

17 

   

18 

   

19 

   

20 
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PLATO’S ACADEMY MATRIC.HR.SEC.SCHOOL, TIRUPPUR-7 

VOL - I   STAR OFFICE KEYBOARD & MENU SHORTCUTS 

 

SHORTCUT FUNCTION 

File -> New-> Text Document To open a new document  

Double click on a word  To select a word  

Click once next to the line To select a particular line 

Ctrl + A To select the entire document 

Edit-> Find & Replace To search for and replace words in a text document 

Insert key To toggle between Insert mode & Type over mode. Status bar shows information 

about Insert mode or Type-over mode 

Window -> (File name) To work with multiple documents 

File -> Close To close a document 

File -> Save To save a document (.odt – Open Document Text, .ods –Open Document 

Spreadsheet , .odb – Open Document Base, .odp – Open Document Presentation ) 

File -> Open To open a document  

File -> Exit It can be used to quit from star office 

Left Arrow One character to the left 

Right Arrow One character to the right 

Ctrl + Left arrow One word to the left 

Ctrl + Right arrow One word to the right 

Shift + Tab One cell to the left in a table 

Tab One cell to the Right in a table 

Up Arrow Up one line 

Down Arrow Down one line 

End To the end of a line 

Home To the beginning of a line 

Page Up Up one Screen ( Scrolling ) 

Page Down Down one screen ( Screen ) 

Ctrl + End To the end of a document 

Ctrl + Home To the beginning of a document 

Edit -> Cut, Ctrl + X To Move the text to the specified location.  

Edit -> Copy, Ctrl + C To Copy the text to the specified location 

Edit -> Paste, Ctrl + V To paste the text to the specified location 

Ctrl + L, Ctrl + E, Ctrl + R,  

Ctrl + J 

Text Alignment  Left, Right, Center & Justify 
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Format -> Character To format the text with formatting options 

Format -> Paragraph To indent several paragraphs to make it more readable  

Hanging indent A -ve value will result in a hanging indent, the first line will hang outside the 

paragraph. 

Fonts Times New Roman – Professional, Fajita – Decorative, Windings – Symbols 

 Font is measured in points, 72 points to an inch 

Ctrl + B, Ctrl + I, Ctrl + U Bold, Italic & Underline  

Font Is a set of characters and numbers in a certain style 

Style Is a set of defaults for formatting a text 

Enter key Hard Return 

Line breaks Soft return 

Highlighting Can be used to call attention to key ideas or points in a document 

½ inch By clicking Increase or Decrease indenting icon 

Single, 1.5 lines, Double, 

Proportional, Atleast, Leading., 

Fixed 

7 Line Spacing options. Single – is the default line spacing 

Format -> Bullets & Numbering To list the important points and messages.  

F1 To open the help window. Online Help, Help Agent, Help Tips, Extended Help 

Tips are the several help options in Star office 

Shift + F1 To show extended help tips 

Tools -> Spellcheck / F7 To Check for spelling & Mistakes after the entire document is typed. 

Tools -> Autocorrect To add / Edit the error and its correction to the autocorrect list box 

Table ->Insert -> Table To create a simple default style table (2 rows, 2 columns) 

Table -> Insert -> Rows  To insert more than one row in the table 

Table -> Insert -> Columns To insert more than one column in the table 

Table -> Delete -> Rows  To Delete more than one row in the table 

Table -> Delete -> Columns To Delete more than one column in the table 

Table -> Delete -> Table To Delete the selected table 

Edit -> Select -> All To select the entire table 

Table -> Table Properties To get a Table Format dialog box 

Column -> Space equally To make all Columns even, right click inside the table and select it in the pop up 

menu 

Row -> Space equally To make all Rows even, right click inside the table and select it in the pop up menu 

Alt +           /  To resize a column , place the cursor in a table cell, hold down Alt, and press left 

or right arrow 

Alt + Ctrl /   To resize a column, without changing the width of the table, hold down Alt + 

Ctrl, and then press the left or right arrows 

Alt +           / To resize a row, place the cursor in the row, hold down Alt, and then press the up 

or down arrows 
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1” inch – Top & Bottom 

1.25” inch – Left & Right 

Default margin values 

Format -> page To change the margins of a file using Page style dialog box if the margin 

value is known 

File -> Page Preview To see the changes made in margins 

View -> Ruler To view the ruler, if the margin value is not known 

Portrait- Default 

Landscape  

Page orientation, Portrait – Length of the document will be more than the width, 

Landscape – Width of the document will be more than the length 

Header Is an area at the top of the page 

Footer Is an area at the bottom of the page 

Insert -> Fields -> Page Number Will insert page numbers on every page 

1975 The Personal Computer PC first appeared in 

Visicalc First electronic spreadsheet for Apple II in 1979, b y Dan Bricklin & Bon 

Frankston. Rows – 63 ; Columns - 254 

Cell The intersection of rows and columns 

Spreadsheet Is like a grid of cells with a programmable calculator attached to each cell. 

Rows – 1 to 32,000 ; Columns – A to z, AA to Az…. 

Lotus 1-2-3, Improve Lotus Development Corporation in 1982 

Excel Microsoft Corporation 

Quattro Pro Borland International 

Star Office Calc Sun Micro Systems 

Main tool bar Below the Menu bar is the Main tool bar 

Function Bar & Object Bar These bars have shortcuts for frequently done tasks 

Formula Bar This is used to display the current cell and its contents 

MM / DD / YY Date Format in spreadsheet 

HH:MM:SS Time format in spreadsheet 

F2 / Double click / Click on the 

formula bar 

To edit the data in the worksheet 

Formula The syntax of a formula begins with an equal sign. It lets you create a value in one 

cell that is calculated based on the values in other cells. 

& Text Operator used to combine sections of the text 

: colon 

! Exclamation point 

Cell Range , Ex  - A1:C108 

Intersection, Ex - SUM (A1:B6! B5:C12) 

Range  A continuous group of cells in a worksheet is called a range 

Rules of precedence Exponentiation( ^ ), Negation( - ), Multiplication & Division ( * , /  ), Addition & 

Subtraction ( + , - ) 

Edit -> Fill -> Series Fill command is used to generate a series of data directly from the values of the 

selected cells   

Relative cell addressing Default type of cell addressing, here formula gets recalculated when the content of 

cells change 

Absolute cell addressing ($) Formula does not change when the cells get edited 

www.Padasalai.Net                                                              www.TrbTnps.com

http://www.trbtnpsc.com/2018/02/latest-12th-study-materials-2018.html

www.Padasalai.Net



 

 

Prepared by : Mr T.P.Durai Samy M.C.A.,M.Sc(IT).,B.Ed., 

Plato’s Academy MHSS, TIrupur-641687 

Feel Free to contact @9952207071, dooldurai@gmail.com 

Insert -> Functions Functions are predefined formulae that are available in staroffice calc  

 Shortcut icon on the formula bar can be used to select and Insert function 

  One of the most commonly used function is the Sum function 

Insert -> Character  

Format -> cells Select the cells you want to format and click on format cells dialog box 

Format -> Autoformat to format the worksheet with different predefined styles and colours 

 Number Format : Currency, Percent , Standard , Add Decimal places, Delete 

decimal places 

Format -> Colum -> Width To change the column width in a spreadsheet 

Right click on the row -> Height To change the row height in a spreadsheet 

View -> Toolbar -> Insert cell 

 

 

 

Insert cells down. Insert cells right, Insert Rows, Insert Columns 

Edit -> Delete Contents To delete a specified cell range 

Edit -> Delete cells To delete an entire row or Column, in the Delete cells dialog box chooseDelete 

entire Rows / Delete entire columns 

Insert -> Picture -> From File To insert a picture in spreadsheet 

Insert -> Special characters To insert special characters in the spreadsheet 

Show Draw Functions icon To provide facilities for drawing lines, circles, ellipses, square, rectangle etc., in 

the standard toolbar 

View -> Toolbar -> Insert object 

 

 

 

Star office calc provides tools for inserting objects like charts, images from image 

editor, formula etc in a worksheet 

Insert Chart icon To present the data in form of different kinds such as Bar chart, Pie chart, Lines, X 

Y Plot etc., 

Insert Formula icon To insert a formula in the worksheet for performing calculations 

Insert Floating frame icon This icon provides to generate a scrolling screen within a worksheet 

Insert OLE icon This icon is used to insert objects from other applications into a worksheet 

Insert Applet icon To import Applets written in Java programming language into the worksheet  

Insert -> Chart The cursor becomes a ‘ + ‘ sign with a small picture of graph indicates where 

you want to insert the chart 

: - colon 

; - Semi colon 

Separates the cells of the same sheet (2 – D Formula), Ex = sum (b4:c4) 

Separates the cells of the different sheet(3 –D Formula),  

Ex =sum(sheet1.b4:c4 ; sheet2.b4:c4) 

File -> Print / Print icon  in standard toolbar to print all the sheets of document (Ctrl +P) 

Format -> Print ranges -> Edit To print a part of the worksheet, select the range to be printed 

Format -> Print ranges -> Delete To remove the Print range setting 

File -> Page View To preview the worksheet before printing 

Sheet tab To print the worksheet with grid lines, choose Format -> page and click sheet tab 
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STAR BASE 

Datum Data comes from the word ‘datum’ 

Character, Number, Boolean The types of data in Star base 

Integer & Float Primitive data types / Built – in / System defined 

User-defined data types It provides a facility by which users can create their own sophisticated data types 

Information Processed data 

Data Processing Involves Data Collection, Verification & Validation and Report Generation 

Manual data processing The work carried out by long hand effort / manual 

Computerized data processing If we use computers to edit, store, process & the print the data 

File / Table The entire collection of related data in one table  

Record Each row in a table, which is a set of data for each database entry 

Field Each column in a table, which groups each piece or item of data among the records 

Manipulation of database Searching, Sorting, Merging, Performing calculations on data, Filtering, Editing 

the database & Report Generation 

Types of database Flat-File, Hierarchical , Relational, Network and Object Oriented  

Flat – F+ile database It consists of a single database table quite useful for small group of institutions 

Relational database Relational structure represents a database made up of related tables, is the most 

prevalent in today’s business organization 

Primary key The common field in one or more tables create relationship is called keys. A 

primary key is a key which uniquely identifies a record 

Hierarchical database It was primarily used on Main Frame computers, records are organized in a 

tree like structure by type. The relationship between record types is said to be 

Parent child relationship, in which any child relates to only a single parent 

type 

Network database Is similar to hierarchical except that any one record type can relate to any number 

of other record types 

Object – Oriented database It groups data items and their associated characteristics, attributes, and procedures 

into complex items called objects 

Database Is a repository collections of related data or facts arranged in a specific structure 

File -> New -> Database To create a new database 

DBMS Is a program, or collection of programs that allows any number of users to access, 

modify, and construct simplex and complex requests to obtain and work with 

selected records 

Table, Queries, Forms & Reports in Database pane in Star base. There are 3 panes in Star base they are Database, 

Tasks & tables 

Insert -> Table Design / Click on 

“create table in Deign view” option 

To create a new table in star base 

 

20 Fields in Star base 
Text[VARCHAR], Text[VARCHAR_IGNORECASE], Text(Fix), Number, Date / 

Time, Date, Time, Yes / No, Memo, Image, Decimal, Binary Field(Fixed), Binary 

Field, Integer, Tiny Integer, Small Integer4, Big Int, Float, Real, Double 

Integer Data type accepts only whole numbers 

Single Precision Decimal values are accurate up to a length of 7 places 
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Double Precision Decimal values are accurate up to a length of 14 places 

Entry required Is used to specify if the user should always enter a value for that field 

Length  Option is used to specify the maximum characters that can be entered in that field 

Default value Is used to specify a default value to be assigned to that field 

Format Example Allows you to specify the number format and alignment of the text 

Right click on table -> Edit To modify the table design 

Right click on Row -> Delete rows to delete the selected records 

Right click on Row -> Row Height to change the height of the selected record 

Sort Ascending icon  The records in the table are displayed in the ascending order of the specified field 

Sort Descending icon  The records in the table are displayed in the descending order of the specified field 

Sort icon  To sort more than one fields at the same time 

SQL Structured Query Language, designed specifically for communicating with a 

database using statements 

Queries  are the special views of the data in a table, it can be saved for later use. 

Filter  Is also a type of query, the two types of filters are Auto filter & Standard Filter. 

Default filter Filter used with a condition is called default filter 

Remove Filter / Sort  to remove the filter, the original table, with all the records is displayed 

Form Is a simple screen that displays the fields of a record in a well spaced out manner 

Add subform To insert a Another form within the form 

Report Is a printed information that is assembled by gathering data based on user supplied 

criteria 

Types of report Static & Dynamic reports 

Edit -> Paste Special To insert a calc cell range into a document 

DDE Dynamic Data Exchange, The modification in spreadsheet will be seen in Text 

document 

File -> Send -> Outline to 

presentation 

To create a new presentation document with the outline 

File -> Send -> AutoAbstract To transfer each heading together with its paragraphs 

Alt key To Move an object which is hiding behind an object 

Alt + tab To open another window, while working with multiple applications 

Fields > - Move one field at a time, >> - Moves all the listed database fields 

Multimedia Is a computer based presentation technique that incorporated Sound, Text, 

Graphics, animations and video elements 

Multimedia Messaging system 

(MMS) 

Is an application that allows you to send and receive messages over cellphones 

CBT / WBT Computer Based Tutorials, Web Based Tutorials 

Virtual Reality Various multimedia components are coordicnated with a technique, an 

environment which is experienced by users similar to reality 

Input devices Joystick & Sensors 
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Output devices Headphones & Goggles 

GIF ( Graphic Interchange 

Format) 

Are lossless format, Creates a perfect reproduction of the original image. limited 

to 8-bit palette an used for Internet and Multimedia based applications 

JPEG ( Joint Photographic 

Experts Group ) 

Are lossy format, supports full colour and produces relatively small file sizes 

Compression Is a technique by which a recurring set of information is identified an replaced by a 

single piece of information. Types – Lossy & Lossless compression 

Vector Graphics Help in rendering the image effectively on th screen. 

Analog Sounds The sounds that you hear is analog sound, Characteristics- Amplitude & Frequency 

Volume  Is the height of each crest inn the wave 

Frequency Is also called as pitch, is the distance between the crests of the wave. Greater the 

distance, the lower is the sound 

Sampling Conversion of analog sound waves to digital format 

Sound Forge To add special effects such as echo, fade in and fade out effects.  

Animations Are primarily used to illustrate or demonstrate an idea or a concept and based on 

drawings.  

Types of Animation 2-D Animation & 3-D Animation 

Types of 2-D animation Cel-based & Object based animation 

Cel-based animation It consists of multiple drawings, each one a little different from the others. When 

displayed in rapid sequence these drawings appear to move 

Object based animation Also referred to as slide or path based animations, are created by moving an object 

across a screen, seen in computer games 

Steps in creating a 3-D animation Modeling -  To create broad shapes and structures of the 3-D objects 

Animating – To animate these models to define their motion 

& Rendering – To render them by giving attributes such as colors & textures to the 

objects 

Morphing Is a technique by which you can blend two or more images to form a new image  

Warping Is the technique of distorting a single image to represent something else 

< 256 Reducing the colour depth to les than 256 colours results in the image looking 

murky 

< 15 frames Reducing the frame count to less than 15 (fps) frames per second cause the video 

to look jerky 

MIDI Musical Instrument Digital Interface , 1982, it contains only digital notes 

5 Mins MIDI file May be only 25kb, Extension - .midi / .mid 

Real Audio / Real Video Real Networks, 1995, Supports sound and videos, Extension - .rm / .ram 

Au Format Extension - .au. Supports all browser and works across different platforms 

AIFF Audio Interchange File Format, developed by Apple. Extension - .aif / .aiff 

Not supported by all web browsers 

Sound Developed by Apple, Extension - .snd 

WAVE Developed by IBM & Microsoft, Supports all web browsers and computers 

running in Windows OS, Extension - .wav 

MP3 / MPEG Developed by Moving Pictures Experts Group 

.mp3 – Music, Extension - .mp3 / .mpga (MPG Audio)  

& .mpeg – Videos, Extension - .mpg / .mpeg, it offers good compression and high 

quality 
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AVI Audio Video Interleave, Developed by Microsoft in 1902, Video files extension - 

.avi. It is a very common format on the internet 

Windows Media Format Developed by Microsoft, Extension - .wmv 

Quick Time Format Developed by Apple for Videos, Extension - .mov 

Shockwave Format Developed by Macromedia, Extension- .swf 

Multimedia Softwares Flash, Dream weaver & Maya 

Inline sound When sound or video is included as part of a web page, then it is called inline 

sound or video 

<bgsound> & <img> tags to add inline sound to a webpage 

Plug-in  A helper application / plug-in , is a program that can be launched by the browser 

<embed>,<applet> & <object> These tags can be used to launch Helper Applications 

A 5 Sec Audio file Is as heavy as 1mb 

File -> New -> Presentation To create a new impress presentation from within any star office application 

3 options First page of the presentation window displays three options that allow you to 

create an empty presentation, Use a pre-created template or open an existing 

presentation 

Second page Helps to choose the background and output medium of the presentation 

Select an output medium Section in the lower half of the page allows you to specify the final output 

medium for the presentation 

Third page Allows you to specify the transition effects that can be used in the presentation 

Select a slide Transition  Section in the top of the page allows you to choose the transition effect and speed 

in the slides 

Automatic option Allows you to specify the duration for each slide and will automatically flip 

through the slides at the specified speed 

Checking “Show Logo” Check box will display the message “ Created with Staroffice” during the pause 

between each presentation 

File -> New -> Templates and 

Documents / Shift + Ctrl + N 

To create a new presentation using template 

Middle pane Displays the slides in the presentation 

Slide pane on the left displays a thumbnail image of the slide and allows you to edit, rename 7 

rearrange them 

Center pane Allows you to view the slides in the presentation. It displays five tabs they are 

Normal, Outline, Notes, Handout, Slide sorter views.  

Normal View Allows you to create and edit slides 

Outline view Allows you to reorder slides, edit slide titles and heading 

Notes view To add notes to the slides or view any existing notes for the slide, to add additional 

information to a slide 

Handouts view To print the presentation and distribute it as a handout. To scale the slides so that 

several slides can fit into a page 

Slide Sorter view To view miniature images of all the slides and rearrange the slides in the 

presentation 

Task Pane on the right displays four options they are, Master Pages, Layouts, Custom 

Animation and Slide Transition 

Master Page  To specify a basic background information that needs to be included in all the 

slides 
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Layouts to display the various layouts provided by staroffice impress , we can choose a 

layout while designing a new slide 

Slide Show -> Custom Animation To display various options that allow you to add or modify animation effects to 

elements of a slide( Effects can be assigned in Normal view) 

Slide Show -> Slide Transition To  display various transition effects that can be attached to a slide along with 

other options 

 

F5 / Slideshow -> Slideshow / Slide 

show icon 

To Start a presentation 

Slide Show -> Slide Show Settings  To adjust the presentation settings 

Esc key To End the presentation 

Slide Show -> Custom Slide Show To Run a custom slide show in the order that you defined 

Insert -> Slide / Slide button To Insert a new slide 

Slide  -> Rename Slide To Rename a slide 

Right click on slide -> Delete To Delete a slide 

Insert -> Picture -> From File  To Insert a picture 

 

Insert -> Movie and Sounds To Insert a Movie in a slide 
 

Tools -> Media Player To open the Media Player Window 

2 sliders in Media playback 

Toolbar 

Position slider, Volume Slider 

Zoom factor For movie files, the bar also contains a list box where you can select the zoom 

factor for the playback 

Insert -> Object To insert objects like Charts, Formula etc in a presentation 

Insert Formula  

 

To insert a formula into the presentation for performing calculations 

Insert OLE Object To import objects from other applications into a presentation 

View -> Toolbars -> Slide View It is the easiest way to assign slide transistion effects, it displays the slide in certain 

specified numbers 

Entrance, Emphasis, Exit & Motion 

Paths 

Are the effects that can be added in Custom Animation 

Format -> Page -> Background To change slide background. Fill options – Color, Gradient, Hatching, Bitmap 

Master Slide Determines the text formatting style for title, outline and the background design for 

individual slides 

Format -> Slide Design To apply a new slide design 

Outline 1 to 9 The styles Outline 1 to 9 enables you to give the outlined headings and topics on 

your slides a uniform look 

Slide layout Determines the number of outline levels 

View -> Outline View To activate the outline view mode 

Format -> Styles and Numbering / 

F11 key 

To open stylist 

Enter key To create a title for a slide in Stylist 

Tab key To create a subtitle for a slide in stylist ( to move one level down while creating a 

subtitle) 
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Shift + Tab To move one level up while creating a sub title 

Slide Show -> Custom Slide Shows To create a custom slideshow in the order you define 

Tools -> Options -> Star Office 

Impress -> General 

To start a presentation from the current slide 

Slide Show -> Show / Hide Slide To Show / Hide a slide from the slides pane 

Slide Show-> Rehearse Timings To record the display time for each slide in normal view and use it fro automatic 

slide changes, the timing will be as recorded. Click Auto Check box 

Tools -> Options -> Star Office 

Impress -> Print 

To set the default printing options for star office impress 

Print file directly To print the current document with default settings, Print File Directly in the 

Function bar 

Fit Object to paper format check 

box 

To print a slide to fit a paper size 

Edit -> Navigator or navigator icon in the function bar, to move from one slide to slide quickly 

File -> Export To export a presentation as a webpage 

Use Browser Colours To apply the colours supported by browsers. Standard Resolution - Medium 

Presentation Can be created using a template or can be created from scratch 

PDF, SWF, JPEG, Webpage Are the different formats in which a presentation can be exported 

Slide Show Is a series of slides, or pages, that present information on a specific topic 

Handout Slides in a presentation can be printed as a handout, so that several slides can be 

printed on a single page of paper 
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