COMPUTER SCIENCE
PRACTICAL GUIDE 2018-19
[ ENGLISH MEDIUM ]

NAME: ______________________________________

SUBJECT: ______________________________________

SCHOOL: ______________________________________
INSTRUCTIONS FOR THE CONDUCT OF PRACTICAL CLASSES & EXAMINATION:

12 Exercises from Star Office and 12 from C++ are practiced in the practical classes.

The Question paper will have two sections A and B.

Section A: One question from Star Office with Internal Choice.
Section B: One question from C++ with Internal Choice.

DISTRIBUTION OF MARKS:

<table>
<thead>
<tr>
<th>Internal Assessment:</th>
<th>10 Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sessional Marks for Class Lab Works</td>
<td></td>
</tr>
<tr>
<td>Attendance</td>
<td>3 Marks</td>
</tr>
<tr>
<td>Observation &amp; Performance of the periodical test</td>
<td>2 Marks</td>
</tr>
<tr>
<td>Record Book</td>
<td>5 Marks</td>
</tr>
<tr>
<td>External Assessment:</td>
<td>20 Marks</td>
</tr>
<tr>
<td>StarOffice</td>
<td>10 Marks</td>
</tr>
<tr>
<td>Procedure</td>
<td>5 Marks</td>
</tr>
<tr>
<td>Execution</td>
<td>5 Marks</td>
</tr>
<tr>
<td>C++</td>
<td>10 Marks</td>
</tr>
<tr>
<td>Procedure</td>
<td>5 Marks</td>
</tr>
<tr>
<td>Execution</td>
<td>5 Marks</td>
</tr>
<tr>
<td>Total Marks:</td>
<td>30 Marks</td>
</tr>
</tbody>
</table>
## CONTENTS

### Section – A  StarOffice

<table>
<thead>
<tr>
<th>S.No</th>
<th>Heading</th>
<th>Page No</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TEXT EDITING AND FORMATTING</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>PAGE FORMATTING</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>TABLE CREATION</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>MARK LIST</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>PAY ROLL</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>SERIES GENERATING</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>STUDENT DETAILS</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>FORM DESIGNING</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>SORTING RECORDS</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>MY SCHOOL</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>PRESENTATION USING TEMPLATES</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>WEEK DAYS</td>
<td></td>
</tr>
</tbody>
</table>

### Section – B  C++ Programming

<table>
<thead>
<tr>
<th>S.No</th>
<th>Heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>13</td>
<td>FIBONACCI SERIES</td>
</tr>
<tr>
<td>14</td>
<td>FACTORIAL NUMBERS</td>
</tr>
<tr>
<td>15</td>
<td>NUMBERS DISPLAY IN WORDS</td>
</tr>
<tr>
<td>16</td>
<td>PALINDROME</td>
</tr>
<tr>
<td>17</td>
<td>ODD AND EVEN NUMBERS</td>
</tr>
<tr>
<td>18</td>
<td>TRANSPOSE MATTI</td>
</tr>
<tr>
<td>19</td>
<td>MATRIX ADDITION</td>
</tr>
<tr>
<td>20</td>
<td>PRIME NUMBERS</td>
</tr>
<tr>
<td>21</td>
<td>USING CLASSES</td>
</tr>
<tr>
<td>22</td>
<td>FUNCTION OVERLOADING</td>
</tr>
<tr>
<td>23</td>
<td>INHERITANCE</td>
</tr>
<tr>
<td>24</td>
<td>WORDS TRIANGLE</td>
</tr>
</tbody>
</table>
1. TEXT EDITING AND FORMATTING

AIM:

To create a text document and perform the editing options like cut, copy, paste, find and replace, correcting typographical mistakes using auto correct option and the formatting options like font and color changing, paragraph alignments and adding bullets or numbered lists.

PROCEDURE:

I. Entering the given text:
1. Invoke Star Office Writer using Start → All Programs → StarOffice 8 → StarOffice Writer.
2. Type the following text:

   Heaven from all creatures hides the book of fate.
   All but the page prescribe the present state.
   A hero perishes or a sparrow fall.

II. Moving the text:
1. Select the text to be moved to a new location.
2. Select Edit → Cut or press Ctrl + X.
3. Move the insertion point to the required location where the text is to be pasted.
4. Select Edit → Paste or press Ctrl + V.

III. Copying the text:
1. Select the text to be copied.
2. Select Edit → Copy or press Ctrl + C.
3. Move the insertion point to the required location where the text is to be pasted.
4. Select Edit → Paste or press Ctrl + V.

IV. Finding and replacing text:
1. Choose Edit → Find & Replace, the Find & Replace dialog box appears on the screen.
2. Type the word “Heaven” in the Search for text box and “God” in the Replace with text box.
3. Click Find button, then click Replace [or Replace All] button.
4. Click Close button.

V. Changing the Fonts and Color:
1. Select the text and choose Format → Character, the Character dialog box appears on the screen.
2. Choose the required font and click OK button.
3. Select the text to be colored and click on Font Color icon that displays a color palette, to click the color.

VI. Paragraph alignment:
1. Place the insertion point in the first line.
2. Click the required left / right / center / justify icons. (Or press Ctrl + L, Ctrl + R, Ctrl +E, Ctrl +J)

VII. Creating Bullets or Numbered Lists:
1. Place the insertion point in the second line.
2. Click the Bullets or Numbering icon on the formatting toolbar.

VIII. Correcting typographical mistakes:
1. Select Tools → AutoCorrect, the AutoCorrect dialog box appears on the screen and click Replace tab.
2. Type the word to be replaced is in the Replace text box and the replacement word is in the with text box.
3. Click New and then OK button.
Output:

Heaven from all Creatures hides the book of fate
All but the Page Prescribe the Present State
A hero perishes or a sparrow fall.

Cut
All but the Page Prescribe the Present State
A hero perishes or a sparrow fall.

Paste
Heaven from all Creatures hides the book of fate

Copy
Heaven from all Creatures hides the book of fate
All but the Page Prescribe the Present State
A hero perishes or a sparrow fall.

Paste
Heaven from all Creatures hides the book of fate

Search (Find)

Heaven from all Creatures hides the book of fate
All but the Page Prescribe the Present State
A hero perishes or a sparrow fall.

Replace

God from all Creatures hides the book of fate
All but the Page Prescribe the Present State
A hero perishes or a sparrow fall.

Fonts and Color also alignment with list

God from all creatures the book of fate.

- All but the page prescribe the present state.
  A hero perishes or a sparrow fall.

CONCLUSION:

The text editing and formatting options are done successfully.
2. PAGE FORMATTING

AIM:
To change the margin settings, page orientation and insert header and footer.

PROCEDURE:

I. Entering the text:
1. Invoke StarOffice Writer using Start → All Programs → StarOffice 8 → StarOffice Writer.

2. Type the following text:
The margins for a particular page can be set to an exact value using a Page Style dialog box or approximately using Rulers. Header and Footer are some references remarks added to at every page of the document of the top and bottom margins respectively.

II. Changing the margins:
1. Click Format → Page, the Page Style dialog box appears on the screen.
2. Click the Page tab, type 0.5 inches in Left and Right spin boxes under Margins group and click on OK button.
3. To change the margins to original settings, place the mouse pointer between the grey and white area of the ruler. It becomes double headed arrow, now click and drag to a new margin.

III. Changing page orientation:
1. In Page Style dialog box, click the Page tab.
2. In the Orientation area, select the portrait or landscape option button and click on OK button.

IV. Creating a Header and Footer:
1. Click Format → Page, the Page Style dialog box appeared on the screen.
2. Select the Header tab and click the Header on checkbox.
3. Select the Footer tab and click the Footer on checkbox.
4. Now click OK button.
5. Click inside the header area and type the text Page Formatting as topic name.
6. Click inside the footer area and choose Insert → Fields → Page Number to insert page numbers on every page.

Output:

CONCLUSION:
The margin settings, page orientation are changed and header and footer are created successfully.
3. TABLE CREATION

AIM:
To prepare students mark list using table

PROCEDURE:

I. Creating Table:

1. Invoke StarOffice Writer using Sart → All Programs → StarOffice 8 → StarOffice Writer.
2. Select Table → Insert → Table option that displays Insert Table dialog box.
3. Type the table name as Mark list in Name text box, number of columns as 4 in Columns spin box and number of rows as 6 in Rows spin box.
4. Click OK button.
5. Enter the names of five students and marks in three subjects.

II. Changing the table borders, line style and background:

1. Select the table or the require cell or cell range.
2. Click Table → Table Properties, the Table Format dialog box appears on the screen.
3. Select the Borders tab and choose the desired borders and line styles.
4. Select the Background tab and choose the desired back color.
5. Click on OK button.

III. Adding rows:

1. Place the insertion point to the last row of the table and choose Table → Insert → Rows.
2. In Insert Rows dialog box, type 2 in Amount spin box and choose After option in Position area and then click on OK button.
3. Enter two students mark details in the last added rows.

Output:

<table>
<thead>
<tr>
<th>STUDENT NAME</th>
<th>TAMIL</th>
<th>ENGLISH</th>
<th>COMPUTER</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANAND.S</td>
<td>112</td>
<td>112</td>
<td>120</td>
</tr>
<tr>
<td>LOKESHWARAN.G</td>
<td>120</td>
<td>120</td>
<td>130</td>
</tr>
<tr>
<td>NAVEENKUMAR.S</td>
<td>140</td>
<td>130</td>
<td>122</td>
</tr>
<tr>
<td>YUVARAJ.K</td>
<td>100</td>
<td>120</td>
<td>131</td>
</tr>
<tr>
<td>SATHISH.K</td>
<td>102</td>
<td>130</td>
<td>112</td>
</tr>
</tbody>
</table>

After add two rows change border, line style and background color:

<table>
<thead>
<tr>
<th>STUDENT NAME</th>
<th>TAMIL</th>
<th>ENGLISH</th>
<th>COMPUTER</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANAND.S</td>
<td>112</td>
<td>112</td>
<td>120</td>
</tr>
<tr>
<td>LOKESHWARAN.G</td>
<td>120</td>
<td>120</td>
<td>130</td>
</tr>
<tr>
<td>NAVEENKUMAR.S</td>
<td>140</td>
<td>130</td>
<td>122</td>
</tr>
<tr>
<td>YUVARAJ.K</td>
<td>100</td>
<td>120</td>
<td>131</td>
</tr>
<tr>
<td>SATHISH.K</td>
<td>102</td>
<td>130</td>
<td>112</td>
</tr>
<tr>
<td>THAMIZH RAJAN.D</td>
<td>145</td>
<td>91</td>
<td>145</td>
</tr>
<tr>
<td>ABDUL ALTHAF.N</td>
<td>160</td>
<td>146</td>
<td>130</td>
</tr>
</tbody>
</table>

CONCLUSION:
The students mark list is successfully created using table.
4. MARK LIST

AIM:
To prepare a mark list and find the total marks, average and the class average for each subject using spreadsheet.

PROCEDURE:

1. Invoke Star Office Calc by clicking on Start → All Programs → StarOffice8 → StarOfficeCalc.
2. Type the following details:
3. Place the cell pointer in E2, type the formula \( =\text{SUM}\ (B2 : D2) \). To copy it to other cells using Fill command, select the cell range E2 : E6 and click on Edit → Fill → Down.
4. Place the cell pointer in F2, type the formula \( =\text{AVERAGE}\ (B2 : D2) \). To copy it to other cells using Fill command, select the cell range F2 : F6 and click on Edit → Fill → Down.
5. Place the cell pointer in B7, type the formula \( =\text{AVERAGE}\ (B2 : B6) \). To copy it to other cells using Fill command, select the cell range B7 : D7 and click on Edit → Fill → Right.

Output:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>STUDENT NAME</td>
<td>TAMIL</td>
<td>ENGLISH</td>
<td>COMPUTER</td>
<td>TOTAL</td>
</tr>
<tr>
<td>1</td>
<td>ANAND.S</td>
<td>112</td>
<td>112</td>
<td>120</td>
<td>344</td>
</tr>
<tr>
<td>2</td>
<td>LOKESHWARAN.G</td>
<td>120</td>
<td>120</td>
<td>130</td>
<td>370</td>
</tr>
<tr>
<td>3</td>
<td>NAVEENKUMAR.S</td>
<td>140</td>
<td>130</td>
<td>122</td>
<td>392</td>
</tr>
<tr>
<td>4</td>
<td>YUVARAJ.K</td>
<td>100</td>
<td>120</td>
<td>131</td>
<td>351</td>
</tr>
<tr>
<td>5</td>
<td>SATHISH KUMAR.K</td>
<td>102</td>
<td>130</td>
<td>112</td>
<td>344</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>AVERAGE</td>
<td>114.80</td>
<td>122.40</td>
<td>123.00</td>
<td></td>
</tr>
</tbody>
</table>

CONCLUSION:
The mark list is prepared and found total marks, average and the class average.
5. PAY BILL

AIM:
To prepare a pay bill, show the variations of basic pay of the employees using a chart.

PROCEDURE:

I. Entering the employee details:
1. Invoke Star Office Calc by clicking on Start → All Programs → StarOffice8 → StarOfficeCalc.
2. Type the following details:
3. Calculate the Gross pay by entering the formula = \( \text{Sum} (C2 : F2) \) in the cell G2. To copy the gross pay to other row, select G2 to G6. Click on Edit → Fill → Down.

II. Changing the row height and column width:
1. Select the row whose height is to be changed and click Format → Row → Height that displays Row Height dialog box. Type the new height in Height spin box and click on the Ok button.
2. Select the column whose width is to be changed and click Format → Column → Width that displays Column Width dialog box. Type the new width in Width spin box and click on the Ok button.

III. Sorting the records:
1. Select the entire details of the employees from A1 to G6.
2. Click on Data → Sort, select the Emp. Name in the Sort by option. Click Ascending option button and OK button.

IV. Adding and deleting the records:
1. Move the cell pointer to the end of the records and type two new records.
2. Select the row to be deleted, choose Edit → Delete Cells option that displays Delete Cells dialog box.
3. Select Delete entire row(s) option and click OK button.

V. Creating a chart:
1. Select the cell range B1 to C7 and choose Insert → Chart that displays Auto Format Chart dialog box, click on Next button.
2. Choose the pie chart in Choose a chart type and click Columns radio button in Data Series in area then click Next button.
3. Choose a desired type of chart in the Choose a variant option, again click on Next button.
4. Type Employee Pay Details in Chart Title text box and click on Create button.

Before sorting the records:

<table>
<thead>
<tr>
<th>EMP.NO</th>
<th>EMP.NAME</th>
<th>BASIC PAY</th>
<th>DA</th>
<th>CCA</th>
<th>HRA</th>
<th>GROSSPAY</th>
</tr>
</thead>
<tbody>
<tr>
<td>101</td>
<td>ANAND.S</td>
<td>5800</td>
<td>300</td>
<td>300</td>
<td>400</td>
<td>6800</td>
</tr>
<tr>
<td>102</td>
<td>LOKESHWARAN.G</td>
<td>5000</td>
<td>350</td>
<td>300</td>
<td>450</td>
<td>6100</td>
</tr>
<tr>
<td>103</td>
<td>NAVEENKUMAR.S</td>
<td>6000</td>
<td>350</td>
<td>450</td>
<td>500</td>
<td>7300</td>
</tr>
<tr>
<td>104</td>
<td>YUVARAJ.K</td>
<td>6500</td>
<td>350</td>
<td>450</td>
<td>450</td>
<td>7750</td>
</tr>
<tr>
<td>105</td>
<td>SATHISH KUMAR.K</td>
<td>7000</td>
<td>400</td>
<td>500</td>
<td>600</td>
<td>8500</td>
</tr>
</tbody>
</table>
After sorting the records:

<table>
<thead>
<tr>
<th>EMP.NO</th>
<th>EMP.NAME</th>
<th>BASIC PAY</th>
<th>DA</th>
<th>CCA</th>
<th>HRA</th>
<th>GROSSPAY</th>
</tr>
</thead>
<tbody>
<tr>
<td>101</td>
<td>ANAND.S</td>
<td>5800</td>
<td>300</td>
<td>300</td>
<td>400</td>
<td>6800</td>
</tr>
<tr>
<td>102</td>
<td>LOKESHWARAN.G</td>
<td>5000</td>
<td>350</td>
<td>300</td>
<td>450</td>
<td>6100</td>
</tr>
<tr>
<td>103</td>
<td>NAVEENKUMAR.S</td>
<td>6000</td>
<td>350</td>
<td>450</td>
<td>500</td>
<td>7300</td>
</tr>
<tr>
<td>104</td>
<td>SATHISH KUMAR.K</td>
<td>7000</td>
<td>400</td>
<td>500</td>
<td>600</td>
<td>8500</td>
</tr>
<tr>
<td>105</td>
<td>YUVARAJ.K</td>
<td>6500</td>
<td>350</td>
<td>450</td>
<td>450</td>
<td>7750</td>
</tr>
</tbody>
</table>

Pie chart for employee salary:

CONCLUSION:

The pay bill is successfully prepared and displayed the variations of basic pay in a chart.
6. SERIES GENERATION

AIM:
To generate the given series of date and numbers using StarOffice Calc.

PROCEDURE:

1. Invoke Star Office Calc by clicking on Start→All Programs→StarOffice8→StarOffice Calc.

I. Generating the series 3/5/00, 3/12/00, 3/19/00……., 5/28/00

1. Click on the column heading A.
2. Choose Edit → Fill → Series that displays Fill Series dialog box, select Down as Direction, Date as Type and Day as Time unit.
3. Type 3/5/00 as Start value and 5/28/00 as End value and 7 as Increment, and then click on OK button.

II. Generating the series 16, 32, 64, 128 ……., 2048:

1. Click on the column heading B.
2. Choose Edit → Fill → Series option that displays Fill Series dialog box, select Down as Direction and Growth as Type.
3. Type the value 16 as Start value, 2048 as End value and 2 as increment, and then click on OK button.

III. Generating the series 33, 30, 27……., 3:

1. Click on the column heading C.
2. Choose Edit → Fill → Series option that displays Fill Series dialog box, select Down as Direction and Linear as Type.
3. Type the value 33 as start value, 3 as End value and -3 as increment, and then click on OK button.

Output:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3/5/2000</td>
<td>16</td>
<td>33</td>
</tr>
<tr>
<td>2</td>
<td>3/12/2000</td>
<td>32</td>
<td>30</td>
</tr>
<tr>
<td>3</td>
<td>3/19/2000</td>
<td>64</td>
<td>27</td>
</tr>
<tr>
<td>4</td>
<td>3/26/2000</td>
<td>128</td>
<td>24</td>
</tr>
<tr>
<td>5</td>
<td>4/2/2000</td>
<td>256</td>
<td>21</td>
</tr>
<tr>
<td>6</td>
<td>4/9/2000</td>
<td>512</td>
<td>18</td>
</tr>
<tr>
<td>7</td>
<td>4/16/2000</td>
<td>1024</td>
<td>15</td>
</tr>
<tr>
<td>8</td>
<td>4/23/2000</td>
<td>2048</td>
<td>12</td>
</tr>
<tr>
<td>9</td>
<td>4/30/2000</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>5/7/2000</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>5/14/2000</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>5/21/2000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>5/28/2000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

CONCLUSION:

The given series are generated successfully.
7. STUDENTS DETAILS

AIM:
To list the students details aged 18 and above.

PROCEDURE:

I. Creating database table:
1. Invoke StarOffice Base by clicking on Star → All Programs → StarOffice 8 → StarOffice Base.
2. Select the require database from the Database Wizard.
3. Choose Insert → Table Design, the Table Design window appears on the screen.
4. Type the following table structure:
5. Right click on the small triangle to the left of the field SNo and choose Primary Key.
6. Press Ctrl + S, enter the table name as Student_details in the dialog box which appears on the screen.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNo</td>
<td>Number [NUMERIC]</td>
<td>Serial Number</td>
</tr>
<tr>
<td>Name</td>
<td>Text [VARCHAR]</td>
<td>Name of the student</td>
</tr>
<tr>
<td>Age</td>
<td>Number [NUMERIC]</td>
<td>Age of the student</td>
</tr>
<tr>
<td>Gender</td>
<td>Text [VARCHAR]</td>
<td>Gender of the student</td>
</tr>
</tbody>
</table>

II. Adding the records:
1. Select Student details on the Table pane and then choose Edi → Open Database Object.
2. Now enter the following data:
3. Save the data by pressing Ctrl + S.

III. Filtering the records:
1. Click the Standard Filer icon on the toolbar that displays Standard Filer window.
2. Choose Age as Field Name, >= as Condition and type 18 in Value text box.
3. Click on OK button
OUTPUT:

CONCLUSION:

The details of students aged 18 and above are listed successfully.

8. FORM DESIGNING

AIM:

To create a table and use it to design a form in Star Office Base to view students marks.

PROCEDURE:

1. Creating database table:
   1. Invoke StarOffice Base by clicking on Start ➔ All Programs ➔ StarOffice 8 ➔ StarOffice Base.
   2. Select the require database from the Database Wizard.
   3. Choose Insert ➔ Table Design, the Table Design window appears on the screen.
   4. Type the following table structure:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RegNo</td>
<td>Number [NUMERIC]</td>
<td>Register Number</td>
</tr>
<tr>
<td>Name</td>
<td>Text [VARCHAR]</td>
<td>Students Name</td>
</tr>
<tr>
<td>Tamil</td>
<td>Number [NUMERIC]</td>
<td>Tamil Mark</td>
</tr>
<tr>
<td>English</td>
<td>Number [NUMERIC]</td>
<td>English Mark</td>
</tr>
<tr>
<td>Maths</td>
<td>Number [NUMERIC]</td>
<td>Mathematics Mark</td>
</tr>
<tr>
<td>Science</td>
<td>Number [NUMERIC]</td>
<td>Science Mark</td>
</tr>
<tr>
<td>Social</td>
<td>Number [NUMERIC]</td>
<td>Social Science Mark</td>
</tr>
<tr>
<td>Total</td>
<td>Number [NUMERIC]</td>
<td>Total Mark</td>
</tr>
<tr>
<td>Average</td>
<td>Number [NUMERIC]</td>
<td>Average Mark</td>
</tr>
</tbody>
</table>
5. Right click on the small triangle to the left of the field RegNo and choose Primary Key.
6. Press Ctrl + S, enter the table name as Mark list in the dialog box which appears on the screen.

II. Adding two more fields:
1. Select the Tables option from <Database> pane and right click on the Mark list table, choose the Edit option from the submenu that appears.
2. In the Table Design window, type two more fields like Result and Comment of type Text[VARCHAR] and press Ctrl + S to save the modification.

III. Adding records:
1. Select Mark list on the Table pane and then choose Edit → Open Database Object.
2. Now enter the data into the table. After completing, save again.

IV. Form Designing:
1. Select Forms icon in <Database> pane and then select Use Wizard to Create Form that appears Form Wizard window on the screen.
2. Select Mark list table and choose all fields in the Available Fields text area. Click Next button for two times.
3. In the Data Entry Mode window, select The form is to display all data radio button and click Next button.
4. Select the require form style from Apply styles Apply styles box and then click Next button.
5. Type the name of the form as Mark list_Form and select the Work with the form radio button.
6. Now click on Finish button.

CONCLUSION:
The students Mark list form is successfully designed
9. SORTING RECORDS

AIM:
To create a database table and sort the records.

PROCEDURE:

I. Creating table:
1. Invoke StarOffice Base by clicking on Start → All Programs → StarOffice 8 → StarOffice Base.
2. Select the require database from the Database Wizard.
3. Choose Insert → Table Design, the Table Design window appears on the screen.
4. Type the following fields:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RegNo</td>
<td>Number [NUMERIC]</td>
<td>Register Number</td>
</tr>
<tr>
<td>Name</td>
<td>Text [VARCHAR]</td>
<td>Students Name</td>
</tr>
<tr>
<td>Tamil</td>
<td>Number [NUMERIC]</td>
<td>Tamil Mark</td>
</tr>
<tr>
<td>English</td>
<td>Number [NUMERIC]</td>
<td>English Mark</td>
</tr>
<tr>
<td>Maths</td>
<td>Number [NUMERIC]</td>
<td>Mathematics Mark</td>
</tr>
<tr>
<td>Science</td>
<td>Number [NUMERIC]</td>
<td>Science Mark</td>
</tr>
<tr>
<td>Social</td>
<td>Number [NUMERIC]</td>
<td>Social Science Mark</td>
</tr>
<tr>
<td>Total</td>
<td>Number [NUMERIC]</td>
<td>Total Mark</td>
</tr>
<tr>
<td>Average</td>
<td>Number [NUMERIC]</td>
<td>Average Mark</td>
</tr>
</tbody>
</table>

5. Right click on the small triangle to the left of the field RegNo and choose Primary Key.
6. Press Ctrl + S, enter the table name as Marklist in the dialog box which appears on the screen.

II. Adding records:
1. Select Marklist on the Table pane and then choose Edit → Open Database Object.
2. Now enter the data into the table. After completing, press Ctrl + S to save the table.

III. Sorting the records:
In the Marklist Table window, select the Total field by clicking on it at the top of the table. Then click on either the Sort ascending icon or Sort descending icon.

OUTPUT:

CONCLUSION:
The database records are sorted.
10. MY SCHOOL

AIM:
To create a presentation about my school in five slides and changes the background and fonts.

PROCEDURE:

I. Creating presentation:
1. Click on Start → All Programs → StarOffice 8 → StarOffice Impress that displays Presentation Wizard.
2. Select Empty presentation option in Type area and click on Next button.
3. Select a slide design and output medium in the second page of Presentation Wizard and then click on Next button.
4. In third page, choose slide transition effect and presentation type and then click on Create button.
5. Choose a layout in StarOffice Impress Presentation Window and type about your school.

II. Inserting Slides:
1. Choose Insert → Slide, if want a new layout; choose it from Layouts page in Tasks pane.
2. Type the content about your school.
3. Use the above steps (1) and (2) for three times.

III. Changing Slide Background and Fonts:
1. Choose Format → Page that displays Page Setup dialog box, select the Background tab.
2. Select the require background fill options from Fill combo box and select the required background in the list and then click OK button.
3. To change background fill for all slides, click Yes button on the Page Settings dialog box that appears.
4. Select the required contents and click Format → Character, choose Font tab in Character dialog box.
5. Select the required fonts and click OK button.
6. Press F5 to run the slide show.

OUTPUT:

CONCLUSION:
The presentation about my school is prepared and changed the background and fonts.
11. PRESENTATION USING TEMPLATES

AIM:
To create a presentation using templates and list the StarOffice functions in bullets.

PROCEDURE:

I. Creating presentation:

1. In StarOffice window, select File → New → Templates and Documents that displays Templates and Documents dialog box.
2. Double click on Education under Templates icon and then select Academic Presentation.
3. Now click Open button.
4. Select all the nine slides except the second slide in the Slide Sorter view and press the Delete key.
5. In the remaining slide, type the heading as STAROFFICE FUNCTIONS and below the heading section types the StarOffice functions one by one.
6. Save the presentation by clicking on File → Save and press F5 to run the slide show.

OUTPUT:

CONCLUSION:

The presentation is prepared using templates and listed the StarOffice functions.
12. DAYS OF A WEEK

AIM:
To sort and display week days in a presentation and add appropriate pictures and sound.

PROCEDURE:

I. Creating presentation:
1. Click on Start → All Programs → StarOffice 8 → StarOffice Impress that displays Presentation Wizard.
2. Select Empty presentation option in Type area and click on Next button.
3. Select a slide design and output medium in the second page of Presentation Wizard and then click on Next button.
4. In third page, choose slide transition effect and presentation type and then click on Create button.
5. Choose a layout in StarOffice Impress Presentation Window and type Sunday in the first slide.

II. Inserting Slides, Pictures and Sound:
1. Choose Insert → Slide, if want a new layout; choose it from Layouts page in Tasks pane.
2. Type Monday.
3. Click Insert → Picture → From File option that displays Insert Picture dialog box, choose the required picture.
4. Select Insert → Movie and Sound, choose the require file from the Insert Movie and Sound dialog box.
5. Repeat the above steps (1) to (5) up to all days.

III. Sorting the slides:
1. Click the Slide Sorter view tab to sort the slides.
2. Save and run the presentation slide show.

OUTPUT:

CONCLUSION:
The week days are displayed successfully and inserted the required picture and sound.
13. FIBONACCI SERIES

AIM:
To generate the Fibonacci series for n terms.

PROGRAM:

```c
#include<iostream.h>
#include<conio.h>
void main()
{     int i, n, f1, f2, f3;
    clrscr();
    f1 = -1;
    f2 = 1;
    cout<<"Enter the number of terms : ";
    cin>>n;
    cout<<"The Fibonacci series is\n";
    for (i=1; i<=n; i++)
    {
        f3 = f1 + f2;
        cout<<f3<<"\n";
        f1 = f2;
        f2 = f3;
    }
    getch();
}
```

OUTPUT:

Enter the number of terms : 7
The Fibonacci series is
0
1
1
2
3
5
8

CONCLUSION:
The Fibonacci series is successfully generated.
14. FACTORIAL NUMBER

AIM:
To find the factorial value of a given number.

PROGRAM:

```c
#include<iostream.h>
#include<conio.h>
void main( )
{
    int n, f=1;
    clrscr( );
    cout<<"Enter a number : ";
    cin>>n;
    while(n>0)
    {
        f*=n;
        n--;
    }
    cout<<"The Factorial Value is :"<<f;
    getch( );
}
```

OUTPUT:

Enter a number : 5 
The Factorial Value is : 120

CONCLUSION:

The factorial value is founded successfully.
15. NUMBERS DISPLAY IN WORDS

AIM:
To display the given number in words by using switch structure.

PROGRAM:
```c++
#include<iostream.h>
#include<conio.h>
void main ( )
{
    int n;
    clrscr( );
    cout<<"Enter a number : ";
    cin>>n;
    switch (n)
    {
    case 1:
        cout<<"The number is one";
        break;
    case 2:
        cout<< "The number is two";
        break;
    case 3:
        cout<< "The number is three";
        break;
    case 4:
        cout<< "The number is four";
        break;
    case 5:
        cout<< "The number is five";
        break;
    case 6:
        cout<< "The number is six";
        break;
    case 7:
        cout<< "The number is seven";
        break;
    case 8:
        cout<< "The number is eight";
        break;
    case 9:
        cout<< "The number is nine";
        break;
    default :
        cout<< "Enter the number between 1 and 9";
    }
    getch ( );
}
```

OUTPUT:
Enter a number : 5
The number is five

Enter a number : 17
Enter the number between 1 and 9

CONCLUSION:
The given number is successfully displayed in words.
16. PALINDROME

AIM:
To check whether the given string is palindrome or not.

PROGRAM:

```c
#include<iostream.h>
#include<conio.h>
#include<string.h>

void main()
{
    char str1[25],str2[25];
    clrscr();
    cout<<"Enter the string : ";
    cin>>str1;
    strcpy(str2, str1);
    strrev(str1);
    if (strcmp(str1,str2)==0)
        cout<<"The given string is palindrome";
    else
        cout<<"The given string is not palindrome";
    getch();
}
```

OUTPUT:

Enter the string : AMMA
The given string is palindrome.

Enter the string : SASTRA
The given string is not palindrome

CONCLUSION:

The given string is palindrome or not checked successfully.
17. ODD AND EVEN NUMBERS

AIM:
To find the number of odd numbers and even numbers in a given array.

PROGRAM:

```c
# include<iostream.h>
# include<conio.h>
void main ( )
{
    int i, n, a[20], odd=0, even=0;
    clrscr ( );
    cout<<"Enter the number of array elements : ";
    cin>>n;
    cout<< "Enter the array values :n";
    for (i = 0; i < n; i++)
    {
        cin>>a[i];
        if (a[i] % 2 == 0)
            even ++;
        else
            odd ++;
    }
    cout<<"Number of odd numbers :"<<odd;
    cout<<"nNumber of even numbers :"<<even;
    getch ( );
}
```

OUTPUT:

Enter the number of array elements : 5
Enter the array values :
11
12
13
14
15
Number of odd numbers : 3
Number of even numbers : 2

CONCLUSION:

The number of odd numbers and even numbers are found.
AIM:
To print the transpose of 3 x 3 matrix.

PROGRAM:

```cpp
#include<iostream.h>
#include<conio.h>

void main ()
{
    int i, j, matA[3][3];
    clrscr();
    cout<<"Enter the A matrix elements :\n";
    for (i = 0; i < 3; i++)
    for (j = 0; j < 3; j++)
        cin>>matA[i][j];
    cout<<"\nThe given A matrix is\n";
    for (i = 0; i < 3; i++)
    { 
        for (j = 0; j < 3; j++)
            cout<<'t'<<matA[i][j];
        cout<<'n';
    }
    cout<<"\nThe transpose matrix of A is\n";
    for (i = 0; i < 3; i++)
    { 
        for (j = 0; j < 3; j++)
            cout<<'t'<<matA[j][i];
        cout<<'n';
    }
    getch();
}
```

OUTPUT:
Enter the A matrix elements :
1
2
3
4
5
6
7
8
9
The given A matrix is
1 2 3
4 5 6
7 8 9
The transpose matrix of A is
1 4 7
2 5 8
3 6 9

CONCLUSION:
The transpose matrix is successfully printed.
19. MATRIX ADDITION

AIM:
To add the given two 3 x 3 matrix.

PROGRAM:
#include<iostream.h>
#include<conio.h>
void main()
{
    int i, j, matrixA[3][3], matrixB[3][3], sum_matrix[3][3];
    clrscr();
    cout<"Enter the A matrix elements : \n";
    for (i = 0; i < 3; i++)
    for (j = 0; j < 3; j++)
        cin>> matrixA[i][j];
    cout<<"Enter the B matrix elements : \n";
    for (i = 0; i < 3; i++)
    for (j = 0; j < 3; j++)
        cin>> matrixB[i][j];
    cout<"Addition of the matrices A and B is \n";
    for (i = 0; i < 3; i++)
    {
        for (j = 0; j < 3; j++)
        {
            sum_matrix[i][j] = matrixA[i][j] + matrixB[i][j];
            cout<<sum_matrix[i][j]<<'t';
        }
    }
    getch();
}

OUTPUT:
Enter the A matrix elements :
2
2
2
2
2
2
2
2
2
Enter the B matrix elements :
1
2
3
4
5
6
7
8
9
Addition of the matrices A and B is
3 4 5
6 7 8
9 10 11

CONCLUSION:
The given two matrices are added successfully.
20. PRIME NUMBERS

AIM:
To determine whether the given number is prime or not.

PROGRAM:

```c
#include<iostream.h>
#include<conio.h>
int prime (int n) {
    int i, p=1;
    for (i = 2; i <= n/2; i++)
        if (n % i == 0)
            p = 0;
    return p;
}
void main ( ) {
    int x;
    clrscr ( );
    cout<<"Enter a number : ";
    cin>>x;
    if (prime(x))
        cout<<"\nThe given number "<<x<<" is prime";
    else
        cout<<"\nThe given number "<<x<<" is not prime";
    getch ( );
}
```

OUTPUT:

Enter a number : 5
The given number 5 is prime

Enter a number : 6
The given number 6 is not prime

CONCLUSION:
It is found whether the given number is prime or not.
21. USES OF CLASSES

AIM:
To prepare employee details using class and objects.

PROGRAM:

```c++
#include<iostream.h>
#include<conio.h>
class employee
{
private:
    int empno;
    char ename[20];
    float basic, hra, da, netpay;
    float calculate()
    {
        return (basic + da + hra);
    }
public:
    void havedata()
    {
        cout<<"Enter the employee number :"
        cin>>empno;
        cout<<"Enter the employee name :
        cin>>ename;
        cout<<"Enter the basic pay : 
        cin>>basic;
        cout<<"Enter the HRA amount : 
        cin>>hra;
        cout<<"Enter the DA amount : 
        cin>>da;
        netpay = calculate ( );
    }
    void dispdata ( )
    {
        cout<<"Employee Details"n"------- --------n";
        cout<<"Employee number : "<<empno;
        cout<<"Employee name : "<<ename; cout<<"Basic pay : "<<basic;
        cout<<"HRA : "<<hra;
        cout<<"DA : "<<da;
        cout<<"Netpay : "<<netpay;
    }
};
void main()
{
    clrscr();
    employee emp;
    emp.havedata();
    emp.dispdata();
    getch();
}
```
OUTPUT:
Enter the employee number : 101
Enter the employee name : JOSHINI
Enter the basic pay : 30000
Enter the HRA amount : 1100
Enter the DA amount : 1000

Employee Details
Employee number : 101
Employee name : JOSHINI
Basic pay : 30000
HRA : 1100
DA : 1000
Netpay : 32100

CONCLUSION:
The employee details are prepared using class.

22. FUNCTION OVERLOADING

AIM:
To find the maximum of two numbers and three numbers by using function overloading.

PROGRAM:
#include<iostream.h>
#include<conio.h>
int max(int a, int b)
{
    return ((a > b) ? a : b);
}
int max (int a, int b, int c)
{
    int m;
    m = (a > b) ? a : b;
    m = (m > c) ? m : c;
    return m;
}
void main ( )
{
    int n1, n2, n3, ch;
    clrscr();
    cout<<"Choices \n";
    cout<<"1. Maximum of two numbers\n";
    cout<<"2. Maximum of three numbers \n";
cout<<"\nEnter your choice : ";
cin>>ch;
switch (ch)
{
    case 1:
        cout<<"\nEnter the first number : ";
cin>>n1;
cout<<"\nEnter the second number : ";
cin>>n2;
cout<<"\nThe maximum number is : "<<max(n1,n2);
        break;
    case 2:
        cout<<"\nEnter the first number : ";
cin>>n1;
cout<<"\nEnter the second number : ";
cin>>n2;
cout<<"\nEnter the third number : ";
cin>>n3;
cout<<"\nThe maximum number is : "<<max(n1,n2,n3);
}
getch();

OUTPUT:

Choices:
1. Maximum of two numbers
2. Maximum of three numbers

Enter your choice : 2

Enter the first number : 15
Enter the second number : 35
Enter the third number : 05

The maximum number is: 35

Choices:
1. Maximum of two numbers
2. Maximum of three numbers

Enter your choice : 1
Enter the first number : 11
Enter the second number : 33

The maximum number is: 33

CONCLUSION:

Maximum of two numbers and three numbers are found successfully.
23. INHERITANCE

AIM:
To find the sum and difference of given numbers using inheritance.

PROGRAM:

```c++
#include<iostream.h>
#include<conio.h>
#include<math.h>
class add
{
    int sum;
    protected:
    int num1, num2;
    public:
    add()
    {
        sum=0;
    }
    void accept()
    {
        cout<<"Enter two numbers \n";
        cin>>num1>>num2;
    }
    void plus()
    {
        sum = num1+num2;
        cout<<"The sum is : "<<sum;
    }
};
class subtract : public add
{
    int sub;
    public:
    subtract()
    {
        sub = 0;
    }
    void minus()
    {
        add::accept();
        sub = abs(num1 - num2);
        cout<<"The difference is : "<<sub;
    }
};
void main()
{
    int ch;
    subtract s;
}```
clrscr();
cout<<"Choices : \n";
cout<<"\n 1. Addition";
cout<<"\n 2. Difference\n";
cout<<"\nEnter your choice : ";
cin>>ch;
switch(ch)
{
    case 1:
s.accept();
s.plus();
    break;
    case 2:
s.minus();
    break;
}
getch();

**OUTPUT:**

Choices :

1. Addition
2. Difference

Enter your choice : 1

Enter two numbers
55
20
The sum is : 75

Enter your choice : 2

Enter two numbers
20
5
The difference is : 15

**CONCLUSION:**

The sum and difference are calculated successfully.
24. WORDS TRIANGLE

AIM:
To print the string in the given format.

C
CO
COM
COMP
COMPU
COMPUT
COMPUTE
COMPUTER

PROGRAM:

#include<string.h>
#include<iostream.h>
#include<conio.h>
void main()
{
    int i, l;
    clrscr();
    char name[] ="COMPUTER";
    i = 1;
    l = strlen(name);
    while (i <= l)
    {
        cout.write (name, i);
        cout<<'n';
        i ++;
    }
    getch();
}

OUTPUT:

C
CO
COM
COMP
COMPU
COMPUT
COMPUTE
COMPUTER

CONCLUSION:
The string is printed in the given format successfully.