
H.SC SECOND YEAR: 2018-19 
SUBECT: COMPUTER SCIENCE 

FULL PORTION-I 

CLASS: XII        Time Allowed: 2.30 Hours  ` Maximum marks: 70 

        PART – A      (15 X 1=15) 

 

1. The key that deletes the characters to the right of the insertion point is  

a) Backspace  b) Delete  c) Insert  d) Print Screen  

2. To open Auto Correct dialog box, use the command  

a) Tools →Auto Format  b) Format →Auto Format  c) Tools →AutoCorrect d) Format 

→AutoCorrect  

3. To resize a row, hold down the key and then press the up or down arrows is  

a) Shift   b) Tab   c) Ctrl   d) Alt  

4. Quattro Pro developed from  

a) Lotus Corporation b) Sun Microsystems c) Borland International d) Microsoft Corporation  

5. The common field or fields are called  

a) Primary key  b) Secondary key  c) Index key  d) Keys  

6. HTTP stands for  

a) Hyper Text Transmission Program   b) Hyper Text Transfer Problem  

b) Hyper Text Transaction Protocol   d) Hyper Text Transfer Protocol  

7. x = 1 + pow(3, 2) * ((3 + 2) – (8 – 7) + 2); then x is  

a) 42  b) 51  c) 55  d) 54  

8. switch selection expression must be of  

a) floating type  b) character type  c) integral type  d) any type  

9. Which reduces the speed of program execution?  

a) STACKS  b) Storage classes  c) Tokens  d) Functions  

10. Which contains the declaration of variables and functions?  

a) Block  b) Class body  c) Structures  d) Loops  

11. Which term means a name having two or more distinct meanings?  

a) Overloading  b) Inheritance c) Acquiring  d) Objects  

12. Which of the following can be applied for constructors?  

a) Operator overloading  b) Inheritance  c) Encapsulation  d) Function overloading  

13. Which is derived class in the given statement?  

a) class subtract : public add  class  b) subtract  c) public  d) add  

14. How much percentage of computers used for word processing?  

a) 75%  b) 65%  c) 85%  d) 95%  

15. How many known virus programs are in existence?  

a) 37000  b) 47000  c) 57000  d) 67000  
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PART – B        (6 X 2=12) 

ANSWERS ANY SIX ONLY (Q.NO 21 COMPULSORY) : 

 

16. How can work with multiple documents? 

17. What is the use of page preview? 

18. What is data hiding or data abstractions? 

19. Write a note on String Literal?  

20. What are the rules for actual parameters? 

21. Write a note on write ( )? 

22. Define operator overloading. 

23. What is an abstract class?  

24. What is meant by e-Learning? 

PART – C        (6 X 3=18) 

ANSWERS ANY SIX ONLY (Q.NO 32 COMPULSORY) 

25. How to make the selected rows and columns of the same size? 

26. Define 3-D formula 

27. Write a note on shockwave format of sound file? 

28. Write the steps for creating Rehearse Timing? 

29. How is a pointer variable different from ordinary variable? 

30. Write the syntax of nested if statement? 

31. Write a note on inline functions. 

32. Difference between Data members and Member functions? 

33. What is called theft of “Computer time”? 

PART – D         

      

ANSWERS ALL:         (5 X 5=25) 

 

34. How will you find and replace a given word in StarOffice writer? 

OR 

Draw and Explain the Various function of the icons in the table formatting tool bar? 

 

35. What are Functions? How can you use them in your work sheet? Explain with an example. 

OR 

 

How will you Insert Rows, Columns and cells in a worksheet? Give an example. 

 

 

36. Explain different Database types? 

OR 

What is a filter? What are the types of filters available in star base? 

 

37. Explain switch statement with a suitable example?  

OR 

 

What is if and if…else Statement explain with an example? 

 

38. Define scope? Explain the different types of scopes variables in C++?  

 

OR 

Explain the different types of inheritance?  
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H.SC SECOND YEAR: 2018-19 
SUBECT: COMPUTER SCIENCE 

FULL PORTION-II 

 

CLASS: XII-        Time Allowed: 2.30 Hours  ` Maximum marks: 70 

        PART – A      (15 X 1=15) 
1. The keyboard shortcut for cutting the selected text is  

a) Ctrl + V  b) Ctrl + X  c) Ctrl + A  d) Ctrl + C  

2. Number of points per inch  

a) 62   b) 72   c) 82   d) 36  

3. The menu that is used to add more than one column in a table is  

a) Table →Insert →Columns   b) Format →Columns →Insert      

c) Format →Insert →Columns  d) Table →Columns →Insert  

4. In StarOffice Calc, which of the following format is used to enter date?  

a) DD/MM/YY   b) DD/MM/YYYY  c) MM/DD/YY   d) YY/MM/DD  

5. Database wizard used to create a  

a) Database   b) Table   c) Query   d) Report  

6. Which tags are used to add inline sound and video to a web page?  

a) <sound> and <video>   b) <bgsound> and <image>  

b) <bgsound> and <bgvideo>   d) <img> and <bgsound>  

7. To start presentation, press  

a) F3    b) F5   c) F7    d) F11  

8. The name C++ was coined by  

a) Bjarne Stroustrup   b) Dennish Ritchie  c) Williams Linda  d) Rick Mascitti  

9. . If a = 5 and b = 4, the value of the expression a + b / 2 * 6 is 

a) 15   b) 16   c) 17   d) 18  

10. Which of the following is not a loop?  

a) go to   b) for    c) do – while    d) while\ 
11. The ACSII value of 99 is  

a) b    b) B   c) C   d) c 

12. How much number of elements in the following array declarations?  

int x[ ][2] = {0, 1, 1, 2, 2, 3};  

a) 2   b) 4   c) 5   d) 6  

13. A constructor without any parameters is called as  

a) Formal constructor  b) Default constructor  c) Dummy constructor   

 d) Actual constructor  

14. Which class inherits properties from its parent class?  

a) Base class  b) Derived class  c) Abstract class  d) Virtual class  

15. Which country has cyber law to prevent computer crimes?  

a) America  b) Japan  c) Europe   d) India  
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PART – B        (6 X 2=12) 

ANSWERS ANY SIX ONLY (Q.NO 17 COMPULSORY) : 

 

16. How many ways the mistakes can be corrected in star office writer? 

17. What is the purpose of creating a header and footer in the document? 

18. What is meant by multiple sorting? 

19. What is the use of master page in presentation?  

20. Give two uses of void data type?  

21. What is the main purpose of function prototype?  

22. What is polymorphism? 

23. What are the technical elements you need to reach out the benefits of IT to the common man? 

24. What is a Call centres?  
 

PART – C        (6 X 3=18) 

ANSWERS ANY SIX ONLY (Q.NO 28 COMPULSORY) 

25. Write down the steps for moving a text.  

26. Can we change the data present in a cell? If you do so, how?   

27. What is compression? List its types.  

28. List the advantages of Object Oriented Programming?   

29. Write the different between while , do…while loops 

30. Explain the memory representation of 2-D arrays?   

31. Define the rules for constructor definition and usage.  

32. What are the advantages of inheritance?  

33. Write a short note on Virus?  

 
PART – D         

      

ANSWERS ALL:         (5 X 5=25) 

 

34. How can we Indent text with the paragraph dialog box? 
OR 

How would you carry out the spell check after the entire document is typed? 

 

35. Write the advantages of using Electronic Spreadsheet?  
OR 

 

Explain the different Formatting options available in star office calc. 
 

 

36. What are the various manipulations of a database in star office base? 
OR 

What are the steps involved in generating a report? Explain. 
 

37. Explain the ‘Nested.. if’ statement with an example in C++?  
OR 

Explain do…while loop with example?  

38. Explain call by reference method with suitable example?  
 

OR 

Explain function overloading with rules.  
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H.SC SECOND YEAR: 2018-19 
SUBECT: COMPUTER SCIENCE 

FULL PORTION-III 

 

CLASS: XII        Time Allowed: 2.30 Hours  ` Maximum marks: 70 

        PART – A      (15 X 1=15) 

 
1. Which one does not move when scroll a document?  

a) Insertion point  b) Page   c) Paragraph   d) Lines 
2. If the Increase Indent icon is clicked, the paragraph is indented from the left margin by  

a) 1 inch   b) ¼ inch   c) ½ inch   d) ¾ inch  

3. To open Auto Correct dialog box, use the command  

a) Tools →Auto Format   b) Format →Auto Format   c) Tools →AutoCorrect ) 

Format →AutoCorrect  

4. Place the insertion point inside the table to resize a column, hold down the key and then press the left 

or right arrows is .. 

a) Shift   b) Ctrl   c) Alt  d) Tab  

5. The number of rows contained in the VisiCalc are  

a) 255   b) 1024   c) 254   d) 354  

6. Which of the following is a text operator? 
 a) :   b) !   c) &   d) | 

 
7. Decimal values are accurate up to a length of 14 places in the case of  

a) Short float   b) Single   c) Real  d) Double  

8. In double precision, the decimal values are accurate up to a length of  

a) 13 places   b) 20 places  c) 7 places   d) 14 place 
9. int a = 5, b = 7; c = (a++) – (--b); cout<<c;  

The output of the above code, when it is executed is  

a) 0   b) 9   c) – 1    d) error  

10. The range of unsigned int is  

a) –32768 to 32767   b) 0 to 65535   c) –128 to 127  d) 0 to 65536  

11. n1 is a reference to m1, which may be depicted as  

a) int &n1 = m1 ;   b) int &m1 = n1 ;  c) int m1 = &n1 ;  d) int n1 = &m1 ;  

12. Which of the following statement increments the value stored as 4th element by 1?  

a) number[3++];   b) number[3]++;  c) number[3] = 1;  d) number[3+1];  

13. char, float and double parameters can be matched with int data type due to  

a) Best match strategy  b) Implicit conversion   c) BODMAS rule  d) Type casting  

14. Which prevents people from acquiring bad habits?  

a) Archive unit   b) Emotion containers  c) Camera   d) Speakers  

15. Illegal access to the network or computer system is  

a) Piracy   b) Virus   c) Cracking   d) Snooping  
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PART – B        (6 X 2=12) 

ANSWERS ANY SIX ONLY (Q.NO 20 COMPULSORY) : 

 

16. What is meant by text editing? 

17. How will you add a requited number of rows and columns in a table? 

18. Define “VisiCalc” 

19. What is a Database? 

20. What is Inline sound and video?  

21. What is Encapsulation?  

22. What is meant by the compiler? 

23. Write the general syntax of a function prototype. Give an example. 

24. What is meant by Computer Crime?  
PART – C        (6 X 3=18) 

ANSWERS ANY SIX ONLY (Q.NO 29 COMPULSORY) 

25. Give the steps involved for change the line spacing?  

26. Write down the steps involved to create footer in a document?  

27. Differentiate Relative and Absolute cell addressing.  

28. What primary characteristics distinguish a Flat-files database from a relational database?  

29. How will you launch a slide show on the screen?  

30. What is an Operator and Operand? Give suitable example.  

31. What is switch statement and give it syntax?  

32. Write the characteristics of member functions?  

33. What are the types of constructors? 
PART – D         

   

ANSWERS ALL:         (5 X 5=25) 

 

34. Explain about moving around the document in StarOffice writer? 
OR 

How would you create the bullets and numbered list? 

 

35. Explain the process of changing margin.  
OR 

Explain the type of operators of star office calc with an example   
 

36. What are the various icons in the Insert Object floating tool bar? Mention their functions 
OR 

What is a filter? What are the types of filters available in star base? Give its function? 
 

37. Explain For loop with example? 
OR 

a) Write a short note on SND format. 

b) Write a short note on Wave format. 

c) Write a short note on MP3/MPEG Format.  

 

38.      a)Write note on strlen() function. 

b)Write note on strcpy() function. 

c) Write note on strcmp() function 

OR 

a) How the computers help in Education? 

b) How the computers help in Entertainment?  

c) How the computers help in agriculture? 
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H.SC SECOND YEAR: 2018-19 
SUBECT: COMPUTER SCIENCE 

FULL PORTION-IV 

 

CLASS: XII        Time Allowed: 2.30 Hours  ` Maximum marks: 70 

        PART – A      (15 X 1=15) 

1. Which of the following is not a word processor?  

a) Star Writer  b) Notepad  c) MS word  d) Word 

2. Which font looks professional?  

a) Fajita  b) Arial  c) Wingdings  d) Times New Roman 

3. In Table how to insert the row in the simplest way?  

a) Ctrl  b) Shift + Tab  c) Ctrl + Tab  d) Tab 

4. Which of the following formula calculates the sum of the numbers in the cell A1 of sheet1 and A2 of 

sheet2 ?  

a)   =Sum(sheet1.A1 + sheet2.A2)   b) =Sum(sheet1.A1 : sheet2.A2)  c) =Sum(sheet1.A1 ; 

sheet2.A2) d) =Sum(sheet1.A1 , sheet2.A2) 

5. SQL stands for  

a) Structured Query Language  b) Sorted Query Language c) Sorted Question Language 

d) Structured Question Language 

6. In the text document that contains the outline, choose  

a) File-->Send-->Outline to Presentation  b) File-->Outline to Presentation  c) File--> 

Presentation 

d) File-->Send-->Presentation. 

7. MPEG stands for  

a)Moving Pictures Experts Group   b) Model Pictures Expression Group 

c) Moving Pictures Expression Group   d) Morphing Pictures Experts Group 

8. Which key is used to end a presentation before the end?  

a) ESC   b) Alt   c) Shift   d) Ctrl + Alt 

9. C++ belongs to which category of programming language?  

a) Structured   b) Object Oriented  c) Modular   d) Procedural 

10. int a,b,c; 

a=6, b=7; 

c= (a++) - (--b); 

cout<<c; 

The output of the above code, when it is executed is a) 0   b) 9   c) 11   d) 

error  

11. Which of the following directs the contents of the variable to the object?  

a) <<   b) >>    c) <<=    d) >>= 

12. _______ are the building blocks of C++ programs?  

a) Date types   b) Functions   c) Variables   d) Class 

13. Which function return 0, if the string are equal?  

a) Strcmp()   b) Strcpy()   c) Strlen()   d) Strcat() 

14. The variable that is initialized only when the first object of the class is created is  

a) Static   b) private    c) public    d) protected 

15. Computer ethics has its roots in the work of _____ during world war II.  

a) Norbert Parker  b) Donn parker  c) Norbert wiener   d) Charles babbage 

 

PART – B        (6 X 2=12) 

ANSWERS ANY SIX ONLY (Q.NO 21 COMPULSORY) : 

 

16. What is Star Office? 

17. How will you delete an entire table in the star office writer document? 

18. How will you delete cells, rows and columns in StarCalc? 

19. What is meant by Editing a Data? 

20. What are the classifications of 2-D animation?  
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21. Write a note on enumerated data type and give the syntax and examples?  

22. What is accessibility? 

23. List out the operators that cannot be overloaded. 

24. What is cracking?  

PART – C        (6 X 3=18) 

ANSWERS ANY SIX ONLY (Q.NO 30 COMPULSORY) 

25. What is the difference between copying text and moving text in star office?  

26. List out the various help features in StarOffice Writer. 

27. How will you insert page numbers in footer/header area? 

28. What is the use of declaration statement?  

29. When is a Copy constructor executed?  

30. Write note on Static Data Member?  

31. How are functions invoked in function overloading?  

32. What are the three access specifies used to inherit a derived class? 

33. Name some areas of computers in agriculture. (3m) 

PART – D         

   

ANSWERS ALL:         (5 X 5=25) 

 

       34. What are the various types of paragraph alignments that can be made? 

OR 

Explain how we can select the text in StarOffice writer? 

 

35. How will you insert header and footer and insert page number in entire document. 

 

OR 

How can you generate a series of values? Explain with an example. 

 

36. What are the steps involved in designing a form in star base? Explain.  

OR 

Explain Exit-check loop with example?  

 

37. Explain Inline Functions with an example?  

OR 

What is operator overloading? And what are the rules for operator overloading?  

 

38. a) What are the different between continue statement and break statement?  

             b) What is the different between if…else and switch statement?  

 

OR 

a. What is physical security? 

b. What is personal security? 

c. What is personnel security? 

He knows not he knows not, and he knows not – avoid him 
He knows he knows not, and he knows not- teach him. 
He knows not he knows, and he knows –awaken him. 

He knows he knows , and he knows – follow him. 

Best of Luck student’s 
 

BEST WISHES 

 

FROM 

 

P.CHANDRASEKARAN 

 

PG ASST IN CS 
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