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CHAPTER – 2 

TEXT FORMATTING 

1. Explain how to create a Bulleted and Numbered List in Star Office Writer? 

 One way to create a list of points or topics in a document is to create a bulleted list.  

 A bullet precedes each item in the list, and the text is indented.  

 Numbered lists work well for directions or other points one want to present in sequence. 

Creating a Bulleted List 

 Select the text that to which bullets are to be added.  

 Star Office Writer will add bullets to each paragraph within the selection, and not to each line.  

 Star Office Writer will add bullets to any blank lines within the selection. 

 Click on the Bullets icon (or) Format→Bullets and Numberingcommand from the 

formatting tool bar, Star Office Writer creates a bulleted list. 

 

 

BULLETS DIALOG BOX   NUMBERING DIALOG BOX 

 

Creating Numbered List 

 Select the text to be numbered.  

 Star Office Writer will number each paragraph. Blank lines within the selection will be 

numbered. 

 Click icon (or) Format→Bullets and Numbering command to create a numbered list. 
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Removing the Bullets or Numbers 

 To remove bullets from a list, the list is selected and the Bullets button is clicked again 

(or) Select Format→Bullets and Numberingand choose none. 

 To remove numbers for a list, select the list and click the Numbering button is clicked 

again (or) Select Format→Bullets and Numberingand choose none. 

CHAPTER – 3 

CORRECTING SPELLING MISTAKES 

1. How would you carry out the spell check after the entire document is typed? 

Tools → Spelling→ Check is selected or is clicked or F7 shortcutkey may also be pressed to 

select the spelling command. 

 

 

SPELL CHECK DIALOG BOX 

 Not in dictionary text area displays the misspelled word and the Suggestions list displays any 

alternative spellings.  

Any of the following can be done: 

 To skip this occurrence but stop on the next one. Ignore Once button is clicked. To skip all 

occurrences of this word. Ignore All button is clicked. 

 To replace the word with one of the selected spellings, in the suggestions list that spelling is clicked, 

and Change button is clicked to change this occurrence and Change All button is clicked to replace 

all occurrences of the world. 
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 If none of the replacements is correct, correction can be made manually in the Not in dictionary text 

area.  

 Add button is clicked to add the word to the dictionary. 

CHAPTER – 4 

WORKING WITH TABLES 

1. Explain the various functions of the icon in the Table Formatting Toolbar in Star OfficeWriter? 

 

Table Fixed 

Table Fixed, Proportional 

Table, Variable 

Merge Cells - This icon is used to combine two or more cell into a single cell. 

Split Cells - This icon is used to split a cell into two or more cells. 

Optimize - Clicking on this icon displays a pop up menu with options like Space columns 

equally, Space rows equally, Optimum row height and Optimum column width. 

Inserting Row - This icon is used to insert a row below the current row. 

Inserting Column - This icon inserts a column to the right of the current column. 

Delete Row - This icon deletes the current row from the table.  

Delete Column - This icon deletes the current Column from the table. 
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Borders - This icon displays a floating toolbar with different border option for the table. 

Line Style - This icon is used to choose the style of line to be used for the border. 

Border Colour - Clicking on this icon displays a palette of colors that can be used as a 

border color for the table. 

CHAPTER – 5 

PAGE FORMATTING 

1. Explain the methods of changing the margins? 

Margins can be changed by two methods, 

 Page Style Dialog Box 

 Changing Margins Using Rulers 

PAGE STYLE DIALOG BOX 

 If the user knows the exact value for the margins then the page style dialog box can be used to 

make a change. The following steps are used: 

 Format→Page command is selected. Page style dialog box appears. 

 Click the Page tab. 

 In Margins group, type the new values in the spin boxes or use the spin arrows to change the 

value. 

 Click the OK button. 

 File→Page Preview option menu can be used to see the change. This option gives an overall 

picture of the document and visually shows to the user, how the change has affected the 

document. 

 

                PAGE SYTLE DIALOG BOX 
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CHANGING MARGINS USING RULERS 

 If the user is not having the exact value for the margins then theRuler option on the View menu can 

be used to change the margins. 

Following steps are used in this method: 

 If the ruler is not displayed in the screen, View→Ruler option is clicked. 

 The gray area of the ruler indicates the margin’s top area. 

 The mouse pointer is then moved in between the gray and white area of the ruler. 

 When the pointer is in the right spot, it changes into a double headed arrow 

 The margin guide is dragged to a new location. 

 

2. Explain the Header and Footer?  Explain how to Create Header and Footer in the Star Office 

Writer? 

HEADER 

 Header is an area at the top of page. 

 Header is some references remarks added at every page of the document of the top margin 

respectively. 

FOOTER 

 Footer is an area at the bottom of the page.  

 The user can specify what he wants to display in this area and StarOffice Writer will insert 

the specified text automatically on each page. 

 Footer is some references remarks added at every page of the document of the bottom 

margin respectively. 

 

PAGE SYTLE DIALOG BOX 
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TO ADD HEADER 

 Select Format→Page option 

 Select the Header Tab 

 Click the Header on Check box 

 Click OK button. 

TO ADDFOOTER 

 Select Format→Page option 

 Select Footer Tab 

 Click Footer on Check box 

 Click OK button 

Example for Header and Footer 

 

Header 

Header is an area at the top of page. 

Footer is an area at the bottom of the page. 

Footer 

 

To add the text in the Header and Page Number in Footer 

 Click mouse pointer in Header area 

 Type the word “Heaven” 

 Click the mouse pointer in Footer area 

 Click Insert→Fields→Page number 

 

CHAPTER – 6 

SPREADSHEET 

1. What are the formatting options available in Star Office Calc? 

This is the Bold icon and is used to display data in bold. To use this icon, highlight the cells 

and click on the icon. 

This icon is used to display the data in italics. 

 

This is used to underline the data in highlighted cells. 
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This is the Change Font icon. This icon displays list of fonts 

that can be used.Select the font by clicking on it. 

This icon is used to change the font size of the data. To do so, select the data and click 

on this icon. 

 

This is the Font Colour icon. This can be used to change the font colour. 

 

These are the Align Left, Align Center, Align Right and Justify icons. They 

are used to align the contents of cells.  

This is the Number Format: Currency icon. Clicking on this will display the contents of the 

selected cells in currency format, that is with a $ in front and with two decimal digits. 

 

This is the Number Format: Percent icon. Clicking on this icon will display the current 

contents in percentage format. Note that it multiplies the contents of the cell by 100 and 

displays the result with 2 decimals. 

This is the Number Format: Standard icon. Clicking on this icon will display the contents of 

the selected cells in default format. 

These are the Number Format: Add Decimal and Number Format: Delete Decimal 

icons. They are used to increase or decrease the number of decimal digits that are to be displayed in the 

selected cells. 

 

2. What are the various icons in the inset object floating tool bar of worksheet? Mention their 

functions and uses? 

 Insert Chart Icon 

 Insert Formula Icon 

 Insert Floating Frame Icon 

 Insert Movie and Sound Icon 

 Insert OLE Object Icon 

 Insert Applet Icon 

 

Insert Chart Icon 

This icon is used for presenting the data in the worksheet in from of charts of different kinds such as 

Bar Chart, Pie Chart, Lines, XY plot, etc. More details on charting are given in a later section. 
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Insert Formula Icon 

This icon is used for inserting a formula in the worksheet for performing calculations. 

 

Insert Floating Frame Icon 

This icon provides to generate a scrolling screen within a worksheet. 

Insert Movie and Sound Icon 

This icon is used to insert sound or video files into the current worksheet. 

 

Insert OLE Object Icon 

This icon is used to insert objects from other application into a worksheet. 

 

Insert Applet Icon 

This icon is used to import Applets written in Java programming language into the worksheet. 

 

3. What are functions? How can you use them in your worksheet? Explain with examples 

Star Office Calc has a wide variety of functions that allow you to perform several frequently 

done calculations. Functions are predefined formulae that are available in Star Office Calc.  

(Insert→Function) 

 

The Function Wizard dialog box appears. A list of all functionsis displayed in the Function box 

when all is selected in the Categorybox. If a category is selected (e.g. Mathematical) the functions 

relatedto that category alone will be displayed in the function box. 

 

Function Wizard Window 
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The Function Wizard shortcut icon on the formula bar can also be used to select and insert 

functions. 

One of the most commonly used functions is the Sum function.  

This function calculates the sum of a given set of numbers. To use this function, you can 

either click on the Function Wizard icon or then select SUM or you can just click on the Sum icon 

on the formula bar. 

 

4. How will you insert chart in a worksheet? 

The purpose of chart is to visually present the data for easy understanding.  

STEPS TO INSERT CHART: 

 Select the data you want to chart. 

 Click on Insert → Chart or click on the Insert Chart icon. 

 

 The cursor becomes a + sign with a small picture of the graph. Place this cursor where you want 

to insert the chart and click. 

 It prompts you to enter the area in the worksheet to be charted. Enter the range and click Next. 

 The next window, displays the different types of charts that can be created along with a preview 

of each. Select the type of chart in which you want to present the data. Click on Next. 

 In the next window you have provisions to give a Title for the chart, Titles for X and Y axes and 

legends. 

 Click on Create. 

 

5. How can you generate a series of values?  Explain with example? 

Fill command to generate a series of data directly from the values of the selected cells. First, select 

the cells of the worksheet that you want to fill. Choose the command Edit→ Fill→ Series. 
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To Generate the Series as 16,32,……………….2048 

 Select the range from B1 to B20 

 Click Edit→Fill→Series 

 Select Series Type as Growth 

 Enter the StartValue as 16 

 Enter the EndValue as 2048 

 Enter the Incrementvalue as 2 

 Click OK button 

If you want to generate the series, first enter the value as 16 and choose Edit→ Fill→ 

Seriesand choose the Series Type as Growth, and enter the End value as 2048 and the 

Increment Value as 2. 

To Generate the number series 33,30………………3 

 Select the range from C1 to C20 

 Click Edit→Fill→Series 

 Select SeriesType as Linear 

 Enter the StartValue as 33 

 Enter the EndValue as 30 

 Enter the IncrementValue as -3  

 Click OK button 
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CHAPTER – 7 

DATABASE 

1. Explain the Manipulations of the Database? 

 Searching 

 Sorting 

 Merging 

 Performing Calculations on data 

 Filtering 

 Editing the database 

 Report Generation 

Searching 

 Searching is a process to select a desired specific data from a database.  

 For example, you want to select the student ranking first in a class with respect to the total marks 

or in individual subjects or you want to see the performance of a particular student.  

 Searching is done using database commands on the relevant fields. 

Sorting 

 Sorting is the process of arranging the data in a table in some order.  

 For example, we may arrange the list of staff – members in an alphabetical order or according to 

the seniority in position or date of joining or in any other order we like. 

 In the case of the student database, you may sort the passed students and failed students 

separately or you may sort the students in the ascending or descending order of their total marks, 

and so on. 

Merging 

 Merging is a process of joining data from two or more tables of the same or different databases.  

 For example, in a student database, you may have mark lists for different classes. You want to 

prepare one table that shows all the first ranking students of each class.  

 For this purpose, you can independently search in each table to select the first rank student from 

each class and merge all the names together in a single file/table. 

Performing Calculations on data 

 You may do any kind of arithmetic calculations on the data stored in the database.  

 For example, to obtain the total marks of all the subjects of a student, you may add the marks in 

the concerned fields of the database and store them in a separate field. 

Filtering 

 There are times when viewing the entire table is unwieldy.  

 Using a Filter is a way of limiting the information that appears on screen.  
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 Filters are a feature for displaying and browsing a selected list or subset of records from a table. 

The visible records satisfy the condition that the user sets. Those that do not satisfy the condition 

are hidden. 

Editing the Database 

 Editing is a process of performing corrections on the existing data, deleting the existing data, 

field(s), or record(s), adding new data, field(s), and record or changing the format of the 

database, and so on. 

Report Generation 

 You may generate any desired report, from the data of the database.  

 For example, in the case of student database, you may generate a report of all the students who 

have scored marks less than the minimum marks required for a pass, and another report that gives 

the list of passed students, and so on. 

 

2. Explain the Different Database Types? 

Based on the conceptual structures, the databases can be classified as follows: 

 Flat – File database 

 Relational database 

 Hierarchical database 

 Network database 

 Object-Oriented database 

Flat – File Database 

 A database file that consists of a single data table is a Flat-file database.  

 Flat-file database can be quite useful for certain single user or small-group situations, especially 

for maintaining lists such as address lists or inventories.  

 Spreadsheet is another example of a flat-file database. 

 They do not allow for more complex requests. 

 However, very often you need to process more extensive information from multiple data tables 

which is not possible in flat-file databases. 

Relational database 

 A relational structure represents a database made up of a set of related tables.  

 In a relational database, one or more common fields existing in two or more tables create a 

relationship between these tables.  

 The common field or fields are called the Keys. 

 A primary key is a key that uniquely identifies a record in a database table. 
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 Emp.No. is a primary key in the employee database, since it uniquely identifies an employee 

record. 

 The relational database structure is the most prevalent database in today’s business organizations. 

Hierarchical database 

 The hierarchical database structures were primarily used on Main Frame computers. 

 In hierarchical databases, records are organized in a tree like structure by type.  

 The relationship between record types is said to be a parent-child relationship, in which any 

child type relates only to a single parent type. 

Network database 

 The Network database is very similar to the hierarchical structure except that any one record type 

can relate to any number of other record types. 

Object oriented database 

 An Object Oriented database is a newer structure 

 The object oriented structure groups data items and their associated characteristics, attributes, and 

procedures into complex items called objects. 

 An object is defined by its characteristics, attributes and procedures.  

 An object’s characteristics can be text, sound, graphics, and video.  Examples of attributes might 

be colour, size, style, quantity, and price.  

 A procedure refers to the processing or handling that can be associated to the object. 
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